A
g

*
*
*

T

*
*
*

European
Commission

:rRUS

OPErmICUS

,.& e,

TRAINING KIT - LAND10

RICE MAPPING WITH SENTINEL-1
Case Study: Vietham, 2018

/8\ Se rCQ muovems ﬁ

ALONG-TRACK



Gpernicus

Research and User Support for Sentinel Core Products

The RUS Service is funded by the European Commission, managed by the European Space
Agency and operated by CSSI and its partners.

Authors would be glad to receive your feedback or suggestions and to know how this
material was used. Please, contact us on training@rus-copernicus.eu

Cover images produced by RUS Copernicus

The following training material has been prepared by Serco Italia S.p.A. within the RUS
Copernicus project.

Date of publication: April 2019

Version: 1.1

Suggested citation:

Serco Italia SPA (2019). Rice Mapping with Sentinel-1 — Case Study: Vietnam 2018 (version
1.2). Retrieved from RUS Lectures at https://rus-copernicus.eu/portal/the-rus-library/learn-

by-yourself

This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0
International License.



mailto:training@rus-copernicus.eu
https://rus-copernicus.eu/portal/the-rus-library/learn-by-yourself/
https://rus-copernicus.eu/portal/the-rus-library/learn-by-yourself/
http://creativecommons.org/licenses/by-nc-sa/4.0/
http://creativecommons.org/licenses/by-nc-sa/4.0/
http://creativecommons.org/licenses/by-nc-sa/4.0/

Table of Contents

1
2
3

4
5
6

7

INErOUCTION £0 RUS ...ttt st s e st e e sab e e sab e e sateesneeesaree s 4
Rice Mapping — back@rouUnd ........ooo i s 4
101 0= SO PP PP PPP ORI 4
3.1 DAt USEA....ueiieeieiet ettt sttt et b e sttt e bt e sh e sae e st st e e an e neennes 4
3.2 Software in RUS @NVIFONMENT ......iiiiiiiiiiiieieeeeeeriee ettt ettt s 4
REISTEr t0 RUS COPBINICUS ..coeieieee et e e e e e e e e e e e e e e e e e e e e e e e e e eeeeeas 5
Request a RUS Copernicus Virtual Maching.........ooocuiiiiiiiiieciiiiec ettt 6
Y =T ol o1V =T o PSR 10
6.1 Data download — ESA SCIHUB..........ciiiiiiiieete ettt ettt st e s e e saree s 10
6.2 DOWNIOAA LA ..ttt sttt ettt e b e sttt sttt e b e b e eaeeenrean 11
6.3 Sentinel-1 SNAP GPT PreproCESSING.......uueieciieeeeiiieeeeiiteeeeitreeeessseeessseeeeessseeesssssessssssseeanns 13
6.3.1 2 CT: [o [T PPN PP PPTPPPUPPRPONt 14
6.3.2 APPIY OFDIt FIlE e e 14
6.3.3 Thermal NOiS@ REMOVAL........cooiiiiiiiiiiieieeeee ettt 15
6.3.4 CaliBration ...ee et st e bbb e e s beeesaree s 15
6.3.5 TeIrain COMTECTION ... eeiiiiiiiie ettt e s 16
6.3.6 SUBDSEE ettt ettt b e s h e sttt e b b ns 17
6.3.7 VU ettt ettt et r e r e s s an e e r e n e s 18
6.3.8 Graph Processing TOOI | GPT...cccuiiiiieeciee ettt et eteeestre e s te e e tee e sre e eeaae e sareeenaeesaree s 18
6.3.9 BatCh PrOCESSING...ciuiviii ittt et e e e s e e et e e e s eaba e e e s b ae e e e nareeas 21
B.3. 10  SEACK ceeeeteetiee ettt ettt b e bt st sabe et e beens 25
6.3.11  Multi-temporal speckle filteriNG........c.ueeeieciiei e e 26
6.3.12  Decibel transformation ........c.cooi oo s 27
6.4 QUGS et b e sttt et r e h e sae e s an e s r e nes 28
6.4.1 Sigma NaUght @VOIULION ..ccceeiiie e e e raaaeeeeas 28
6.4.2 QUGS PrOCESSING . uuvitiieitiiiiiiiitteee e e e sttt e e e e s s ssartreeeessssssbabaaeeeeesssssssrseaaeeesssssnsssnnaeeees 30
Further reading aNd FESOUICES .....uuiiii ittt e ettt e e e e e eeer e e e e e e s esrebreeeeaeeessnsrsaeeeeeeeesnnsenns 34



1 Introduction to RUS

The Research and User Support for Sentinel core products (RUS) service provides a free and open
scalable platform in a powerful computing environment, hosting a suite of open source toolboxes
pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel
satellites constellation.

In this tutorial, we will employ RUS to detect rice using a dense time-series of Sentinel-1 GRD
products as input data over an area in Vietnam.

2 Rice mapping — background

H,_-' According to the International Rice Research Institute

(IRRI), rice, wheat, and maize are the three leading food

crops in the world; together they directly supply more
than 50% of all calories consumed by the entire human

population. Wheat is the leader in area harvested each

year with 214 million ha, followed by rice with 154
million ha and maize with 140 million ha. Human
consumption accounts for 85% of total production for

rice, compared with 72% for wheat and 19% for maize.

X
Rice fields in the south of Spain ~ Rice is also the most important crop to millions of small
farmers who grow it on millions of hectares throughout the region, and to the many landless workers

who derive income from working on these farms.

A few years ago, the European Union (EU) started an ambitious program, Copernicus, which includes
the launch of a new family of earth observation satellites known as Sentinels. Amongst other
applications, this new generation of satellites will improve the identification, mapping, assessment,
and monitoring of crops and their dynamics at a range of spatial and temporal resolutions.

3 Training
Approximate duration of this training session is two hour.

The Training Code for this tutorial is LAND10. If you wish to practice the exercise described below
within the RUS Virtual Environment, register on the RUS portal and open a User Service request
from Your RUS service > Your dashboard.

3.1 Data used

* 24 Sentinel-1A images acquired from March until December 2018 [downloadable at
https://scihub.copernicus.eu/ using the .meta4 file provided in the Original folder of this

exercise]

. Pre-processed data stored locally
@/shared/Training/LAND10_RiceMapping_Vietnam/AuxData/

3.2 Software in RUS environment

Internet browser, SNAP + GPT + S1 Toolbox + QGIS


https://scihub.copernicus.eu/

4 Register to RUS Copernicus

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as
a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on

Login/Register in the upper right corner.

T = . $ . i p . 6 g 3 - N=C A

Login/Register &

v News from RUS

One year on!

Copernicus Info Session - Reykjavik - 19 September 2018

SPIE Remote Sensing 2018 - Berlin (Germany) - 11-12
September 2018

SIWI World Water Week 2018 - Stockholm - 26-31
August 2018

MedRIN Kick-off Meeting - Chania - 13 & 14 July 2018

00000 0000 RUS Webinar - Special edition “AskRUS - Sentinel-1” - 12

July 2018

v Welcome to Rese: User Support RUS Training Session - Valencia - 22 July 2018

IGARSS 2018 - Valencia - 22-27 July 2018

Welcome to the Copernicus Research and User Support (RUS) Service portal!

v The RUS agenda

The RUS Service is the “New Expert Service for Sentinel Users” funded by the European Commission, Conferences & Workshops

fihandeed hv/the Furanean Snace Acsency and anerated by CS Sl and its nartner:

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus
Users’ Single Sign On Registration. Click Register.

Login / Register

Registered RUS users, as well as persons who already own

a Copernicus SSO account, can directly access our service.
Rogistration form
T se °
Login ’ o
e E "
°
°
Newcomers shall first create an account on the Copernicus Single Sign-On (SSO) :
authentication server used to support registration to the RUS service. °
°
@
Create my Copernicus SSO account °
M
NB: persons using a Google e-mail address for registration shall check
their mailbox spam folder regularly as Google tends to filter RUS e-mails. ]

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-
mail to activate your account.

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter
your chosen credentials.



http://www.rus-copernicus.eu/
https://rus-copernicus.eu/

Login / Register Credentials

The registration system to access the RUS service platform has moved toward the
COPERNICUS Single Sign On authentication server. CDS-SS0 1D 9

* New Users who have not yet registered to the RUS portal shall first create a

COPERNICUS SSO account. Password o
Note that your Copernic SO account will be activated only after the reception of
the third email sent by the Copernicus service. We advise you to consult this document . half a da v
and this page to facilitate your registration procedure Max Idle Time i o
REGISTER COPERNICUS Max Session Time | Until browser close ASL 7 ]
550 account
Users who already have a COPERNICUS S50 account can login here: Login Reset

Forgot your password?

Upon your first login you will need to enter some details. You must fill all the fields.

Do you want to subscribe for a new RUS account?

Your ESA-SSO subscription data:

Additional subscription information

Please complete the following information:

uhear about the  outreach event
colleagues
newsletter
conference
social media
other
Select one it

+39

~ Select one item --

5 Request a RUS Copernicus Virtual Machine

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise
or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service 2>
Your Dashboard.

(emes User Support

Hello, Miguel &

@3 The RUS Service ¥ The RUS Offer v The RUS Library ¥ The RUS Community ¥ -

A Your profile

You are here: Home > Your RUS service

&1 Your training B
This section gathers pages related to your RUS services:

= Your profile: displays your personal information linked to your ESA SSO and RUS accounts,
One year on!

--Hows you to access your private dashboard, Copernicus Info Session - Reykjavik - 19 September 2018

SPIE Remote Sensing 2018 - Berlin (Germany) - 11-12
= Your training: allows you to register to a training session you have been invited to participate in. September 2018

SIWI'World Water Week 2018 - Stockholm - 26-31
August 2018

MedRIN Kick-off Meeting - Chania - 13 & 14 July 2018

RUS Webinar - Special edition “AskRUS - Sentinel-1" - 12
July 2018

RUS Training Session - Valencia - 22 July 2018

IGARSS 2018 - Valencia - 22-27 July 2018




Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that
the appropriate cloud environment can be assigned according to your needs.

@; RUS Research and

User Support

-
@E_ﬂ The RUS Service v The RUS Offer v The RUS Library ¥ The RUS Community ¥ g Your RUS service ¥

Hello, Miguel &

You are here: Home > Your RUS service > Your dashboard

v Your dashboard

|E%| Request a new User Service ‘} Chat with Support Desk

Copyright © 2017 Research and User Support

Contact Us  Termsand conditions  Glossary ~Acronyms FAQ

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the
appropriate field.

v User Support Request

Step 1/3 Your experience

Please help us learn more about your background by answering a few questions. This
information will be stored in your User Profile.

How many years of experience in Remote Sensing do you have?

Choose one item... v

Have you already downloaded Copernicus data via the Copernicus Open access hubs?
® Yes

No

Have you already handled/processed Copernicus data?
®Yes

O No

Do you wish to practice a tutorial exercise shown in a RUS webinar? If yes, please select your choice
(hold down CTRL key for multiple selections).

HAZAO1 - Flood Mapping in Malawi a
HAZAO2 - Burned Area Mapping in Portugal

HYDRO1 - Water Bodies Mapping over Northern Poland

LANDO1 - Crop Mapping in Seville

LANDO4 - Land Monitoring in Cyprus

OCEAO1 - Ship Detection in Gulf of Trieste v

If you wish to request another tutorial exercise that doesn't appear in the above list, please type here
its name or code. Note that you can request multiple tutorial exercises.

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your
request once you are finished.



» User Support Request

Summary information on your request:

This is a collection of information selected across the USR forms.
You can go back and edit this information if necessary.

General information on your request:
Years of experience in Remote Sensing 5-10years

Downlozded Copernicus data? 7
Handled/processed Copernicus data? J
Webinar codes HAZADZ, LANDOS

About your RUS project:
Thematic area Cryosphere (ice and snow)
Ciperations to perform on RUS Algorithm development
Preference for downloading process Self-downloading
Foreseen activities and support needs Develop 2lznd cover dassification
Project name RUS Project1

Earth Observation Data information:
Type of Earth Observation Data:
Sentinel-1 <
S1-Product 1
51- Product type GRD
51- Sensor mode
51- Polarisation
51- Orbit direction
Sentinel-2
Sentinel-3
Other
I don’t know
Region of interest:
Min Latitude 39.3303
Max Latitude 405877
Min Longitude -4.6736
Max Longitude -27205
Reference polyzons

R A 4

Data acquisition date(s):
None
Additional data specifications

O | have read and agree to the Terms and conditions of RUS Service.

Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email
with all the details about your Virtual Machine. To access it, go to Your RUS Service = Your
Dashboard and click on Access my Virtual Machine.

GF RUS Researchons SugeLy &9

Hello, Miguel 2

@E-.: The RUS Service v The RUS Offer ¥ The RUS Library ¥ The RUS Community v % Your RUS service v
You are here: Home > Your RUS service > Your dashboard
v Your dashboard

| =°| Request a new User Service 6) Chat with Support Desk

f Date of 3 . q

Project Name ID i Status Actions Virtual Environment
) submission
. . Access my CPU
Follow my project Get support Close my service monitoring dashboard
RUS_trainingl 231 2017-08-31 Open .
Get awebinar kit Rate my service Freeze my Virtual Report a technical
% ¥ % k& Machine(s) incident
Copyright © 2017 Research and User Support ContactUs  Terms and conditions ~ Glossary ~Acronyms ~ FAQ




Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access

your RUS Copernicus Virtual Machine.

C' A Notsecure | htps://usr-231.rus-copernicus.eu/#/

APACHE GUACAMOLE

S

| Username

| Password

]

This is the remote desktop of your Virtual Machine.




6 Step by step

6.1 Data download - ESA SciHUB

Before starting the exercise, make sure you are registered in the Copernicus Open Access Hub so that
you can access the free data provided by the Sentinel satellites.

Go to https://scihub.copernicus.eu/

S Late
Welcome to the Copernicus Open Access Hub

The Copernicus Open Access Hub (previously known as Sentinels Scientific Data Hub) provides complete, free and open access to Sentinel-1,
Sentinel-2 and Sentinel-3 user products, starting from the In-Orbit Commissioning Review (IOCR).

-3 5
oo 7 .

a; o ld e P

/ QY e .

Yo SR v N4

» <3 =

Open Hub API Hub S-3 PreOps Hub S-5P PreOps Hub GNSS Hub

User Guide (7} Open Source Portal ﬂ Reports & Stats
? mi o :

Open Access Hub - access point for all Sentinel missions with access to the interactive graphical user interface.

API Hub - access point for APT users with no graphical interface. All APT users reqularly downloading the latest data are encouraged to use this access point for a
better performance

Sentinel-34 Pre-operational Hub - pre-operational access point for 2l users to Sentinel-3 L1 and L2 Land data. Login credentials are s3guest:s3guest
Sentinel-5P Pre-operational Hub - pre-operational access point for 3l users to Sentinel- 5P L18 and L2 data. Login credentials are sSpguest:sSpguest

Go to Open Hub. If you do not have an account, sign up in the upper right corner, fill in the details
and click register.

Copernicus Open Access Hub

Register new account
Sentinel data access is free and open to all.

On completion of the registration form belaw you wil receive an e-mail with a link 1o validate your e-mail address. Foliowing this you can start lo download the data
Usemame field accepts only aiphanumeric characters phus ", %, *_* and

Salect Domain

Select Country

By registering in this website you are deemed to have accepted the TAC for Sentinel data use.

You will receive a confirmation email on the e-mail address you have specified: open the email and
click on the link to finalize the registration.

Once your account is activated — or if you already have an account —log in.
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6.2 Download data

In this exercise, we will analyze 24 Sentinel-1A images during 2018. The following table shows the
date and reference of the images that will be used:

SATELLITE ” DATE || IMAGE ID

2018-03-07 S1A_IW_GRDH_1SDV_20180307T224528_20180307T224553_020915_023E2F_F92F

2018-03-19 S1A_IW_GRDH_1SDV_20180319T224528_20180319T224553_021090_0243B4_2FEF

2019-03-31 S1A_IW_GRDH_1SDV_20180331T224528_20180331T224553_021265_024942_546B

2018-04-12 S1A_IW_GRDH_1SDV_20180412T224529_20180412T224554_021440_024EB3_0516

2018-04-24 S1A_IW_GRDH_1SDV_20180424T224529_20180424T224554_021615_025428_1B32

2018-05-06 S1A_IW_GRDH_1SDV_20180506T224530_20180506T224555_021790_0259B4_0789

2018-05-18 S1A_IW_GRDH_1SDV_20180518T224530_20180518T224555_021965_025F45_05AD

2018-05-30 S1A_IW_GRDH_1SDV_20180530T224531_20180530T224556_022140_0264E6_8978

2018-06-11 S1A_IW_GRDH_1SDV_20180611T224532_20180611T224557_022315_026A59_BBF6

2018-06-23 S1A_IW_GRDH_1SDV_20180623T224532_20180623T224557_022490_026F94_1CAQ

2018-07-05 S1A_IW_GRDH_1SDV_20180705T224533_20180705T224558_022665_0274AF_03A1

) 2018-07-17 S1A_IW_GRDH_1SDV_20180717T224534_20180717T224559_022840_027A09_D025
Sentinel-1A

2018-08-10 S1A_IW_GRDH_1SDV_20180810T224535_20180810T224600_023190_02850C_4510

2018-08-22 S1A_IW_GRDH_1SDV_20180822T224536_20180822T224601_023365_028AB2_F68E

2018-09-03 S1A_IW_GRDH_1SDV_20180903T224537_20180903T224602_023540_029043_3D7A

2018-09-15 S1A_IW_GRDH_1SDV_20180915T224537_20180915T224602_023715_0295DF_3261

2018-09-27 S1A_IW_GRDH_1SDV_20180927T224537_20180927T224602_023890_029B8C_2691

2018-10-09 S1A_IW_GRDH_1SDV_20181009T224538_20181009T224603_024065_02A150_C5FB

20181021 || S1A_IW_GRDH_1SDV_20181021T224538_20181021T224603_024240_02A700_E03C

2018-11-02 S1A_IW_GRDH_1SDV_20181102T224538_20181102T224603_024415_02ACCD_DD65

2018-11-14 S1A_IW_GRDH_1SDV_20181114T224537_20181114T224602_024590_02B33B_A620

2018-11-26 S1A_IW_GRDH_1SDV_20181126T224537_20181126T224602_024765_02BSAA_C6AC

2018-12-08 S1A_IW_GRDH_1SDV_20181208T224536_20181208T224601_024940_02BF81_757D

2018-12-20 S1A_IW_GRDH_1SDV_20181220T224536_20181220T224601_025115_02C5D5_0E2A

To improve the data acquisition process, we will use a download manager (See " | NOTE 1) that will
take care of downloading all products that will be used. The metadata of the Sentinel products are
saved in a products.meta4 file created using the ‘Cart’ option of the Copernicus Open Access Hub.

»

NOTE 1: A download manager is a computer program dedicated to the task of downloading possibly
unrelated stand-alone files from (and sometimes to) the Internet for storage. For this exercise, we will
use aria2. Aria2 is a lightweight multi-protocol & multi-source command-line download utility. More
info at: https://aria2.github.io/

The products.meta4 file containing the links to the Sentinel-1 products to be downloaded can be
created following the methodology explained in " | NOTE 2. Follow the instructions and create your
cart file, download it and save it in the following path:

Path: /shared/Training/LAND10_RiceMapping_Vietnam/Original/
11
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Before using the downloading manager and the .meta4 file, let’s test if aria2 is properly installed in

the Virtual Machine. To do this, open the Command Line (in the bottom of your desktop window)
and type the following and press Enter:

aria2c

If aria2 is properly installed, the response should be as follows. If the response is ‘-bash aria2c:
command not found’ it means aria2 is not installed (See " INOTE 3).

ﬂ Terminal - rus@front-usr-231: ~

File Edit View Terminal Tabs Help

rus@front-usr-231:~$ aria2c

Specify at least one URL.

Usage: aria2c [OPTIONS] [URI | MAGNET | TORRENT FILE | METALINK FILE]...

|-u-=||£|?,\'\.

‘aria2c -h'
rus@front-usr-231:-%

"1 NOTE 2: The Copernicus Open Access Hub allows you to add products to a ‘Cart’. For that, perform a
query; select the desired products from the result list and click on the ‘Add Product to Cart’ icon - ®. To
find the appropriate images, copy-paste the image ID specified in the table (pg. 11) in the search box of
the Copernicus Open Access Hub.

BN EXEEs1a 1w GRDH_1SDV_20181220T224536 20181220T224601 025115 02¢... O
s Download URL t 1 I u/dht lata/v1/Pr S i464-5e5d-441
%‘j Mission: Sentinel-1 Instrument: SAR-C Sensing Date: 2018-12-20T22:45:36.548Z Sjze: 1
P o® e
l_l -@8a  opemicus Copernicus Open Access Hub 20n
- @ . —— o
S e e (]
ESE G 51 1_GROW_15DV_201804127224529 201804127224554 021440 024E..0) 8
I A 16 1w _GROM 1SDV_201804307224449_201004307224514 010719 0139..0
ERE 15 v cow 1oV SorsosisTiaesas isoereraaeia sioses s 0 [0 v........‘.,fc o
|y
BRI EEEs1A W _GROH_15DV_201804247224529_201804247224554 021615 0254.0 B
o e | -
S 5 15_w_GAOW_150V_ 20180406V 224449 _20180406T224524_ 010369, 0126..0 ‘ el (e o o R g R apvin
B _f i X s B .,: - e
Products per page: (25 ¥ page:| 1 |of1 s v ¥ 4y e ¢ Lo s s pstia’] | 1
To view the products present in the cart just click anytime car icon - =] . on the top left corner of the
screen. To download the cart click on "Download Cart" on the bottom right of the page. A download
window will pop up, asking the user confirmation to save a .meta4 file named ‘products.meta4’. This file
contains all the metalinks of the products.
" NOTE 3: If (and only if) the response is -bash aria2c: command not found’, you need to install aria2. In
the command line, type: sudo apt-get install aria2
When requested, type: Y
Once finished, test the installation as explained before.

12



Once aria2 is ready to use, we can start the download process. For that, we need to navigate to the
folder where the products.meta4 file is stored. Type the following command in the terminal and run
it (press Enter).

cd /shared/Training/LAND10 RiceMapping Vietnam/Original/

- Terminal - rus@front-usr-231: /shared/Training/LAND10_RiceMapping_Vietnam/Original c=lrs

File Edit View Terminal Tabs Help
rus@front-usr-231:~% cd /shared/Training/LAND10 RiceMapping Vietnam/Original/

rus@front-usr-231:/shared/Training/LAND1O@ RiceMapping Vietnam/Original$

Next, type the following command (in a single line) to run the download tool. Replace username and
password (keep the quotation marks) with your login credentials for Copernicus Open Access Hub
(COAH). Do not clear your cart in the COAH until the download process is finished.

aria2c --http-user='username' --http-passwd='password' --check-certificate=
false --max-concurrent-downloads=2 -M products.metad

The Sentinel products will be saved in the same path where the products.meta4 file is stored.

6.3 Sentinel-1 SNAP GPT Preprocessing

Once the Sentinel-1 images are downloaded, we need to run some pre-processing steps before they
can be used for our final purpose. For this, we will use the SNAP software. In Applications ->

Processing open SNAP Desktop; click Open product li, navigate to the following path and open the
first S1 image (2018-03-07).

Path: /shared/Training/LAND10_RiceMapping_Vietnam/Original/

The opened product will appear in Product Explorer. Click + to expand the contents of the first image,
then expand the Bands folder and double click on Amplitude_VH to visualize it. (See " INOTE 4).

] SNAP [FaE

File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help Q-
a§ PalQ Por Wl ®O w2z @2 XE®x roaAAERNYE@ R

Product Explorer X | Pixel Info & @ (1) Amplitude_VH x [«]¥]]~][O]
¢ @ [1] S1A_W_GRDH_1SDV_20180307T224528_20180307T224553
o [ Metadata
o (@ Vector Data
o @ Tie-Point Grids
o @ Quicklooks
¢ & Bands
B Amplitude v 4@
[ intensity VH
B Amplitude W
[ intensity W

AlRJqr 3nposd

< i | D

Navigation - [1] Ampl... | Colour Manipulation .. |World Map x| &

Jabeuep xsen §y | | [Buuouuon iov @

Jabeuey Joken )

X 5640 Y 5672 |Lat10°06'31"N Lon 106°21'01" E| Zoom 1:25.3 Leveld (@

To process this and the other Sentinel-1 images, we will take advantage of the batch processing
option available in SNAP GPT. In this way, we can define a specific processing chain and apply it to

13



several images in an automatic way. This allows reducing processing time and storage requirement
since no intermediate steps are created. Only the final product is physically saved.

Before running batch processing, it is necessary to create a graph containing all the processing steps.
Go to Tools -> Graph Builder. So far, the graph only has two operators: Read (to read the input) and
Write (to write the output). By right-clicking on the white space at the top panel, you can add an
operator while a corresponding tab is created and added at the bottom panel. To avoid confusion,
right click on the Write operator and delete it.

Add >

Connect Graph

6.3.1 Read

By default, Graph Builder will use the image we have previously opened in SNAP as the input image
for the processing chain. Since we will be changing this parameter later in GPT, there is no need to
change anything.

| Read I

Source Product

Mame:

|[l] S1A W _GRDH_1SDV_20180307T224528_20180307T224553_020915_023E2F_F92F w || ..

Data Format: Amy Format |«

6.3.2 Apply orbit file

The first step of our Sentinel-1 pre-processing chain will update the orbit metadata (See " I NOTE 4)
of the product to provide accurate satellite position and velocity information. To add the operator to
our graph, right click and navigate to Add -> RADAR -> Apply-Orbit-File. Connect the new Apply-Orbit-
File operator with the Read operator by clicking to the right side of the Read operator and dragging
the red arrow towards the Apply-Orbit-File operator. In the corresponding tab, check the option Do
not fail if new orbit file is not found.

»

NOTE 4: The orbit state vectors provided in the metadata of a SAR product are generally not accurate
and can be refined with the precise orbit files, which are available days-to-weeks after the generation
of the product. The orbit file provides accurate satellite position and velocity information. Based on this
information, the orbit state vectors in the abstract metadata of the product are updated. (SNAP Help)

‘ Read HAppIy-orblt-Flle |

Read l Apply-Orbit-File I

Orbit State Vectors:|gentine| Precise (Auto Download) -

Polynomial Degree: |3

m [v] Do not fail if new orbit file is not found
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6.3.3 Thermal Noise Removal

Next, we will remove the thermal noise (See " I NOTE 5). To add the operator to our graph, right click
and navigate to Add -> RADAR -> Radiometric -> ThermalNoiseRemoval. In the corresponding tab,
leave all the parameters for this operator as default. Connect the ThermalNoiseRemoval operator
with the Apply-Orbit-File operator by clicking to the right side of the Apply-Orbit-File operator and
dragging the red arrow towards the ThermalNoiseRemoval operator.

NOTE 5: Thermal noise in SAR imagery is the background energy that is generated by the receiver itself.
(SNAP Help) It skews the radar reflectivity to towards higher values and hampers the precision of radar
reflectivity estimates. Level-1 products provide a noise LUT for each measurement dataset, provided in
linear power, which can be used to remove the noise from the product.

| Read HApply-nrhlt-Flll Hmermlll\lnlseumnll

_ Read | Apply-Crbit-File | ThermalNoiseRemovall

Polarisations: WH
W
[¥] Remove Thermal Noise

[] Re-Introduce Thermal Noise

6.3.4 Calibration

Now, we can perform the Radiometric calibration. The objective of SAR calibration is to provide
imagery in which the pixel values can be directly related to the radar backscatter. Though
uncalibrated SAR imagery is sufficient for qualitative use, calibrated SAR images are essential to
guantitative use of SAR data (See " | NOTE 6). To add the operator to our graph, right click and
navigate to Add -> RADAR -> Radiometric -> Calibration. In the corresponding tab, leave all the
parameters for this operator as default. Connect the Calibration operator with the
ThermalNoiseRemoval operator by clicking to the right side of the ThermalNoiseRemoval operator
and dragging the red arrow towards the Calibration operator.

| Read HApply-orblt-FlleHmermnll\l i 'HCallt ti |

NOTE 6: Typical SAR data processing, which produces level-1 images, does not include radiometric
corrections and significant radiometric bias remains. The radiometric correction is necessary for the
pixel values to truly represent the radar backscatter of the reflecting surface and therefore for
comparison of SAR images acquired with different sensors, or acquired from the same sensor but at
different times, in different modes, or processed by different processors. (SNAP Help)

15



Read Apply-Orbit-File | ThermalNoiseRemoval rCalibration |

Polarisations: WVH
Vv

1 e e tout
[w] Output sigma0 band

| Output gammal band

| Output beta0 band

6.3.5 Terrain correction

Our data are still in radar geometry, moreover due to topographical variations of a scene and the tilt
of the satellite sensor, the distances can be distorted in the SAR images. Therefore, we will apply
terrain correction to compensate for the distortions and reproject the scene to geographic projection
(See " | NOTE 7). To add the operator to our graph, right click and navigate to Add -> RADAR ->
Speckle Filtering -> Speckle-Filter. In the corresponding tab, make sure you select UTM / WGS 84
(Automatic) as Map Projection. Uncheck the option Mask out areas without elevation (this option is
only for visualization purposes). Connect the Terrain-Correction operator with the Calibration
operator by clicking to the right side of the Calibration operator and dragging the red arrow towards
the Terrain-Correction operator.

| Read HMply-orhh-Flle HThelmaanIsellemnvaI H Calibration H Terrain-Correction |

NOTE 7: The geometry of topographical distortions in SAR
imagery is shown on the right. Here we can see that point B
with elevation h above the ellipsoid is imaged at position B’ in
SAR image, though its real position is B". The offset Ar
between B' and B"exhibits the effect of topographic
distortions. (SNAP Help)

i Read |” Apply-Orbit-File | ThermalNoiseRemoval | Calibration lTerrain-Currect\on I

Source Bands: Sigma0_vH
Sigma0_wW
Digital Elevation Model SRTM 3Sec (Auto Download) [+
DEM Resampling Method: ‘B\UNEAR_INTERPOLAT\ON -
Image Resampling Method: ‘B\UNEAR_INTERPOLAT\ON -
Source GR Pixel Spacings (azx rg):  10.0(m) x 10.0(m)
Pixel Spacing (m) [100 J
Pixel Spacing (deg): [8.983152841195215€-5 |
Map Projection: ‘ WGSE4(DD) —
I [] Mask out areas without elevatlonl O output t L= Map Projection B
Output bands for: Coordinate Reference System (CRS)
[¥] Selected source band [] DEM [[] Latitude & Longitude @® [Custom CRS
[l Incidence angle from ellipsoid Local incidence angle [ ] Projected local incidence angle X
Geodetic datum: | ‘
[[] Apply radiometric normalization - rojection [ wGs 84 tautomatic) [~]
Os \ ol
O ‘ () Predefined CRS. ‘ l ‘
] sa band
i | ‘ cancel || nelp |
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6.3.6 Subset

To investigate the capabilities of the different polarizations to detect rice growth, we will save as
independent files the VV and VH polarizations. In this way we will be able to analyse the temporal
evolution of the backscatter coefficient for every channel independently. At the same time, we will
reduce the original extent of the image. This will reduce the size of the product and processing time.

For this, add two Subset operators. Right click and navigate to Add -> Raster -> Geometric -> Subset.
Next, connect the Subset and Subset(2) operators with the Terrain-Correction operator by clicking to
the right side of the Terrain-Correction operator and dragging the red arrow towards the Subset
operators.

| Read anply-Orblt-Flle HThermnlMolsenemwnl }—).I Calibration HTerraln-Correctlon Subset ‘

In the first Subset tab, select the band Sigma0_VH choose the option Geographic Coordinates. Paste
the following Well-Known Text to define to subset area. Then, click Update and visualize the area
(click on the zoom icon - ).

POLYGON ((104.97827895096175 10.312537866158335, 105.80329350853457 10.311540351754
259, 105.80185401875113 9.726089296805576, 104.97831787983566 9.727029083669775, 10
4.97827895096175 10.312537866158335))

In the second Subset(2) tab, select the band Sigma0O_VV and choose the option Geographic
Coordinates. Paste again the same Well-Known Text to define to subset area. Then, click Update and
visualize the area by clicking on the zoom icon.

Read | Apply-Orbit-File ThermalNoiseRemoval Calibration | Terrain-Correction l Subset ‘l Subset(2)

Source Bands Sigma0_VH

Sigma0_W

v| Copy Metadata

Pixel Coordinates |® Geographic Coordinates

77539062, 104.97827911376953 9.726089477539062, 104.97827911376953 10.312538146972656, 104.97827911376953] Update
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Read Apply-Orbit-File ThermalNoiseRemoval Calibration [ Terrain-Correction Subset l Subset(2) I

Source Bands Sigma0 VH

v| Copy Metadata

Pixel Coordinates [! Geographic Coordinates

1376953 9.726089477539062, 104.97827911376953 10

Update

312538146972656, 104.97827911376953 10.312538146972656)

6.3.7 Write

Finally, add the Write operators. Right click and navigate to Add -> Input-Output -> Write. Add two
Write operators. Although we will change the output name and output directory in GPT, to avoid
confusion set the output directory to the following path.

Path: /shared/Training/LAND10_RiceMapping_Vietnam/

| Read Hﬁpnly-orblt—ﬂleHThermnlMolsenemwnlHCallhratlonHTerraln-Cormdlonw‘setI»—>| Write |
| Subset(2) |—>{ Write(2) |

Read | Apply-Orbit-File | ThermalNoiseRemoval | Calibration | Terrain-Correction Subset | Subset(2) | Write | Write(2) |

Target Product

Name:
Subset S1A IW_GRDH_1SDV_20180307T224528_20180307T7224553_020915_023E2F F92F Orb_NR_Cal_TC

Save as: |BEAM-DIMAP -

Directory.

fhomefrus/shared/Trai ning L,iNDl-.'J_Rir,eMa nping_"."iefn am

I

J'h__: Load 3 Save ¥ Clear l }/Note ‘ @I Help | [~ Run

Once the graph is completed, click on the Save icon located on the lower part of the graph builder.
Navigate to the following path and save the graph as S1_Orb_Thm_Cal _TC sub.xml. After saving the
graph, close the Graph Builder window and SNAP.

Path: /shared/Training/LAND10_RiceMapping_Vietnam/AuxData/

6.3.8 Graph Processing Tool | GPT

In this exercise, we will use the SNAP GPT command line interface (which can be found in the bin
folder of the Sentinel Toolbox installation) to process our Sentinel-1 products. This tool is used to
execute SNAP raster data operators in batch-mode. The operators can be used stand-alone or
combined as a directed acyclic graph (DAG). Processing graphs are represented using XML files. Using
the GPT provides a convenient way to use operators in a headless environment or in batch mode
(See "I NOTE 8).
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NOTE 8: To run an operator using the GPT, it is necessary to indicate the path to the source product(s),
to the target product and to other operator-specific parameters which might be mandatory or specific.
As for complex operators the call from the command line can easily become confusing, it is also
possible to pass the required settings in form of a xml-encoded graph file. It will then suffice to just

pass the graph as parameter to the GPT.

To access GPT, open a Terminal window by clicking on its icon - H - write the following text and
press enter (See " I NOTE 9).

gpt

= Terminal - rus@front-usr-231: ~ Caelolf
File Edit View Terminal Tabs Help
rus@front-usr-231:~$ gpt
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing ex
ternal tool adapters

SEVERE: org.esa.s2tbx.dataio.gdal.activator.GDALDistributionInstaller: The envir|
onment variable LD_LIBRARY_PATH is not set. It must contain the current folder

Usége:
gpt <op>|<graph-file> [options] [<source-file-1> <source-file-2> ...]
Description:

This tool is used to execute SNAP raster data operators in batch-mode. The
operators can be used stand-alone or combined as a directed acyclic graph

(DAG) . Processing graphs are represented using XML. More info about
processing graphs, the operator API, and the graph XML format can be found
in the SNAP documentation.

JArguments:
<op> Name of an operator. See below for the list of <op>s.
<graph-file> Operator graph file (XML format).
<source-file-i> The <i>th source product file. The actual number of source
file arguments is specified by <op>. May be optional for
operators which use the -S option.

»

NOTE 9: Note that in the RUS Copernicus Virtual Machines, the gpt command is an environment
variable and can be called directly from the terminal. If this is not your case, you will have to set it or
specify the path to gpt to call the program.

To process our images in batch mode using GPT we need to change the input and output reference
to specific input/output files by variables (See " | NOTE 10). Navigate to the following path, right
click on the graph file (called S1_Orb_Thm_Cal_TC sub.xml) and select Open With -> Open with
Mousepad. Once the xml file is opened, click on View -> Line Numbers.

Path: /shared/Training/LAND10_RiceMapping_Vietnam/AuxData/

NOTE 10: The graph created in the Graph Builder tool in SNAP is an xml document that contains the
different operators that have been added. The xml document is structured in a way that all the
information of a specific operator is specified between the <node> and </node> tags.

In line 7, delete only the path to the input image highlighted in orange (do not remove <file> and
</file>) and write Sinput1. Line 7 should look like this (highlighted in green):

<file>$inputl</file>
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4

File Edit Search View Document Help
i<graph i‘d:‘;'G-rap-h“.:v . - o
2 <version>1.0</version>

3
4
5 <sources/>
6
7

8 </parameters>
9 </node>

51_Orb_Thm_Cal_TC_sub.xml - Mousepad

<node id="Read">
<operator>Read</operator>

<parameters class="com.bc.ceres.binding.dom.XppDomElement">
<file>/home/rus/shared/Training/LAND1® RiceMapping Vietnam/Original/
S1A_IW_GRDH_1SDV_20180307T224528 20180307T224553_020915_ 023E2F_F92F.zip</file>

K4

$1_Orb_Thm_Cal_TC_sub_GPT.xml - Mousepad oo B

File Edit Search View Document Help
1 <graph id="Graph">
2 <version>1.0</version>
3 <node id="Read">
4 <operator>Read</operator>
5 <sources/>
6 <parameters class="com.bc.ceres.binding.dom.XppDomElement">
7
8
9

<file>$inputl</file>
</parameters>
</node>

In line 143, delete only the path to the output image highlighted in orange (do not remove <file> and
</file>) and write Soutput2. Line 143 should look like this (highlighted in green):

<file>S$Soutput2</file>

R4 S1 Orb_Thm_Cal_TC sub.xml - Mousepad
File Edit Search View Document Help
137 <node id="Write(2)">

138 <operator>Write</operator>
139 <sources>
140 <sourceProduct refid="Subset(2)"/>
141 </sources>
142 <parameters class="com.bc.ceres.binding.dom.XppDomElement">
143 <file>/home/rus/shared/Training/LAND1® RiceMapping Vietnam/Processing/
Subset S1A_IW_GRDH_1SDV_20180307T224528 20180307T224553 020915 023E2F_F92F Orb_NR Cal TC.dim</file>
144 <formatName>BEAM-DIMAP</formatName>
145 </parameters>

146  </node>

K4 S§1 Orb_Thm_Cal_TC_sub_GPT.xml - Mousepad Mﬁ.
File Edit Search View Document Help
137 <node id="Write(2)">

138 <operator>Write</operator>

139 <sources>

140 <sourceProduct refid="Subset(2)"/>

141 </sources>

142 <parameters class="com.bc.ceres.binding.dom.XppDomElement">
143 <file>$output2</file>

144 <formatName>BEAM-DIMAP</formatName>

145 </parameters>

146 </node>

In line 153, delete the path to the output image highlighted in orange (do not remove <file> and
</file>) and write Soutputl. Line 153 should look like this (highlighted in green):

<file>S$Soutputl</file>

R4 S1 Orb_Thm_Cal_TC_sub.xml - Mousepad

File Edit Search View Document Help

147 <node id="Write">

148 <operator>Write</operator>

149 <sources>

150 <sourceProduct refid="Subset"/>

151 </sources>

152 <parameters class="com.bc.ceres.binding.dom.XppDomElement">

153 <file>/home/rus/shared/Training/LAND16 RiceMapping Vietnam/Processing/
Subset S1A IW GRDH_1SDV 20180307T7224528 20180307T7224553 020915 023E2F F92F Orb NR Cal TC.dim</file>

154 <formatName>BEAM-DIMAP</formatName>

155 </parameters>

156 </node>

K4 S1_Orb_Thm_Cal_TC_sub_GPT.xml| - Mousepad Mﬁ.
File Edit Search View Document Help
147 <node id="Write">

148 <operator>Write</operator>

149 <sources>

150 <sourceProduct refid="Subset"/>

151 </sources>

152 <parameters class="com.bc.ceres.binding.dom.XppDomElement">
153 <file>$outputl</file>

154 <formatName>BEAM-DIMAP</formatName>

155 </parameters>

156  </node>

Once the input and output variables are defined, save the graph as a new xml file. Go to File->Save
As. Navigate to the following path and save it as SI_Orb_Thm_Cal _TC _sub_GPT.xml.

Path: /shared/Training/LAND10_RiceMapping_Vietnam/AuxData/
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Now, the Sinputl, Soutputl and Soutput2 variables allow the graph to be used with different images.
However, to run the graph, the value of the variables has to be properly set so that GPT knows which
file to use as input and where to save the outputs. When running a graph with variables in GPT, we
have to use the ‘-P’ option followed by the name of the variables we have created. In an XML graph,
all occurrences of ${<name>} will be replaced with <value>.

To run a graph with variables in GPT, the following structure is used:

gpt /path/to/graph/ -Pinputl=/path/input/Sentinel/images/ -Poutputl=/path/o
utputl/directory/file.dim -Poutput2=/path/output2/directory/file.dim

For example:

gpt /shared/Training/LAND10 RiceMapping Vietnam/AuxData/Sl Orb Thm Cal TC sub GPT.x
ml -Pinputl=/shared/Training/LAND10 RiceMapping Vietnam/Original/S1A IW GRDH 1SDV 2
0180307T224528 20180307T224553 020915 023E2F F92F.zip -Poutputl=/shared/Training/LA
ND10 RiceMapping Vietnam/Processing/20180307 VH.dim -Poutput2=/shared/Training/LAND
10 RiceMapping Vietnam/Processing/20180307 VV.dim

i Terminal - rus@front-usr-231: ~ e o B

File Edit View Terminal Tabs Help
rus@front-usr-231:~$ gpt /shared/Training/LAND10 RiceMapping Vietnam/AuxData/S1 Orb Thm Cal TC sub GP
T.xml -Pinputl=/shared/Training/LAND10 RiceMapping Vietnam/Original/S1A IW _GRDH_1SDV 20180307T224528

20180307T224553 020915 023E2F F92F.zip -Poutputl=/shared/Training/LAND1© RiceMapping Vietnam/Processi
ng/20180307 VV.dim -Poutput2=/shared/Training/LAND10 RiceMapping Vietnam/Processing/20180307 VH.dim

6.3.9 Batch processing

Once the graph is modified with the Sinputl, Soutputl and Soutput2 variables, we are ready to
process them in batch mode with GPT. For that, when an image is processed, the Sinputl, Soutputl
and Soutput2 variables have to change with the appropriate name. There are several approaches to
do so but, in this exercise, we will use a bash script (See " INOTE 11).

NOTE 11: Bash is a Unix shell and command language written by Brian Fox for the GNU Project as a free
software replacement for the Bourne shell. Bash is a command processor that typically runs in a text
window where the user types commands that cause actions. Bash can also read and execute
commands from a file, called a shell script. Like all Unix shells, it supports filename globbing (wildcard
matching), piping, here documents, command substitution, variables, and control structures for
condition-testing and iteration. The keywords, syntax and other basic features of the language are all
copied from sh. Other features, e.g., history, are copied from csh and ksh. Bash is a POSIX-compliant
shell, but with several extensions.

Go to the following path /shared/Training/LAND10_RiceMapping_Vietnam/AuxData/ and click on
File -> Create document -> Empty file. Name it Script_GPT.sh and click Create. See " | NOTE 12 for
some basic information regarding bash.

»

NOTE 12: The hash exclamation mark ( #! ) character sequence is referred to as the Shebang. Following
it is the path to the interpreter (or program) that should be used to run (or interpret) the rest of the
lines in the text file (for Bash scripts it will be the path to Bash, but there are many other types of
scripts and they each have their own interpreter). The shebang must be on the very first line of the file.
There must also be no spaces before the # or between the ! and the path to the interpreter. More
information on bash scripting on: https://ryanstutorials.net/bash-scripting-tutorial/
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The scrip that we will use first defines three variables that are used to set specific paths:

- Path_S1: path to folder containing the original Sentinel-1 products (Path_S1)
- Path_VH: path to folder where S1 processed images with VH polarization will be saved
- Path_VV: path to folder where S1 processed images with VV polarization will be saved

Next, the script defines three other variables:

- oldEnd: used to identify original products using the .zip pattern
- VVpol: used to define the name of the processed images in VV polarization
- VHpol: used to define the name of the processed images in VH polarization

Next, a for loop starts. All the Sentinel-1 images in the specify directory are identified and a list

containing the names is created.

In each iteration (for each element of the list), the sensing time of the product is extracted from the

file name and saved in the variable ‘n’. Then, the element of the list is passed in to the -Pinputl

variable and processed using the predefined graph. The -Poutputl variable is defined by adding:

- Path_VH =2 path of the output directory
- n 2sensing time of the Sentinel-1 product
- VH_pol 2 polarization

For example:
Path VH + n + VH pol
L
v v
A A
r N7 \

~

/shared/Training/LAND10 RiceMapping Vietnam/Processing/VH/ + 20180307 + VH

/shared/Training/LAND10 RiceMapping Vietnam/Processing/VH/20180307 VH.dim

The same procedure is used to define the -Poutput2 and the -Poutput3 variables. The date command

provides the starting and finish time of the gpt command.

Now that we have a better idea of what the bash script will do, right click on the Script_GPT.sh we

have created and select Open with Mousepad. Copy-paste the following text and remember to save

the file after pasting the script (File -> Save).
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#!/bin/bash

# 1- Define path variables
Path Sl=/shared/Training/LAND10 RiceMapping Vietnam/Original/
Path VH=/shared/Training/LAND10 RiceMapping Vietnam/Processing/VH/

Path VV=/shared/Training/LAND10 RiceMapping Vietnam/Processing/VV/

# 2- Define name variables
oldEnd=.zip
VHpol= VH
VVpol= VV
# 3- Extract date & run GPT
for i in $(1s -d -1 $Path S1$S1*.zip)
do
n=5{i%.*}
n=${1i%T*}
n=${n#"S{ns *} "}
date

gpt /shared/Training/LAND1O RiceMapping Vietnam/AuxData/S1 Orb Thm Cal
TC sub GPT.xml -Pinputl=$i -Poutputl="S$Path VHSnS$VHpol" -Poutput2="$Path VV
Sn$vvpol"

date

done

Once the script is saved, we can run it. Open a new terminal window, copy-paste the following
command and press enter to run it. If you get a Permission denied error, see " | NOTE 13. You can
monitor the usage of RAM memory by opening the Task Manager (Applications -> System -> Task
Manager). This process may take some time depending on the number of images to process, the
processing steps applied and your IT environment.

/shared/Training/LAND10 RiceMapping Vietnam/AuxData/Script GPT.sh
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NOTE 13: When running the Script_GPT.sh bash script, it can happen that the following error appears in
Terminal: Permission denied

Terminal - rus@front-usr-231: ~ A _aTx
File Edit View Terminal Tabs Help
rus@front-usr-231:~% /shared/Training/LAND10 RiceMapping Vietnam/AuxData/Script GPT.sh

bash: /shared/Training/LAND1@ RiceMapping Vietnam/AuxData/Script GPT.sh: Permission denied

It is cause by the lack of an execute permission bit for the file you want to run. To solve it, we just need
specify that the file can be executed. For that, access the folder where the file is stored. Copy paste the
following code in Terminal and run it (Press Enter).

cd /shared/Training/LAND10 RiceMapping Vietnam/AuxData/

Terminal - rus@front-usr-231: /shared/Training/LAND10_RiceMapping_Vietnam/AuxData [N
File Edit View Terminal Tabs Help
rus@front-usr-231:~% cd /shared/Training/LAND10 RiceMapping Vietnam/AuxData/

rus@front-usr-231:/shared/Training/LAND10 RiceMapping Vietnam/AuxData$

Next, copy-paste the following command to make the file executable and run it by pressing enter.

chmod +x Script GPT.sh

ﬁ Terminal - rus@front-usr-231: /shared/Training/LAND10_RiceMapping_Vietnam/AuxData TR

File Edit View Terminal Tabs Help
rus@front-usr-231:~% cd /shared/Training/LAND1® RiceMapping Vietnam/AuxData/

rus@front-usr-231:/shared/Training/LAND1@_ RiceMapping Vietnam/AuxData$ chmod +x Script_GPT.sh

H Terminal - rus@front-usr-231: ~ R =)

File Edit View Terminal Tabs Help
rus@front-usr-231:~% /shared/Training/LAND10 RiceMapping Vietnam/AuxData/Script GPT.sh

ﬂ Terminal - rus@front-usr-231: ~ e =gl
File Edit View Terminal Tabs Help

rus@front-usr-231:~% /shared/Training/LAND10 RiceMapping Vietnam/AuxData/Script GPT.sh
Fri Apr 12 08:39:10 UTC 2019

INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external t
ool adapters

SEVERE: org.esa.s2tbx.dataio.gdal.activator.GDALDistributionInstaller: The environment v
ariable LD LIBRARY PATH is not set. It must contain the current folder

Executing processing graph

INFO: org.hsgldb.persist.Logger: dataFileCache open start

H Terminal - rus@front-usr-231: ~ |47 = =8l
File Edit View Terminal Tabs Help

rus@front-usr-231:~$ /shared/Training/LAND10 RiceMapping Vietnam/AuxData/Script GPT.sh
Fri Apr 12 08:39:10 UTC 2019

INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external t
ool adapters

SEVERE: org.esa.s2tbx.dataio.gdal.activator.GDALDistributionInstaller: The environment v

ariable LD LIBRARY PATH is not set. It must contain the current folder
Executing processing graph

INFO: org.hsqldb.persist.Logger: dataFileCache open start
ceeel0%.eei20%.:..30%....40%....50%....60%....70%....80%....90% done.
Fri Apr 12 08:40:37 UTC 2019
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Once the script is finished and all the images have been processed, you will find them in the paths

specified in the bash script. Navigate to the following paths and check the files have been created.

Path 1 = /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VH/

Path 2 & /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VV/

[E/LAND10_RiceMapping_Vietnam/Processing/VV/ G

[B'LAND10_RiceMapping_Vietnam/Processing/VH/ G

{120180307_VV.data
[§120180319_VV.data
{120180331_VV.data
{120180412_VV.data
[§120180424_VV.data
[§120180506_VV.data
{920180518_VV.data
§20180530_VV.data
{§20180611_VV.data
§20180623_VV.data
§120180705_VV.data
§920180717_VV.data
§920180810_VV.data
[120180822_VV.data
120180903 _VV.data
§20180915_VV.data
120180927 VV.data
[§120181009_VV.data
[20181021_VV.data
§920181102_VV.data
120181114 _VV.data
§120181126_VV.data
§920181208_VV.data
120181220 _VV.data

/] 20180307_VV.dim

» 20180319_VV.dim

20180331_VV.dim

~ 20180412_VV.dim
~ 20180424_VV.dim
/| 20180506_VV.dim

20180518_VV.dim
20180530_VV.dim

/| 20180611 _VV.dim
/| 20180623_VV.dim

20180705_VV.dim

» 20180717_VV.dim

20180810_VV.dim

~ 20180822_VV.dim

20180903_VV.dim

# 20180915_VV.dim

20180927_VV.dim
20181009_VV.dim

/| 20181021_VV.dim
/| 20181102_VV.dim
//20181114_VV.dim

20181126_VV.dim
20181208_VV.dim
20181220_VV.dim
VV.snap

{20180307_VH.data
[§20180319_VH.data
{120180331_VH.data
§20180412_VH.data
{120180424_VH.data
{120180506_VH.data
[20180518_VH.data
[§120180530_VH.data
[120180611_VH.data
{120180623_VH.data
{20180705_VH.data
[§120180717_VH.data
{20180810_VH.data
{§20180822_VH.data
{§120180903_VH.data
[120180915_VH.data
[§120180927_VH.data
[§120181009_VH.data
{120181021_VH.data
{520181102_VH.data
{20181114_VH.data
[§520181126_VH.data
{20181208_VH.data
{§120181220_VH.data

20180307_VH.dim

#20180319_VH.dim

20180331_VH.dim
20180412_VH.dim
20180424_VH.dim
20180506_VH.dim
20180518_VH.dim
20180530_VH.dim
20180611_VH.dim
20180623_VH.dim
20180705_VH.dim
20180717_VH.dim
20180810_VH.dim
20180822_VH.dim
20180903_VH.dim
20180915_VH.dim
20180927_VH.dim
20181009_VH.dim
20181021_VH.dim
20181102_VH.dim

+20181114_VH.dim

20181126_VH.dim
20181208_VH.dim
20181220_VH.dim
VH.snap

6.3.10 Stack
After the images have been processed, we will stack them together according to their polarization to
allow further processing.

To prevent errors when creating the stack, images have to be opened in chronological order. For
convenience SNAP session files have been created in advanced and are located in the following paths
(See " | NOTE 14). In SNAP go to File -> Session -> Open Session. Navigate to Path_1 and open the
VH_images.snap file. Next, go to RADAR -> Corregistration -> Stack Tools -> Create Stack.

NOTE 14: Note that opening the SNAP session file will only work if Sentinel-1 images have been
processed and stored in the appropriate path as explained in previous steps. If you run batch
processing without errors, you should not face any issue. You can also manually load images in
chronological order.

Path_1: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VH/

Path_2: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VV/
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In the 1-ProductSet-Reader click on the Add Opened icon - % - and click on the Refresh - < _icon to
update the metadata information. In the 2-CreateStack tab, select NEAREST_NEIGHBOUR resampling
method, set the initial offset method to Product Geolocation and click on the Find Optimal Master
button. In the 3-Write tab, change the name to S1_VH Stack and make sure to set the output
directory to the Path_1. Click Run.

[a Create Stack s € Create Stack [FA 5

1-ProductSet-Reader | 2-Createstack | 3-Write 1-ProductSet-Reader Iml 3write |

File Name Type Acquisition Track Orbit " Master- 20180717 VH

20180307_VH GRD 07Mar2018 18 20915 el T

20180318_VH GRD 15Mar2018 18 21030 e e IEAREST_NEIGHEOUR |
20180331_VH GRD 31Mar2018 18 21265 Initial Offset Method Product Geolocation -
20180412 VH GRD 12Apr2018 18 21440 +

20180424 VH |GrRD [24Apr2018 18 21615 [N =t Master -
20180506_VH |GRD [06May2018 18 21790 —

20180518_VH GRD 18May2018 18 21965

(20180530 vH G [30May2018 18 [22140 i

20180611 _VH GRD 11jun2018 18 22315

[20180623_VH [Gro [23)un2018 18 |22430

20180705_VH GRD 05/ul2018 18 22665 &

20180717_VH GRD 17)ul2018 18 22840

20180810_VH GRD 10Aug2018 18 23190

20180822_VH GRD 22Aug2018 18 23365 4

20180903_VH GRD 03Sep2018 18 23540

20180915 _VH GRD 15Sep2018 18 23715 @

20180927 VH GRD 27Sep2018 18 23890

20181009_VH ‘GRD ‘090&2013 18 24065

20181021 VH |GRD [210ct2018 18 24240

20181102 VH GRD 02Nov2018 18 24415

[20181114_vH [GRD [14Nov2018 18 [24550 %

20181126_VH GRD 26Nov2018 18 24765 ©

20181208_VH GRD 08Dec2018 18 24940

20181220_VH GRD 20Dec2018 18 25115 24 Products;

@ Heio [> Run | © e I [> Run
¢ Create Stack s

1-ProductSet-Reader | 2-CreateStack G
Target Product

Name:
S1_VH_Stack

Save as: [BEAM-DIMAP -

Directory:

/home/rus/shared/Training/LAND10_RiceMapping_Vietnam/Processing/VH/

Help > Run
>

Once finished, repeat the same procedure for the VV polarization images and save them with the
appropriate names and in the appropriate directory: S1_VV_Stack and Path_2 respectively.

6.3.11 Multi-temporal speckle filtering

Once the two different stacks have been created, we will reduce the effect of speckle noise in each of
them. SAR images have inherent salt and pepper like texturing called speckles that degrade the
quality of the image and make interpretation of features more difficult (See "I NOTE 15). To reduce
the speckle effect, we will take advantage of the temporal dataset we are working with and apply a
multi-temporal speckle filter. For this exercise, the default filter used in SNAP (Lee Sigma) will be
used.

NOTE 15: Speckle is caused by random constructive and destructive interference of the de-phased but
coherent return waves scattered by the elementary scatters within each resolution cell. Speckle noise
reduction can be applied by either spatial filtering or multilook processing. Multi-temporal filtering is
one of the commonly used speckle noise reduction techniques. (SNAP Help)

Go to RADAR -> Speckle Filtering -> Multi-temporal speckle filter. First we will reduce the speckle for
the S1_VH_stack.dim file that was created in the previous step. In the [/O Parameters tab click on the
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"icon go to Path_1 and select the file. Make sure the output name is set to S1_VH_ Stack Spk and
the output directory to the following path. In the Processing Parameters tab leave the default values.

Path_1: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VH/

(- & Multi-temporal Speckle Filter v o x M-e Multi-temporal Speckle Filter BORERES
File Help File Help
| /O Parameters I Processing Parameters | [ /O Parameters | Processing Parameters |

Source Product

»

Sigma0_VH_db_slvlé_27Sep2018
) Sigma0_VH_db_slvl7_090ct2018
|Sl_VH_Stack |v | ‘ Sigma0_VH_db_sIv18_210ct2018

Sigma0_VH_db_slv19_02Nov2018

source;

Source Bands

Sigma0_VH_db_slv20_14Nov2018

Target Product Sigma0_VH_db_slv21_26Nov2018
Name: Sigma0_VH_db_slv22_08Dec2018 T
|51 VH_Stack Spkl Sigma0_VH_db_slv23_20Dec2018 -
[¥] Save as: |[BEAM-DIMAP - Filter. Lee Sigma v|
Directory Number of Looks: [ v|
ra||1|ng_FLANDlU_RlceMapping_Vietnam,’Processing,"'lietnam,"\-'HI| ‘ Window Size: Tx7 '|
[w] Open in SNAP Sigma: 0.9 —
Target Window Size: |5, -

Run Close Run Close

Once finished, repeat the same procedure for the S1_VV_Stack.dim file. Make sure to save it with the
appropriate name and in the appropriate directory: S1_VV _Stack Spk and Path 2 respectively. Once
finished, close all the products in SNAP except for the two stacked files.

Path_2: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VV/

6.3.12 Decibel transformation

Due to the high dynamic range of SAR imagery, the decibel transformation is used to improve
visualization and data analysis. The transformation will stretch the RADAR backscatter over a more
usable range which has nearly a gaussian distribution. The RADAR backscatter coefficient (c°) is
transformed into the decibel scale using the following equation:

0° (dB) = 10 *log 100°

Go to Raster -> Data Conversion -> Convert bands to/from dB. In the /O Parameters tab, make sure
to select the S1_VH_Stack Spk as input and set the output directory to the following path. Leave the
default settings in the Processing Parameters tab.

Path: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VH/
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m Converts bands to/from dB SN E =X m Converts bands to/from dB \%

File Help File Help

IfO Parameters I Processing Parameters | [ /O Parameters I Processing Parameters I

Source Product Source Bands: |Sigma0_VH_mst_07Mar2018 —

source: Sigma0_VH_shvl_l9Mar2018

‘[1] S1_VH_Stack _Spk \.‘ Sigma0_VH_shv2_31Mar2018
Slgma0_VH_slv3_12Apr2018
SigmaO_VH_s|v4_24Apr2018

Target Product Sigma0_VH_shvS_06May2018

Name Sigma0_VH_shv6_18May2018

‘Sl_VH_Stack_Spk_dEl Sigma0_VH_sh7_30May2018 =

Sigma0_VH_shE_11jun2018
|v| Save as: Sigma0_VH_sh9_23Jun2018
Directory: Sigma0_VH_shv10_05Jul2018
Sigma0_VH_sh11_17jul2018
Sigma0_VH_siv12_10Aug2018
[] Open in SNAP Sigma0_VH_slv13_22Aug2018
Sigma0_VH_siv14_03Sep2018
Sigma0d_VH_shv15_15Sep2018
Sigma0d_VH_shv16_27Sep2018
Sigma0_VH_sh17_090ct2018 |
Sigma0d VH shvl8 210ct2018 ¥

Once finished, repeat the same procedure for the S1_VV_Stack_Spk file and save the output in the
following path:

..hared.i'l'rainingfLANDlD_Ri( EMapping_Vietnam!F‘rocessingNHd

Path: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VV/
6.4 QGIS

6.4.1 Sigma Naught evolution

Once the conversion to the decibel scale is finished, close SNAP and open QGIS (Applications ->
Processing -> QGIS Desktop). For convenience, a session containing the images we will use to analyse
the temporal evolution of the backscatter coefficient has been created in advance. Go to Project ->
Open, navigate to the following path and open the QGIS LAND10.qgs file (See " INOTE 16).

Path: /shared/Training/LAND10_RiceMapping_Vietnam/AuxData/

*

NOTE 16: The QGIS session file that is provided in this exercise will only work if you have saved the
processed Sentinel-1 files with the same name and in the same path as specified in this tutorial. If not,
you can always load the products to QGIS manually.
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Sigma0_VH_slv21_26Nov2018_db
Sigma0_VH_slv20_14Nov2018_db
Sigma0_VH_slv19_02Nov2018_db
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To analyse the evolution of the backscatter coefficient we will use the Value Tool (See " INOTE 17),a
specific plugin that allows to plot pixel values in different layers with the mouse position as

reference.

the ‘Value Tool’ and click install.

NOTE 17: If you do not have the ‘Value Tool’ plugin install, click on the menu Plugins -> Manage and
install plugins. Select the ‘All’ section on the right-side panel, write ‘Value Tool’ on the search box, select

B Not installed

Y& Upgradeable

* Settings

Plugins | All (808)

Search [value tool

Vrm- plugin is trusted
Value Tool

Display in a table or plot the values from
the visible raster layers at the current
mouse position

Display raster layer values at current mouse position
[ 52 rating vote(s), 91053 downloads

Tags: raster
More infa: homepa ge buc tracker code rg(g@(o ¥

Author: Ghislain Picard - Etienne Tourigny

Avallable version: 0.8.5 (in QGIS Official Plugin
Repository)

< | 2|
Upgrade aIII

Install plugin |

Close Help

Once installed, the tool will appear in the lower left corner (if not visible, right click on the Toolbar
and select Value Tool). Activate the tool by clicking on Enable, go to the Options tab and click on the

option Plot values only when mouse is clicked. Set the following parameters:

Show layers: Selected layers

Show ba

In the list of layers of the Value Tool, select all the VH (or VV) images (24 in total) to analyze the

tempora

nds: All bands

| profile.

=] ¥ Render ) EPSG:32648 @




Value Tool & X | |value Tool 8 X
¥ Enable v Enable
Table | Graph Table | Graph
¥ Plot values only when mouse is clicked [V Plot values only when mouse is clicked
Show layers: [Selected layers x| Show layers: W
Show bands: |All bands - Show bands: |All bands vI
Select active layers and display options: Select active layers and display options:
Layer | # Bands | ij Layer I # Bands I—;l
1 |#I|Sigma0_VH_mst_07Mar2018_db i [1] l 22| 1| Sigma0_VH_slv21_26Nov2018... #][1]
2 |#|Sigma0_VH_slvl_19Mar2018 db #|][1] _2: Sigma0_VH_slv22_08Dec2018... -—: [1] =
3 Sigma0_VH_slv2_31Mar2018_db #|[1] 24 E]VSigmaO_VH_sIvZB_ZODecZOl&.. #|[1]
4 Sigma0_VH_slv3_12Apr2018_db i (1] 25 |[] Sigma0_VV_mst_07Mar2018_db 7 83
s_m.lsiumao VH slvd 24Apr2018 db | #1111 = 7—5 M!Siama0 VV slvl 19Mar2018 db : 11 LI

Once all the parameters are set, click on the Graph tab. Zoom in a specific area of the image, place
your mouse over a field and click. The graph will then show the Sigma Naught (c0) evolution in all the
Sentinel-1 VH (or VV) images we have previously processed.
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Project Edit View Layer Settings Plugins Vector Raster Database Web Progessing Help
e == ; % @ O 0) (0] A &~ v &1~ 0 2=
[DEBRORINSSLSRPPHHIMRles -6 - @z a- 08
= EEL %2 Pz > : e (W abg ‘abg ai TS |
[#./B5m-sr@>=o03l=0fE% %55 lai e e
[IEES) RO BREARPORRTEC-
——|Layers Panel 8 x
Vo [vawve-waa |
¥ [E5@ 0 somaova =
o % @ ¥ Sigma0_VH_mst_07Mar2018_db
ﬁ, @[] @ Sigma0_VH_slvl_19Mar2018_db
5 &[] g Sigma0_VH_slv2_31Mar2018_db
'n' &[] g Sigma0_VH_slv3_12Apr2018_db
@ [] g Sigma0_VH_slva_24Apr2018_db
@' @ [] @ Sigma0_VH_slv5_06May2018_db
&[] ¥ Sigma0_VH_slvé_18May2018_db
@ &[] g Sigma0_VH_slv7_30May2018_db
@v @ [] g Sigma0_VH_slvé_11jun2018_db
- Sioma0 VH slv9 231un2018 db ;l
,u Value Tool 8 x
/7 | P Enable
Y v Table options |

Y min [ Y max |

Coordinate. 534891,1109894 ¥ scale[1:403.438 <] @ Magnifier[100% =] Rotation [0.0 = ¥ Render @ EPSG:32648 @

Coordinate: (525924.233476, 1115765.012354)

6.4.2 QGIS Processing

In the last step we will take advantage of the large differences of backscatter produced by the
different growing stages of rice to highlight the fields where this crop is been cultivated. Go to
Processing -> Toolbox. In the search box, write r.series and open the tool.

Processing Toolbox 8 x
r.series | a
- Recently used algerithms
- ¢ GRASS GIS 7 commands [314 geoalgo...

= Raster (r.*)

B iy rseries - Makes each output cel..,
i~ rseries.accumulate - Makes ea...
..y rseries.interp - Interpolates ras...

In the Input raster layer(s), click on the L] icon, select all the VH bands and click OK.
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/ Muitiple selection aanleled s

Sigma0_VH_sIv4_24Apr2018_db [EP5G:32648] Select all I
Sigma0_VH slv15_155ep2018_db [EPSG:32648]

] Sigma0_VH mst_(7Mar2018_db [EPSG:32648] :
Sigma0_VH slv13_22Aug2018_db [EPSG:32648] Clear selection |
[ Sigma0_ WV slv9_23jun2018_db [EPSG:32648]

[ Sigma0_VV slv11_17jul2018_db [EPSG:32648] Toggle selection
] Sigma0_VH_slv21_26Nov2018_db [EPSG:32648]

[ Sigma0_VV_slv20_14Nov2018_db [EPSG:32648]
] Sigma0_VH_sIv20_14Nov2018_db [EPSG:32648]
] Sigma0_VH_slv19_02Nov2018_db [EPSG:32648] Cancel '
[J Sigma0_VV_slv18_210ct2018_db [EPSG:32648]

[] Sigma0_VV_mst_07Mar2018_db [EPSG:32648]

[] Sigma0_VV_slv15_155ep2018_db [EPSG:32648]
[] Sigma0_VV_slv6_18May2018_db [EPSG:32648]
L] Sigma0_WV_slv13_22Aug2018 db [EPSG:32648]
Sigma0_VH_slv9_23Jun2018_db [EPSG:32648]
[ Sigma0_VV_slv7_30May2018_db [EPSG:32648]
[ Sigma0 VW slv17_090ct2018_db [EPSG:32648]
] Sigma0_VH_slv7_30May2018_db [EPSG:32648]
¥l Sigma0_VH sIvs_06May2018_db [EPSG:32648]
m,

CinmnaN A/ ch?3 AONAFINIG dh fEDER-376401

In the Aggregate operation tab, select minimum. Leave the remaining parameters as default and save
the output as S1_VH_Min in the following path. Then, click Run. Once finished, change the Aggregate
operation to maximum and save the output as S1_VH_Max in the same directory as before.

Path: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VH/

/| rseries - Makes each output cell value a function of the values assigned to the corresponding ce i (e 4| | // rseries - Makes each output cell value a function of the values assigned to the corresponding ce G (= .. |

Parameters I Log | Help | Run as batch process... I Log | Heip | Run as batch process...|
Input raster layer(s) Input raster layer(s)

[2% elements selected i I [24 elements selected i I

I~ Propagate NULLs I~ Propagate NULLS

Aggregate operation Aggregate operation
[minimum | = | [maximum | il

GRASS GIS 7 region extent (xmin, xmax, ymin, ymax) GRASS GIS 7 region extent (xmin, xmax, ymin, ymax)

| [Leave blank to use min covering extent! [ (Leave blank to use min covering extent

GRASS GIS 7 region cellsize (leave 0 for default) GRASS GIS 7 region cellsize (leave 0 for default)

[0.000000 :IJ [0.000000 :IJ

» P »
Aggregated Aggregated
|/shared/Training/LANDLO RiceMapping VietnamjProcessing/VH/S1 VH Min.tif | |/shared/Training/LAND10_RiceMapping Vietnam/Processing/VH/S1 VH Min.tif |
 Open output file after running algorithm  Open output file after running algorithm
[ 0% [ 0%
I oo ] oo |

Once the minimum and maximum value for each pixel has been derived for the Sentinel-1 VH
images, do the same for the VV layers. Change the input raster layer(s) and derive the same statistics.
Name them S1_VV_Min and S1_VV_Max and save them in the following path:

Path: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VV/
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Next, we will derive the difference between the minimum and maximum value for both polarizations.

Go to Raster -> Raster Calculator. Set the output name as Difference_VH and save it in the following

path.

Path: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VH/

Leave the remaining parameters as default and copy-paste the following expression under the Raster

calculator expression. Then, click Ok.

"S1_VH_Max@1" - "S1_VH_Min@1"

Sigma0_VH_mst_07Mar2018_db@1
Sigma0_VH_slv10_05Jul2018_db@1
Sigma0_VH_slvl1_17jul2018 db@1
Sigma0_VH_slvl2_10Aug2018_db@1
Sigma0_VH_slvl3_22Aug2018_db@1
Sigma0_VH_slvl4_03Sep2018 db@1

Sigma0_VH slvl5 15S5ep2018 db@1l
Sigma0_VH_slv16_27Sep2018_db@1
Sigma0_VH_slvl7_090ct2018_db@1

Sigma0_VH slv18_210ct2018 db@1

Current layer extent I

1(' Raster calculator il S
—Raster bands —Result layer
S1_VH_Max@1 2| || outputlayer cessing/VH/Difference VH.tf
_VH_Min@1 tput lay L oV = J |
51"V Max@1
S1TW Min@1 Output format |GeoTIFF 3|

Xmin [497614.43535

=] XMax [587964.43535 =]

Y min |lﬂ?5119 26588

=] Y max [1140079.26588  —

Columns [9035
Output CRS

=] Rows [6496 =]

[selected crs (EPSG:32648. WGS 343-_‘-'

Sigma0_VH_slv19_02Nov2018_db@1 x| || ¥ Add result to project
w Operators
+ I * I sqrt cos I sin | tan I log10 I ( |
= I ! | - acos | asin | atan I In | ) |
< | > | = = | <= | >= | aw | or |

— Raster calculator expression

“S1_VH_Max@1" - *S1_VH_Min@1" ]

Expression valid

Cancel

Once finished, repeat the same procedure to derive the difference between the S1_VV_ Max and
S1_VV_Min layers. Set the output name as Difference_VV and save it in the following path. Leave the

remaining parameters as default and copy-paste the following expression. Then, click OK.

Path: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VV/

"S1_VW_Max@1" - "S1_VWV Min@1"

Finally, we will create a false-colour RGB composition to better visualize the crop patterns. In the
Layers Panel, select only the Difference_VH, S1_VH_Max and S1_VH_Min layers. Next, go to Raster ->

Miscellaneous -> Build Virtual Raster
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Select the option Use visible raster layers for input, save the output file as RGB_VH in the following
path and check the option Separate. Then, click Ok. Repeat the same procedure for the
Difference_VV, S1_VV_Max and S1_VV_Min layers and save it as RGB_VV in the corresponding

folder. (You may have different color patterns depending on how the layers have been assigned to
the RGB channels).

Path: /shared/Training/LAND10_RiceMapping_Vietnam/Processing/VH/

7 Build Virtual Raster (Catalog) B

EUse visible raster layers for input

I~ Choose input directory instead of files

Input files | Select... '
OQutput file |/Processing/VH/RGB_VH ||§ Select... ||
[~ Resolution |Average |

I~ Source No Data |0
I~ Target SRS [ Select |
[]separate

I~ Allow projection difference

¥ Load into canvas when finished

gdalbuildvrt -separate il 4
/home/rus/shared/Training/LAND10_RiceMapping_Viet
nam/Processing/VH/RGB_VH __]
/shared/Trainina/LAND10 RiceMappina Vietnam/Proc

[ ok ] close | e |
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QGIS 2.18.18 - QGIS_LAND10

Edit View Layer Settings Plugins Vector Raster Database Web

DEJEI_IQEQIHI_@'@JQ@RDPQJBEB@elﬂ%a\vrm £, BT B, -l

A/ B Smak@€o B % Q("ds'ﬁ'ﬁﬁmlﬂ'm.}%‘

UMO%@%%@%‘S%%F@““W &~

——/|Layers

dmv?ﬂvﬁlﬁlu

Sigma0_VH
m Sigma0_VV

4
[cRCRURCRCRRR U RCR R
DDDDDDDDD

Coordinate 489045,1136900 % scale[T:403,434 <] @ Magnifier[100% =] Rotation [0.0 =] ¥ Render ) EPSG:32648 @

THANK YOU FOR FOLLOWING THE EXERCISE!

7 Further reading and resources

Sentinel-1 User Guide

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar

Sentinel-1 Technical Guide

https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-1-sar

SNAP GPT Guide

https://senbox.atlassian.net/wiki/spaces/SNAP/overview

Bash and Linux Tutorial

https://ryanstutorials.net/bash-scripting-tutorial/
FOLLOW Uus!!!

@RUS-Copernicus
RUS-Copernicus

RUS-Copernicus

RUS Copernicus Training

)8 E ¢

www  RUS-Copernicus website
@ RUS-Copernicus Training website
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