
CHÖÔNG VI. 
NAÏP DÖÕ LIEÄU VAØO BAÛN ÑOÀ SOÁ

Chöông naøy trình baøy phaàn naïp döõ lieäu cho moät soá lôùp, ngöôøi ñoïc coù theå töï naïp
döõ lieäu theo yù muoán cho caùc lôùp khaùc.

VI.1. NAÏP DÖÕ LIEÄU

VI.1.1. Lôùp giao_thong

Môû lôùp giao_thong vaø aûnh queùt bd_hcvn ñaõ ñaêng kyù ra.

Trong lôùp naøy ta ñaõ veõ hai kieåu ñöôøng, ñöôøng nhöïa vaø ñöôøng saét.

- Töø menu chính choïn Window > New Browser Window, cöûa soå döõ lieäu cuûa lôùp giao
thoâng ñöôïc hieån thò (hình VI.1). Neáu ta môû nhieàu lôùp baûn ñoà cuøng luùc thì seõ coù moät
hoäp thoaïi nhoû môû ra cho pheùp ta choïn môû döõ lieäu cuûa lôùp baûn ñoà naøo.

ÔÛ goùc döôùi beân traùi cuûa cöûa soå chính cuûa MapInfo, ta thaáy hieän doøng chöõ, ví duï
“records 1-10 of 60”, töùc laø treân cöûa soå Browser ñang môû coù 10 haøng ñaàu tieân (töø haøng
1 ñeán haøng 10) trong toång soá 60 haøng. Moãi haøng naøy töông öùng vôùi moät vaät theå ñöôïc
veõ treân cöûa soå baûn ñoà. Khi ta thay ñoåi cöûa soå Browser hoaëc duøng thanh tröôït ñöùng ñeå
di chuyeån caùc haøng leân xuoáng thì hai con soá ñaàu seõ thay ñoåi töông öùng theo soá haøng
vaø soá thöù töï caùc haøng ñöôïc hieån thò treân cöûa soå Browser.

Ta thaáy raèng döõ lieäu cuûa lôùp giao_thong chæ coù moät tröôøng laø ID. Ñaây laø tröôøng ñöôïc
taïo ra töï ñoäng khi ta soá hoaù baûn ñoà, taát caû caùc haøng trong tröôøng naøy ñeàu coù giaù trò
maëc ñònh laø 0 (tröôøng naøy ñöôïc ñònh daïng maëc ñònh laø Integer - soá nguyeân).

Tieáp theo ta caàn phaân tích xem caàn naïp nhöõng döõ lieäu gì cho lôùp giao_thong. Trong
tröôøng hôïp naøy giaû söû ta chæ caàn phaân bieät ñöôøng nhöïa vaø ñöôøng saét, vaäy thì ta seõ taïo
theâm moät tröôøng môùi coù teân laø thuoc_tinh (thuoäc tính cuûa caùc ñöôøng).

Ñeå taïo theâm tröôøng môùi, ta thöïc hieän nhö sau:
- Choïn Table > Maintenance > Table Structure (töông töï nhö ôû treân, neáu môû nhieàu lôùp

ñoàng thôøi thì seõ coù moät hoäp thoaïi nhoû môû ra cho pheùp ta choïn teân lôùp caàn thao taùc),
hoäp thoaïi Modify Table Structure môû ra (hình VI.2).

- Choïn nuùt Add field (theâm tröôøng môùi), moät tröôøng môùi ñöôïc taïo thaønh vaø ñöôïc
MapInfo töï ñoäng ñaët teân cho noù laø Field2 trong oâ Name. Ta ñoåi teân tröôøng naøy thaønh
thuoc_tinh. Löu yù raèng teân tröôøng khoâng ñöôïc coù khoaûng traéng (töùc khoâng ñöôïc
caùch chöõ vaø teân tröôøng khoâng hieån thò ñöôïc tieáng Vieät ñöôïc neân phaûi boû daáu ñi).
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- Khai baùo kieåu cuûa tröôøng trong oâ Type, trong tröôøng hôïp naøy ta döï ñònh seõ goõ caùc
chöõ trong tröôøng môùi laø “ñöôøng nhöïa” vaø “ñöôøng saét”, nhö vaäy ñaây laø tröôøng kieåu
kyù töï, vaäy trong Type ta choïn laø Character. Khi choïn xong phía döôùi oâ Type xuaát
hieän theâm moät oâ nöõa laø Width, oâ naøy cho pheùp taùc xaùc ñònh soá kyù töï toái ña ñöôïc goõ
vaøo tröôøng môùi taïo. Giaù trò trong oâ Width laø soá kyù töï cuûa chöõ daøi nhaát döï ñònh goõ
vaøo. Ta naïp vaøo oâ Width laø 16.

Löu yù raèng trong tröôøng hôïp goõ tieáng Vieät thì caùc daáu cuõng ñöôïc tính laø kyù töï,
ñoàng thôøi khoaûng traéng (daáu caùch) cuõng ñöôïc tính laø moät kyù töï. Vì theá ta phaûi
tính soá kyù töï cuûa chöõ daøi nhaát ñeå naïp giaù trò vaøo oâ Width cho ñuùng.

Chuù yù: caàn xaùc ñònh soá kyù töï toái ña cho ñuùng, khoâng thieáu cuõng khoâng thöøa, vì neáu
thieáu thì khi naïp döõ lieäu nhöõng kyù töï quaù soá löôïng quy ñònh trong oâ Width seõ bò caét
boû, coøn neáu thöøa thì seõ laøm cho kích thöôùc taäp tin lôùn moät caùch khoâng caàn thieát.
Ñieàu naøy ñuùng cho caû vieäc xaùc ñònh kích thöôùc cuûa moät soá tröôøng khaùc. Xem chi
tieát ñònh daïng tröôøng vaø caùc kieåu tröôøng trong Chöông IX.

- Laøm xong choïn OK. Ta thaáy raèng lôùp giao_thong bò “bieán maát” treân cöûa soå baûn ñoà,
cöûa soå Browser cuõng ñöôïc taét ñi.

Hình VI.1. Baûn ñoà ñöôïc soá hoaù, cöûa soå Browser cuûa noù cuøng aûnh queùt
maø töø ñoù baûn ñoà ñöôïc soá hoaù môû ra cuøng moät luùc
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Ñaây laø moät ñaëc tính cuûa MapInfo, khi thöïc hieän nhöõng thay ñoåi treân caáu truùc
baûng döõ lieäu cuûa moät lôùp baûn ñoà trong hoäp thoaïi Modify Table Structure thì lôùp
ñoù töï ñoäng ñöôïc taét ñi (nhöng khoâng phaûi ñoùng laïi).

- Ñeå hieån thò laïi baûn ñoà ñöôøng giao thoâng, ta vaøo Map > Layer Control. Choïn nuùt Add,
hoäp thoaïi Add Layer môû ra, ta choïn giao_thong roài choïn Add.

- Naïp döõ lieäu: coù nhieàu caùch ñeå naïp döõ lieäu, moãi caùch coù öu nhöôïc ñieåm rieâng. Phaàn
döôùi ñaây trình baøy 3 caùch naïp döõ lieäu.

VI.1.1.1. Naïp döõ lieäu qua cöûa soå Browser

- Choïn Map > New Browser Window, cöûa soå Browser cuûa lôùp giao_thong ñöôïc môû ra.
Luùc naøy ta thaáy raèng tröôøng thuoc_tinh ñaõ ñöôïc taïo theâm.

- Choïn Window > Tile Window, hai cöûa soå baûn ñoà vaø Browser ñeàu ñöôïc hieån thò, ñieàu
chænh kích thöôùc hai cöûa soå naøy sao cho chuùng hieån thò ñöôïc khoaûng khoâng gian to
nhaát treân maøn hình MapInfo ñeå deã thao taùc. Ta cuõng coù theå ñieàu chænh chieàu roäng
cuûa caùc tröôøng theo yù muoán.

- Nhaép chuoät vaøo moät vaät theå (moät ñöôøng) treân cöûa soå baûn ñoà ñeå choïn noù thì ta thaáy
raèng moät haøng beân cöûa soå Browser cuõng ñöôïc choïn töông öùng (oâ vuoâng beân traùi
ñöôïc toâ ñen), neáu ta khoâng thaáy haøng ñöôïc choïn (vì noù naèm ngoaøi vuøng nhìn thaáy)
thì ta coù theå laøm cho noù hieän ra baèng leänh Query > Find Selection. Ví duï ta choïn
tuyeán ñöôøng saét daøi nhaát laø tuyeán ñöôøng saét töø Baéc vaøo Nam, haøng töông öùng trong
cöûa soå Browser ñöôïc choïn, trong coät thuoc_tinh taïi haøng ñöôïc choïn, ta goõ vaøo chöõ
“ñöôøng saét” (hình VI.3.).

Hình VI.2. Hoäp thoaïi Modify Table Structure cho pheùp
thay ñoåi caáu truùc baûng MapInfo
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Chöõ “ñöôøng saét” ñöôïc hieån thò khoâng ñuùng tieáng Vieät. Muoán hieån thò ñuùng tieáng
Vieät, ta kích hoaït cöûa soå Browser roài choïn nuùt ñònh daïng kieåu chöõ. Chænh kieåu chöõ veà
VNI-Helve chaúng haïn trong oâ Font. Luùc naøy tieáng Vieät seõ hieån thò ñuùng. 

Nhö vaäy ta ñaõ naïp xong thuoäc tính cho moät vaät theå.

Töông töï nhö vaäy laàn löôït choïn caùc vaät theå (caùc ñöôøng) treân cöûa soå baûn ñoà vaø naïp
thuoäc tính cuûa noù vaøo cöûa soå Browser. Khi laøm xong, nhôù löu laïi (nhaán toå hôïp phím
<Ctrl>+<S> hay File > Save).

Caùch nhaäp döõ lieäu nhö treân coù ñieåm thuaän tieän laø khoù nhaàm laãn nhöng laïi chaäm,
nhö trong lôùp ñöôøng giao thoâng cuûa ví duï naøy, ta coù vaøi chuïc vaät theå (kieåu ñöôøng) coù
chung moät thuoäc tính laø “ñöôøng nhöïa”, nhö vaäy cöù moãi laàn choïn moät vaät theå coù thuoäc
tính laø “ñöôøng nhöïa” ta laïi phaûi goõ laïi (maëc duø ta coù theå duøng leänh Copy (<Ctrl>+<C>)
ñeå sao chöõ vöøa goõ roài daùn (<Ctrl>+<V>) sang haøng khaùc nhöng duø sao cuõng vaãn
chaäm.

VI.1.1.2. Naïp döõ lieäu baèng leänh Update Column (Caäp nhaät coät)

Hình VI.3. Naïp döõ lieäu cho vaät theå ñoà hoaï qua cöûa soå Browser.
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Caùch naïp döõ lieäu baèng phöông phaùp naùy nhö sau:
- Choïn coâng cuï choïn (hình muõi teân ñen treân thanh coâng cuï Main)
- Choïn ñöôøng thöù nhaát, giöõ <Shift> ñeå choïn theâm caùc ñöôøng khaùc coù cuøng tính chaát

maø ta ñònh naïp, ví duï “ñöôøng saét”.
- Vaøo Table > Update Column (caäp nhaät coät), hoäp thoaïi Update Column hieän ra.
- Trong Table to Update, choïn Selection (caàn caån thaän trong phaàn choïn naøy vì neáu

nhaàm coù theå laøm thay ñoåi caùc döõ lieäu khaùc)
- Trong Column to Update, choïn thuoc_tinh (teân coät caàn caäp nhaät)
- Trong oâ Value (giaù trò caàn caäp nhaät), ta goõ vaøo chöõ “ñöôøng saét”, chöõ naøy phaûi ñöôïc

ñaët trong ngoaëc keùp (hình VI.4.).

Löu yù raèng MapInfo cuõng khoâng theå hieån thò tieáng Vieät ñuùng trong caùc hoäp thoaïi
nhöng noù hieån thò ñuùng trong cöûa soå Browser vaø khi trình baøy baûn ñoà, vì theá ta
phaûi goõ cho thaät ñuùng chính taû.

- Ta coù theå choïn hay boû choïn trong oâ Browse Results, neáu ta choïn oâ naøy roài choïn OK
thì MapInfo seõ môû ra moät cöûa soå döõ lieäu nöõa, cöûa soå naøy chæ goàm coù nhöõng  vaät
theå maø ta ñaõ choïn ôû treân, vaø trong coät thuoc_tinh cuûa caùc vaät theå ñaõ choïn ñöôïc naïp
chöõ “ñöôøng saét”. Löu yù raèng neáu ñaùnh daáu choïn vaøo oâ Browse Results thì cöûa soå
môùi môû ra ñöôïc MapInfo töï ñoäng ñaët teân laø Query1 Browser. Neáu ta boû choïn trong

oâ Browse Results thì hai vaät theå treân cuõng vaãn ñöôïc naïp thuoäc tính vaøo coät
thuoc_tinh treân baûng döõ lieäu chính. Ta coù theå ñoùng cöûa soå Query1 Browser laïi baèng
leänh File > Close table, menu Close table môû ra, choïn Query1 roài choïn Close.

- Töông töï nhö vaäy, ta choïn taát caû caùc vaät theå ñöôøng laø ñöôøng nhöïa (giöõ phím <Shift>
ñeå choïn nhieàu vaät theå cuøng luùc) roài choïn Table > Update Column, trong Table to
Update, ta choïn Selection, trong Column to Update ta choïn thuoc_tinh, trong Value,
ta goõ chöõ “ñöôøng nhöïa” (trong ngoaëc keùp).

Töông töï ta choïn cuøng moät luùc taát caû caùc vaät theå naøo laø ñöôøng saét vaø duøng leänh

Hình VI.4. Nhaäp lieäu baèng leänh Update Column (caäp nhaät coät).
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Caäp nhaät coät ñeå naïp thuoäc tính vaøo cho chuùng.

Khi laøm xong nhôù löu laïi nhöõng thay ñoåi treân baèng leänh File > Save Table.

Luùc naøy ta coù theå taét cöûa soå giao_thong Browse ñi.

VI.1.1.3. Naïp döõ lieäu baèng Info Tool

Nuùt Info Tool Button ôû treân thanh coâng cuï Main. Ñaây laø moät nuùt leänh ñeå xem
thoâng tin cuûa töøng vaät theå, tuy vaäy ta coù theå lôïi duïng tính chaát naøy ñeå naïp döõ lieäu.

Caùch söû duïng coâng cuï naøy ñeå naïp thoâng tin nhö sau:
- Choïn nuùt Info.
- Di chuyeån con troû chuoät veà cöûa soå baûn ñoà, con troû chuoät bieán thaønh hình daáu coäng.
- Nhaép chuoät leân moät vaät theå ñöôøng, moät cöûa soå nhoû môû ra hieån thò thoâng tin cuûa vaät

theå ñoù (hình VI.5). Ví duï trong tröôøng hôïp naøy ta nhaép chuoät leân moät vaät theå laø
ñöôøng saét thì cöûa soå Info Tool hieän ra goàm hai haøng, haøng thöù nhaát laø haøng ID vaø
haøng thöù hai laø haøng thuoc_tinh. Haøng ID, nhö ñaõ trình baøy ban ñaàu, laø haøng maëc
ñònh vaø coù giaù trò laø 0.

- Haøng thuoc_tinh khoâng coù giaù trò gì caû. Nhìn treân baûn ñoà queùt ñeå xem ñoù laø loaïi
ñöôøng naøo, ví duï neáu ñoù laø ñöôøng saét thì ta coù theå goõ chöõ “ñöôøng saét” vaøo haøng
naøy. 

Khi naïp giaù trò laø chöõ (kieåu kyù töï) trong cöûa soå Info Tool ta khoâng caàn goõ giaù trò
trong ngoaëc keùp, vaø cuõng nhö trong taát caû caùc hoäp thoaïi cuûa MapInfo, tieáng Vieät
khoâng hieån thò ñuùng.

- Khi nhaép chuoät sang choïn moät vaät theå
khaùc, cöûa soå Info vaãn giöõ nguyeân,
nhöng caùc haøng trong ñoù hieån thò giaù
trò cuûa vaät theå môùi ñöôïc choïn. Ta laïi
naïp giaù trò thích hôïp cho vaät theå vaøo.
Tuaàn töï nhö vaäy cho ñeán heát.

* Nhaän xeùt: trong 3 caùch naïp döõ lieäu nhö
treân thì ta thaáy raèng neáu ta naïp döõ
lieäu cho nhieàu vaät theå coù cuøng moät
tính chaát (hay moät giaù trò) thì söû
duïng leänh Update column laø nhanh
choùng vaø chính xaùc nhaát. Tuy nhieân,
nhö ta seõ thaáy trong phaàn tieáp theo, neáu caùc giaù trò cuûa moãi vaät theå treân lôùp baûn
ñoà ñeàu khaùc nhau thì ta phaûi duøng caùch 1 (naïp vaøo Browser) hay caùch 3 (duøng
Info Tool). Trong tröôøng hôïp naøy, coù moät caùch tieát kieäm thôøi gian hôn nöõa laø naïp
döõ lieäu ngay trong quaù trình soá hoaù baûn ñoà. Ta seõ thaûo luaän phaàn naøy sau.

VI.1.2. Naïp döõ lieäu cho lôùp thanh_pho

Duøng leänh File > Close all ñeå ñoùng taát caû caùc lôùp ñang môû (neáu coù), neáu coù lôùp
naøo chöa coù nhöõng thay ñoåi thì MapInfo seõ hieån thò moät hoäp thoaïi hoûi ta coù löu nhöõng
thay ñoåi hay khoâng, neáu thaáy caàn thieát ta choïn Save hay Save all, neáu khoâng ta choïn
Discard hoaëc Discard all.

Hình VI.5. Hoäp thoaïi Info Tool
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Phaân tích: Chuùng ta seõ taïo thuoäc tính vaø naïp döõ lieäu theo chuù giaûi ñaõ coù treân baûn
ñoà giaáy. Khi quan saùt baûn ñoà queùt vaø chuù giaûi treân baûn ñoà ta thaáy coù nhöõng thuoäc tính
sau:

- ngoâi sao maøu ñen : thuû ñoâ,
- voøng troøn lôùn coù chaám ñen lôùn ôû giöõa : thaønh phoá
- voøng troøn vöøa coù moät chaám ñen nhoû : thò traán
- voøng troøn trôn nhoû : caùc ñieåm daân cö khaùc;

ñoàng thôøi nhöõng chaám naøo coù maøu ñoû laø tænh lî.

Nhö vaäy rieâng trong phaàn thuoäc tính ta thaáy coù hai tính chaát, 1) ñieåm ñoù laø thuû ñoâ,
thaønh phoá, thò xaõ hay ñieåm daân cö khaùc vaø 2) ñieåm ñoù coù phaûi laø tænh lî hay khoâng.
Ngoaøi ra ñöông nhieân coøn coù moät thoâng tin nöõa laø teân caùc thaønh phoá, thò xaõ.

Phaàn naøy ta seõ söû duïng phöông phaùp maõ hoaù döõ lieäu moät caùch ñôn giaûn. Ta nhaän
thaáy raèng trong tröôøng hôïp caàn phaân bieät moät ñieåm daân cö coù phaûi laø tænh lî hay khoâng
phaûi laø tænh lî, ta coù theå taïo theân moät tröôøng kieåu kyù töï (Character) vaø goõ vaøo laø “tænh
lî” vaø “khoâng phaûi tænh lî”. Ta seõ thaáy raèng caùch taïo tröôøng nhö vaäy khaù daøi doøng vaø
toán khoâng gian treân maøn hình, vaäy neáu ta quy öôùc tænh lî laø soá 1 vaø khoâng phaûi tænh lî
laø soá 0 thì vieäc naïp döõ lieäu seõ trôû neân raát ñôn giaûn vaø ít bò sai soá vì goõ nhieàu. Töông töï
nhö vaäy ñoái vôùi caùc ñieåm daân cö, ta coù theå quy öôùc nhö sau: 0: Thuû ñoâ; 1: thaønh phoá,
2: thò xaõ; 3: ñieåm daân cö khaùc.

Caùch quy öôùc nhö vaäy ñöôïc goïi laø maõ hoaù döõ lieäu. Phöông phaùp naøy laøm cho vieäc
naïp döõ lieäu ñôn giaûn hôn nhieàu, traùnh sai soá ñoàng thôøi trong moät soá tröôøng hôïp coøn
baûo maät ñöôïc thoâng tin. Löu yù raèng khi maõ hoaù döõ lieäu thì nhöõng thoâng tin maõ hoaù naøy
caàn phaûi ñöôïc ghi laïi ôû moät choã naøo ñoù ñeå traùnh nhaàm laãn hay bò queân. Ñoái vôùi nhöõng
heä thoáng baûn ñoà lôùn, chi tieát vaø coù haøng nghìn thoâng tin vaø thuoäc tính, khi maõ hoaù döõ
lieäu ngöôøi ta caàn tuaân thuû theo moät quy taéc maõ hoaù naøo ñoù ñeå ñaûm baûo khi phaùt trieån
heä thoáng baûn ñoà theâm sau naøy vieäc maõ hoaù ñöôïc deã daøng vaø khoâng bò truøng laép. Ta
seõ baøn chi tieát veà vaán ñeà naøy trong phaàn ///.

Nhö vaäy trong lôùp thanh_pho ta söû duïng leänh Table > Maintenance > Modify Table
Structure ñeå taïo ra 3 tröôøng môùi coù teân laø 1) ten (ñònh daïng kieåu Character, chieàu daøi
(width) laø 16 (vì ta thaáy teân daøi nhaát laø T.P. Hoà Chí Minh bao goàm 16 kyù töï theo boä maõ
VNI), 2) kieu (kieåu ñieåm daân cö, laø 0, 1, 2 hay 3) (ñònh daïng kieåu Small Integer) vaø 3)
thuoc_tinh (0 hay 1) (ñònh daïng kieåu Small Integer). Ta coù theå söû duïng nuùt leänh Add
Field nhieàu laàn lieân tieáp ñeå theâm nhieàu tröôøng moät laàn.

Ta baét ñaàu naïp thuoäc tính cho caùc ñieåm daân cö. Trong phaàn naøy nuùt Info Tool laø
tieän lôïi nhaát neân ta seõ söû duïng Info Tool ñeå naïp döõ lieäu. Caùch laøm:
- Môû lôùp thanh_pho vaø lôùp aûnh queùt bd_hcvn.
- Cuõng nhö trong caùc tröôøng hôïp khaùc, khi soá hoaù caùc vaät theå laø ñieåm, kieåu ñieåm maëc

ñònh laø hình ngoâi sao maøu ñen, côõ 12 point, neân khi môû treân lôùp baûn ñoà queùt caùc
thuoäc tính ôû döôùi bò che khuaát, ta laïi söû duïng leänh Map > Layer Control, choïn lôùp
thanh_pho roài choïn Display vaø ñaùnh daáu choïn vaøo oâ Style Override, chænh kieåu ñieåm
sao cho deã nhìn thaáy caùc ñaëc tính ôû döôùi lôùp baûn ñoà queùt. Trong tröôøng hôïp naøy,
ví duï ta chænh kieåu ñieåm thaønh chöõ X coù maøu vaøng, hoaëc baát kyø kieåu bieåu töôïng naøo
ñeå deã thaáy noäi dung phía döôùi tôø baûn ñoà queùt.

- Choïn nuùt Info Tool, nhaép chuoät leân moät ñieåm daân cö baát kyø, cöûa soå Info môû ra goàm
4 haøng, haøng ID maëc ñònh, haøng ten, hang kieu vaø haøng thuoc_tinh (hình VI.6).
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- Nhìn vaøo ñieåm daân cö ta vöøa nhaép chuoät xem noù teân gì, laø thaønh phoá hay thò xaõ, coù
phaûi laø tænh lî hay khoâng vaø laàn löôït naïp caùc thuoäc tính vaøo cöûa soå Info Tool theo
quy öôùc nhö ñaõ trình baøy ôû phaàn treân. Ví duï ta nhaép chuoät vaøo thuû ñoâ Haø Noäi, trong
haøng ten, ta goõ “Haø Noäi” (khoâng goõ daáu ngoaëc keùp, doøng hieån thò thöïc chaát khoâng
ñuùng kieåu chöõ), trong haøng kieu, ta goõ laø 0, trong haøng thuoc_tinh ta goõ laø 1 (vì Haø
Noäi cuõng laø moät tænh lî neáu xeùt theo thuoäc tính naøy). Ñeå di chuyeån giöõa caùc tröôøng
ta coù theå duøng phím <Tab> hay toå hôïp phím <Shift> + <Tab>.

- Nhaép chuoät sang moät ñieåm khaùc vaø laïi naïp thuoäc tính moät caùch töông töï.

Trong suoát quaù trình naïp döõ lieäu, neáu ta phaùt hieän thaáy mình soá hoaù soùt moät thaønh
phoá naøo ñoù thì ta coù theå duøng coâng cuï veõ ñieåm ñeå chaám theâm thaønh phoá ñoù, khi chaám
xong, hoäp thoaïi Info Tool seõ laäp töùc hieän leân thoâng tin cuûa ñieåm môùi veõ, ta coù theå naïp
luoân thoâng tin vaøo thaønh phoá bò soá hoaù soùt ñoù. Khi naïp xong nhôù choïn laïi nuùt leänh Info

Hình VI.6. Naïp döõ lieäu cho moät ñieåm daân cö ôû caû 3 tröôøng.
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Tool vaø nhaép chuoät leân ñieåm daân cö khaùc ñeå naïp tieáp döõ lieäu

Ta cuõng coù theå duøng nuùt leänh Grabber (hình baøn tay) treân thanh coâng cuï Main ñeå
di chuyeån baûn ñoà trong quaù trình nhaäp lieäu, di chuyeån ñeán vuøng caàn thieát xong nhôù
choïn laïi nuùt Info Tool.

Nhö vaäy ta ñaõ naïp xong döõ lieäu trong lôùp thanh_pho vôùi 3 tröôøng. Khi laøm xong nhôù
löu laïi nhöõng thay ñoåi baèng leänh File > Save Table.

Trong quaù trình naïp lieäu vôùi nhieàu vaät theå nhö vaäy, ta coù theå naïp soùt döõ lieäu moät
soá vaät theå, ñeå kieåm tra xem coù soùt moät soá ñieåm daân cö naøo chöa ñöôïc naïp döõ
lieäu hay khoâng, ta laøm theo caùch sau:

1- Choïn Query > Select, hoäp thoaïi Select môû ra
2- Trong oâ Select Records from Table, ta choïn lôùp thanh_pho; choïn nuùt Assist, hoäp

thoaïi Expression môû ra, 
3- Trong oâ Column, duøng muõi teân thaû xuoáng choïn coät ten, teân tröôøng seõ ñöôïc

chuyeån sang oâ Expression, trong oâ Operators ta choïn daáu “=”, daáu baèng ñöôïc
chuyeån sang oâ Expression, sau daáu baèng ta goõ hai daáu ngoaëc keùp lieàn nhau
(khoâng coù khoaûng traéng ôû giöõa), keát quaû laø trong oâ Expression ta ñöôïc bieåu thöùc
(hình VI.7): 

ten = ””
Nhaán chuoät vaøo nuùt Verify, neáu hoäp thoaïi MapInfo hieän ra doøng chöõ

“Syntax is correct”, thì ta ñaõ goõ bieåu thöùc ñuùng, neáu khoâng caàn kieåm tra laïi xem
ta ñaõ goõ ñuùng hay chöa; choïn OK quay laïi hoäp thoaïi Expression, nhaán OK laàn
nöõa vaø quay laïi hoäp thoaïi Select. Nhôù ñaùnh daáu choïn vaøo oâ Browse Results roài
nhaán OK.

Neáu khoâng coøn soùt thaønh phoá naøo chöa naïp döõ lieäu, MapInfo seõ hieän ra
hoäp thoâng baùo “No records selected” (töùc khoâng choïn ñöôïc baûn ghi naøo). Ta
nhaán OK roài keát thuùc.

Neáu coøn soùt moät vaøi baûn ghi chöa ñöôïc naïp döõ lieäu, moät cöûa soå Browser
(coù teân laø Queryn Browser) (trong ñoù n laø moät con soá, tuyø thuoäc vaøo soá pheùp
choïn ñaõ thöïc hieän tröôùc ñoù) ñöôïc môû ra hieån thò moät soá haøng naøo ñoù. Ta thaáy
trong tröôøng ten khoâng coù kyù töï naøo caû, töùc chöa naïp döõ lieäu, giaû söû trong tröôøng
hôïp naøy ta thaáy ñaõ naïp soùt 6 ñieåm daân cö.

Luùc naøy ñeå naïp nhöõng baûn ghi coøn soùt, vì chuùng khoâng nhieàu neân ta coù
theå naïp tröïc tieáp leân cöûa soå Broswer. 

4- Choïn Window > Tile Windows, cöûa soå baûn ñoà vaø Browser ñöôïc môû chung. Ñieàu
chænh kích thöôùc caùc cöûa soå sao cho phuø hôïp.

5- Nhaép chuoät vaøo moät oâ vuoâng treân cuûa soå Queryn Browser ñeå choïn moät haøng
baèng caùch nhaép chuoät vaøo oâ vuoâng beân traùi haøng ñoù oâ vuoâng ñöôïc toâ ñen ñoàng
thôøi moät ñieåm töông öùng treân cöûa soå baûn ñoà cuõng ñöôïc choïn.

6- Tìm ñieåm ñöôïc choïn baèng leänh Query > Find Selection. Cöûa soå baûn ñoà seõ “nhaûy”
veà vuøng coù ñieåm ñang ñöôïc choïn, ñieåm ñöôïc choïn seõ ñöôïc ñaùnh daáu maøu xanh
lô, ta coù theå phoùng to baûn ñoà baèng nuùt phoùng to - thu nhoû ñeå nhìn thaáy roõ ñieåm
ñöôïc choïn laø ñieåm daân cö naøo vaø naïp thuoäc tính vaøo töøng oâ treân cöûa soå Query1
Browser taïi haøng ñoù. 

Töông töï nhö vaäy laëp laïi böôùc 5 cho moät haøng troáng khaùc ñeå tìm vaø naïp
döõ lieäu tieáp cho nhöõng ñieåm coøn soùt.
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YÙ nghóa cuûa böôùc 1 ñeán böôùc 3 trong phaàn naøy laø: laäp moät bieåu thöùc baûo
MapInfo tìm cho ta nhöõng ñieåm naøo maø coät (tröôøng) ten roãng (giöõa hai daáu ngoaëc
keùp khoâng coù gì) vaø môû ra cöûa soå Browser lieät keâ danh saùch nhöõng ñieåm ñoù.
Ta seõ tìm hieåu kyõ hôn veà leänh Choïn (Select) vaø Bieåu thöùc (Expression) trong
caùc phaàn sau.

Trong quaù trình naïp döõ lieäu nhö treân, vì ta nhìn thoâng tin treân tôø baûn ñoà queùt ñaõ
ñaêng kyù ñöôïc môû chung vôùi caùc lôùp baûn ñoà vì theá ñoâi nhìn khoâng roõ thoâng tin treân baûn
ñoà. Toát nhaát laø neân coù moät tôø baûn ñoà giaáy beân caïnh ñeå xem thoâng tin khi khoâng nhìn
roõ treân maøn hình maùy tính.

Baèng phöông phaùp töông töï ñöôïc duøng cho nhaäp lieäu vaøo lôùp thanh_pho ta coù theå
taïo theâm tröôøng vaø naïp döõ lieäu cho caùc lôùp cac_tinh vaø lôùp song. Khi taïo tröôøng vaø naïp
döõ lieäu, coù theå löu yù moät soá ñieåm sau:
- Taïo moät tröôøng laø ten cho lôùp cac_tinh (ñònh daïng laø Character, caàn ñeå yù ñeán soá kyù

töï toái ña cuûa teân tænh ñeå naïp vaøo oâ Width sao cho khoâng thöøa maø cuõng khoâng thieáu),
taïo moät tröôøng thöù hai laø tröôøng dan_so (töùc daân soá, tröôøng naøy ñònh daïng laø
Integer)

- Khi taïo tröôøng ten cho soâng, luùc naïp döõ lieäu ta chæ caàn naïp teân con soâng, khoâng caàn
naïp chöõ “Soâng” phía tröôùc, ví duï “Soâng Hoàng” ta chæ goõ laø “Hoàng” laø ñuû. Dó nhieân
cuõng coù theå goõ ñaày ñuû coù caû chöõ “Soâng” nhöng ñieàu naøy seõ laøm taêng kích thöôùc
tröôøng leân daãn ñeán vieäc taêng kích thöôùc cuûa caùc taäp tin moät caùch khoâng caàn thieát.
Chöõ “Soâng” seõ ñöôïc ñöa leân baûn ñoà luùc trình baøy baèng moät caùch khaùc maø khoâng
caàn phaûi naïp vaøo tröôøng döõ lieäu.

VI.2. TOÁI ÖU HOAÙ BAÛN ÑOÀ SAU KHI NAÏP DÖÕ LIEÄU

Nhö ta ñaõ bieát, khi thöïc hieän soá hoaù baûn ñoà trong MapInfo, caùc vaät theå ñöôïc veõ ñeàu
coù kieåu maëc ñònh nhö ñieåm laø hình ngoâi sao maøu ñen, ñöôøng laø ñöôøng lieàn maøu ñen
daøy 1 pixel, vuøng coù maøu traéng ranh giôùi laø ñöôøng lieàn maøu ñen, neùt daøy 1 pixel. Ñieàu
naøy khieán cho khi môû caùc lôùp baûn ñoà ra raát khoù phaân bieät. Dó nhieân trong quaù trình soá

Hình VI.7. Duøng Bieåu thöùc trong leänh Select ñeå tìm nhöõng ñieåm
daân cö chöa ñöôïc naïp döõ lieäu
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hoaù, khi soá hoaù ñeán moät vaät theå coù thuoäc tính naøo ta coù theå duøng caùc nuùt coâng cuï chænh
kieåu ñieåm, kieåu ñöôøng vaø kieåu vuøng cho phuø hôïp. Tuy nhieân caùch laøm nhö vaäy maát
thôøi gian. Sau khi ñaõ naïp döõ lieäu cho caùc vaät theå treân baûn ñoà, ta coù theå thöïc hieän ñieàu
chænh baûn ñoà sao cho deã nhìn thaáy khi môû ra. Phaàn döôùi ñaây trình baøy caùch ñieàu chænh
baûn ñoà cho moät soá lôùp, caùc lôùp khaùc coù theå thöïc hieän töông töï.

VI.2.1. Ñieàu chænh lôùp song

Soâng suoái treân baûn ñoà thöôøng coù maøu xanh döông. Ta tieán haønh ñieàu chænh nhö
sau:

- Môû lôùp song ra baèng leänh File > Open Table.

- Töø menu chính choïn Map > Layer Control ñeå vaøo hoäp thoaïi Kieåm soaùt Lôùp.

- Ñaùnh daáu vaøo coät chænh söûa ôû haøng song, laøm xong choïn OK.

- Töø menu chính choïn Query, menu Query môû ra.
- Neáu trong cöûa soå chæ coù lôùp song thì ôû haøng thöù ba cuûa menu Query seõ coù tuyø choïn

nhanh laø Select All from song. Ta choïn tuyø choïn naøy. Neáu trong cöûa soå baûn ñoà coù
nhieàu lôùp ñang môû thì ta choïn Select ñeå vaøo hoäp thoaïi Select. Trong hoäp thoaïi naøy
choïn lôùp song ôû oâ Select Records from Table; taét choïn trong oâ Browse results ñi
roài choïn OK. Treân cöûa soå baûn ñoà ta thaáy taát caû caùc vaät theå trong lôùp song ñöôïc
choïn.

- Töø menu chính choïn Options > Line Style hay choïn nhanh baèng nuùt ñònh daïng kieåu

ñöôøng treân thanh coâng cuï Drawing. Hoäp thoaïi Line Style môû ra.

- Trong phaàn Style, giöõ nguyeân kieåu ñöôøng laø ñöôøng lieàn; trong oâ Color chænh ñöôøng
veà maøu xanh döông; trong phaàn Width, ôû oâ Pixel giöõ nguyeân chieàu daøy ñöôøng laø 1.

- Laøm xong choïn OK. Ta thaáy taát caû caùc ñöôøng trong lôùp song ñöôïc ñoåi thaønh maøu
xanh döông.

- Choïn File > Save Table hay nhaán toå hôïp phím <Ctrl>+<S> hay nhaép chuoät vaøo nuùt
löu baûng . Hoäp thoaïi Save Table môû ra, choïn lôùp song roài nhaán Save.

VI.2.2. Ñieàu chænh lôùp giao_thong

Lôùp giao thoâng coù hai kieåu ñöôøng ñaõ ñöôïc naïp döõ lieäu vaøo tröôøng thuoc_tinh laø
ñöôøng nhöïa vaø ñöôøng saét. Giaû söû ta seõ chænh ñöôøng nhöïa thaønh maøu ñoû, neùt daøy 2
pixel vaø ñöôøng saét thaønh maøu ñen, neùt daøy 2 pixel. Caùch thöïc hieän:

- Môû lôùp giao_thong ra.

- Choïn Map > Layer Control ñeå vaøo hoäp thoaïi Kieåm soaùt Lôùp.

- Ñaùnh daáu vaøo coät chænh söûa ôû haøng giao_thong roài choïn OK.

- Choïn Query > Select, hoäp thoaïi Select môû ra.

- Trong oâ Select Fecords from Table choïn lôùp giao_thong, taét choïn trong oâ Browse
Results.
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- Nhaép chuoät vaøo nuùt Assist hoäp thoaïi Expression môû ra.

- Nhaép chuoät vaøo nuùt thaû xuoáng trong oâ Column choïn tröôøng thuoc_tinh, teân
thuoc_tinh ñöôïc ñöa vaøo hoäp thoaïi goõ bieåu thöùc beân traùi.

- Trong oâ Bieåu thöùc goõ theâm vaøo sau teân tröôøng daáu baèng (=) vaø chöõ ñöôøng saét trong
ngoaëc keùp. Löu yù: chöõ naøy phaûi gioáng vôùi chöõ ta ñaõ naïp vaøo tröôøng döõ lieäu luùc ñaàu.
Neáu khoâng nhôù, ta môû cöûa soå döõ lieäu cuûa lôùp giao_thong ra, nhaép chuoät vaøo haøng
naøo coù chöõ “ñöôøng saét” thì chöõ ñoù ñöôïc choïn, nhaán toå hôïp phím <Ctrl>+<C> ñeå
cheùp noù vaøo boä nhôù taïm roài môùi chaïy leänh Select, khi goõ bieåu thöùc ta duøng leänh
<Ctrl>+<V> ñeå daùn chöõ ñoù vaøo bieåu thöùc cho chính xaùc.

- Laøm xong choïn OK hai laàn. Taát caû caùc ñöôøng trong lôùp giao_thong coù thuoäc tính laø
“ñöôøng saét” ñöôïc choïn.

- Choïn Options > LIne Style hay nhaép chuoät choïn nuùt Line Style treân thanh coâng
cuï Main.

- Chænh kieåu ñöôøng töông töï ñaõ laøm vôùi lôùp song, ñoåi sang maøu ñen vaø neùt daøy 2
pixel.

- Thöïc hieän laïi leänh Query > Select nhöng goõ chöõ ñöôøng nhöïa vaø chænh thaønh ñöôøng
maøu ñoû, neùt daøy 2 pixel.

- Choïn File > Save Table hay nhaán toå hôïp phím <Ctrl>+<S> hoaëc nhaép chuoät vaøo nuùt

Save Table treân thanh coâng cuï Standard. Hoäp thoaïi Save Table môû ra, choïn

lôùp giao_thong roài choïn Save.

Nhö vaäy lôùp giao_thong ñaõ ñöôïc ñieàu chænh kieåu ñöôøng cho phuø hôïp vôùi thuoäc tính
cuûa chuùng.

Thöïc hieän töông töï ñoái vôùi lôùp thanh_pho vaø ñieàu chænh caùc bieåu töôïng ñieåm theo
tröôøng kieu (kieåu) töông öùng vôùi caùc quy öôùc maõ hoaù treân phaàn naïp döõ lieäu (0: Thuû
ñoâ, 1: Thaønh phoá, 2: Thò xaõ, 3: Ñieåm daân cö khaùc). Vì tröôøng kieu ñöôïc ñònh daïng laø
kieåu soá nguyeân nhoû (Small Integer) neân khi goõ giaù trò trong hoäp thoaïi Select, khoâng
ñöôïc goõ daáu ngoaëc keùp, ví duï kieu=2 laø ñuùng nhöng kieu=”2” laø sai. Dó nhieân
neáu ta ñònh daïng tröôøng kieu laø kyù töï (Character) vaø naïp vaøo ñoù caùc chöõ soá (chöù khoâng
phaûi con soá) 1, 2, 3 vaø 4 thì khi thöïc hieän leänh Select ta phaûi ñeå trong ngoaëc keùp.

Thöïc hieän ñieàu chænh kieåu cho caùc lôùp khaùc moät caùch töô g töï. Rieâng lôùp cac_tinh
neáu ñoåi kieåu cuûa töøng tænh thaønh caùc maøu khaùc nhau raát maát thôøi gian, ta thöïc hieän
baèng moät caùch khaùc seõ ñöôïc ñeà caäp trong Chöông  VIII, Trình baøy baûn ñoà.
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