
CHÖÔNG  VII. 
THOÂNG TIN CUÛA CAÙC VAÄT THEÅ TREÂN BAÛN ÑOÀ SOÁ

Moät baûn ñoà treân MapInfo ñöôïc hình thaønh bôûi nhieàu lôùp khaùc nhau. Vì vaäy tuyø theo
nhu caàu ta coù theå môû moät hay nhieàu lôùp baûn ñoà ñeå hieån thò caùc thoâng tin caàn thieát.
Ñaây laø moät ñaëc ñieåm maø baûn ñoà giaáy khoâng coù ñöôïc. Baûn ñoà giaáy ñöôïc xaây döïng cho
moät muïc ñích söû duïng naøo ñoù vaø khi ñöôïc in ra chuùng khoâng theå thay ñoåi ñöôïc nöõa.
Ví duï ta khoâng theå boû ñöôøng giao thoâng ra khoûi moät tôø baûn ñoà giaáy ñeå nhìn thaáy roõ
ranh giôùi caùc quaän chaúng haïn. Muoán laøm ñieàu naøy ñoái vôùi baûn ñoà giaáy ta phaûi can laïi
phaàn thoâng tin muoán coù.

Tuy nhieân ngoaøi nhöõng öu ñieåm treân (hieån thò thoâng tin treân baûn ñoà theo yù muoán),
MapInfo coøn coù moät soá tính naêng khaùc ñeå laáy thoâng tin treân baûn ñoà soá. Ta seõ laàn löôït
xem xeùt moät soá leänh nhö vaäy.

Löu yù raèng caùc thoâng tin veà ñòa lyù do MapInfo töï ñoäng tính toaùn treân maùy tính phaûi
ñöôïc caên cöù töø nhöõng lôùp baûn ñoà ñöôïc soá hoaù moät caùch chính xaùc, neáu khoâng thoâng
tin thu ñöôïc seõ sai. Trong tröôøng hôïp chuùng ta soá hoaù moät baûn ñoà töø aûnh queùt ñaõ
ñaêng kyù thì baûn ñoà queùt phaûi ñöôïc ñaêng kyù chính xaùc, neáu khoâng nhöõng lôùp baûn ñoà
soá hoaù töø aûnh queùt ñaêng kyù cuõng seõ bò sai vaø caùc thoâng tin ñòa lyù do chuùng cung caáp
töø MapInfo cuõng khoâng chính xaùc.

VII.1. XEM CAÙC THOÂNG TIN ÑÒA LYÙ CUÛA VAÄT THEÅ TREÂN BAÛN ÑOÀ 

Haõy môû nhöõng lôùp baûn
ñoà ta ñaõ laøm coù caùc kieåu vaät
theå khaùc nhau ñeå thöïc taäp
phaàn naøy. Vì caùc baûn ñoà maø
ta ñaõ taïo ra töø moät aûnh queùt
ñaõ ñaêng kyù heä quy chieáu laø
Longitude/Latitude (WGS84)
neân nhöõng thoâng tin veà toaï
ñoä laø kinh ñoä vaø vó ñoä. Phaàn
trình baøy döôùi ñaây chæ ñeà
caäp ñeán ñôn vò toaï ñoä kieåu
naøy. Tuyø theo heä quy chieáu
ñöôïc söû duïng maø ñôn vò toaï
ñoä hieän ra trong cöûa soå
thoâng tin coù theå khaùc nhau.Hình VII.1. Hoäp thoaïi Point Object - Hieån thò toaï ñoä

ñieåm theo ñoä thaäp phaân vaø theo ñoä - phuùt - giaây.
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Ñeå xem caùc thoâng tin veà ñòa lyù cuûa moät vaät theå trong moät lôùp baûn ñoà, ta laøm nhö
sau: Söû duïng coâng cuï choïn nhaép chuoät choïn vaät theå ñoù, choïn Edit > Get Info. Moät cöûa
soå seõ môû ra cho bieát caùc thoâng tin cuûa vaät theå ñöôïc choïn. Ta cuõng coù theå thöïc hieän
taét leänh naøy baèng caùch duøng coâng cuï choïn nhaép chuoät ñuùp leân vaät theå ñoù.

VII.1.1.Vaät theå kieåu ñieåm

Caùc vaät theå kieåu ñieåm
chæ coù moät thoâng tin duy
nhaát laø toaï ñoä cuûa ñieåm. 

Thoâng tin hieån thò laø toaï
ñoä cuûa vaät theå ñieåm ñöôïc
choïn (hình VII.1). LocationX
laø kinh ñoä, LocationY laø vó
ñoä. Theo maëc ñònh toaï ñoä
hieän ra laø ñoä thaäp phaân.
Neáu muoán toaï ñoä hieän ra laø
Ñoä - Phuùt - Giaây thì ta laøm
nhö sau: Choïn Map >
Options; ñaùnh daáu choïn vaøo oâ Show DMS trong hoäp thoaïi Map Options.

Neáu lôùp baûn ñoà ñang môû ñöôïc ñaùnh daáu ôû cheá ñoä chænh söûa thì hoäp thoaïi naøy hieän
ra hôi khaùc (hình VII.2). Hai oâ LocationX vaø LocationY hieän ra ôû cheá ñoä coù theå thay ñoåi
giaù trò toaï ñoä. Neáu ta thay ñoåi caùc thoâng soá trong hai oâ naøy thì khi choïn OK ñieåm ñoù seõ
“nhaûy” ñeán vò trí maø ta goõ toaï ñoä. Ngoaøi ra phía döôùi haøng toaï ñoä coøn coù nuùt Style cho
pheùp ta chænh kieåu bieåu töôïng cuûa ñieåm ñang ñöôïc choïn.

VII.1.2. Vaät theå kieåu ñöôøng

ÔÛ ñaây ta chæ xem xeùt thoâng tin cuûa vaät theå kieåu ñöôøng thöôøng söû duïng nhaát laø
ñöôøng gaáp khuùc (polyline).
Veà thoâng tin cuûa caùc vaät theå
kieåu ñöôøng khaùc nhö hình
cung (arc) vaø ñöôøng thaúng
(line), xin xem trong phaàn
/////. Hoäp thoaïi hieån thò
thoâng tin cuûa vaät theå kieåu
ñöôøng coù nhieàu thoâng tin
hôn (hình VII.3). 

BoundX1 vaø BoundX2 cho
bieát toaï ñoä caän traùi vaø caän
phaûi cuûa ñöôøng ñoù.
BoundY1 vaø BoundY2 cho
bieát caän döôùi vaø caän treân
cuûa noù. CenterX vaø CenterY
cho bieát toaï ñoä troïng taâm
cuûa ñöôøng. Total Length
cho bieát chieàu daøi cuûa vaät
theå ñöôøng. Neáu heä quy

Hình VII.2. Hoäp thoaïi Point Object, cheá ñoä chænh söûa.

Hình VII.3. Hoäp thoaïi Polyline Object - hieån thò
thoâng tin veà vaät theå kieåu ñöôøng.
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chieáu coù toaï ñoä theo heä
kinh/vó thì ñôn vò ño chieàu
daøi maëc ñònh laø daëm (mile -
vieát taét laø mi). Neáu heä quy
chieáu laø None Earth thì ñôn
vò ño chieàu daøi seõ phuï
thuoäc vaøo ñôn vò ñöôïc khai
baùo khi choïn heä quy chieáu
ñoù. Xem theâm phaàn heä quy
chieáu trong Chöông XIX.
Muoán hieån thò ñôn vò ño
khoaûng caùch khaùc ta vaøo
Map > Options; trong phaàn
Map Units, choïn ñôn vò
khoaûng caùch khaùc trong oâ
Distance Units. Doøng Line
Segments cho bieát ñöôøng
ñöôïc choïn goàm bao nhieâu
ñoaïn. Sections cho bieát
ñöôøng ñoù goàm bao nhieâu
phaàn. Ví duï nhö ta veõ hai
vaät theå ñöôøng caùch xa nhau, sau ñoù duøng leänh goäp (Combine) ñeå nhaäp chung laïi laøm
moät thì vaät theå ñöôøng taïo thaønh seõ ñöôïc xem laø coù 2 phaàn. Xin xem theâm leänh
Combine trong  Chöông V, phaàn Chænh söûa vaät theå.

Neáu lôùp chöùa vaät theå ñang ñöôïc choïn ôû cheá ñoä chænh söûa, cöûa soå hieån thò cuõng
khaùc ñi (hình VII.4). Caùc oâ toaï ñoä cho pheùp thay ñoåi giaù trò. Khi thay ñoåi giaù trò trong
caùc oâ BoundX1, BoundX2 vaø BoundY1, BoundY2 thì vaät theå ñöôøng seõ bò co, daõn. Neáu
thay ñoåi toaï ñoä trong caùc oâ CenterX vaø CenterY thì ñöôøng ñoù seõ dòch leân-xuoáng, traùi-
phaûi. Phía döôùi ôû goùc phaûi cuõng coù nuùt leänh Style cho pheùp ta chænh kieåu ñöôøng. Goùc
döôùi beân traùi coù tuyø choïn Smooth, ñaùnh daáu oâ naøy thì ñöôøng seõ ñöôïc “bo troøn”. 

VII.1.3. Vaät theå kieåu vuøng

Caùc thoâng tin hieån thò
khi choïn moät vaät theå kieåu
vuøng gioáng vôùi vaät theå kieåu
ñöôøng, chæ khaùc laø coù theâm
moät soá thoâng tin nöõa (Hình
VII.5). Total Area cho bieát
dieän tích cuûa vuøng ñöôïc
choïn. Ñoái vôùi nhöõng baûn ñoà
coù heä quy chieáu theo heä
kinh/vó ñoä thì ñôn vò dieän
tích maëc ñònh laø daëm vuoâng
(square mile - vieát taét sq
mi). Neáu muoán ñoåi dieän tích
veà ñôn vò khaùc ta vaøo Map
> Options, trong phaàn Map

Hình VII.4. Hoäp thoaïi Polyline Objects - thoâng tin veà
vaät theå kieåu ñöôøng (polyline) ôû cheá ñoä chænh söûa.

Hình VII.5. Hoäp thoaïi Region Object - thoâng tin veà vaät
theå kieåu vuøng ôû cheá ñoä chænh söûa.
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Units, ñoåi ñôn vò ño dieän tích trong oâ Area Units. Ñôn vò dieän tích thöôøng ñöôïc söû duïng
ôû nöôùc ta laø meùt vuoâng (square meters), heùcta (hectare) vaø kiloâmeùt vuoâng (square kilo-
meters). Haøng Total Perimeter cho bieát chu vi toång coäng cuûa vuøng ñang ñöôïc choïn.
Line segments cho bieát toång soá ñoaïn cuûa vaät theå kieåu vuøng ñöôïc choïn. Töông töï nhö
trong vaät theå kieåu ñöôøng, moät vaät theå kieåu vuøng coù theå goàm hai phaàn taùch rôøi nhau.
Soá vuøng ñoù ñöôïc thoâng baùo trong doøng Polygons (ña giaùc). Khi lôùp chöùa vaät theå vuøng
ñöôïc choïn ôû cheá ñoä chænh söûa, thay ñoåi caùc thoâng soá trong caùc oâ toïa ñoä cuõng laøm
thay ñoåi hình daïng cuûa vaät theå ñoù hay laøm di chuyeån vò trí cuûa noù.

VII.1.4. Vaät theå kieåu kyù töï

Vaät theå kieåu kyù töï laø
moät loaïi vaät theå ñaëc bieät
trong MapInfo. Caùc leänh
lieân quan ñeán vaät theå
kieåu kyù töï ñaõ ñöôïc trình
baøy chi tieát trong
Chöông V, muïc V.3.4.
Hình VII.6 ñöôïc ñöa ra
nhaèm giuùp ñoäc giaû nhôù
laïi caùc chi tieát cuûa hoäp
thoaïi naøy.

Ngoaøi caùc thoâng tin
veà ñòa lyù nhö treân (toaï
ñoä, chieàu daøi, dieän tích,
giôùi haïn,...) nhö ta ñaõ
thaáy trong phaàn VII.1,
nuùt leänh Info Tool treân
thanh coâng cuï Main coù
theå cho pheùp ta xem caùc
thoâng tin veà döõ lieäu ñaõ
ñöôïc naïp cho moät vaät
theå.

VII.2. NAÏP CAÙC THOÂNG TIN VEÀ ÑÒA LYÙ VAØO BAÛNG DÖÕ LIEÄU CUÛA LÔÙP BAÛN ÑOÀ

Nhö ñaõ thaáy, khi muoán xem thoâng tin ñòa lyù cuûa moät vaät theå naøo ñoù ta phaûi choïn
vaät theå ñoù roài duøng leänh Edit > Get Info hoaëc nhaép chuoät ñuùp leân vaät theå ñoù. Caùch
laøm naøy coù moät ñieåm baát tieän laø chæ xem ñöôïc thoâng tin cuûa moät vaät theå duy nhaát. Khi
muoán xem thoâng tin cuûa moät vaät theå khaùc ta laïi phaûi choïn vaät theå ñoù. MapInfo coù moät
vaøi haøm soá cho pheùp ta naïp moät soá thoâng tin ñòa lyù quan troïng nhö toaï ñoä, chieàu daøi,
dieän tích,... vaøo baûng döõ lieäu cuûa lôùp baûn ñoà moät caùch töï ñoäng. Phaàn döôùi ñaây seõ trình
baøy caùch naïp caùc thoâng tin ñòa lyù quan troïng cuûa caùc vaät theå ñoà hoaï treân baûn ñoà vaøo
baûng döõ lieäu cuûa chuùng.

Hình VII.6. Hoäp thoaïi Text Object - thoâng tin veà vaät theå
kieåu kyù töï ôû cheá ñoä chænh söûa.
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VII.2.1. Naïp toaï ñoä cuûa caùc vaät theå ñieåm

Haõy môû lôùp thanh_pho ra baèng leänh File > Open Table ñeå thöïc taäp leänh naøy. Ta
seõ tieán haønh naïp toaï ñoä caùc thaønh phoá, thò xaõ trong lôùp naøy.

Toaï ñoä cuûa moät ñieåm ñöôïc xaùc ñònh baèng hai giaù trò: kinh ñoä vaø vó ñoä. Vì vaäy muoán
chöùa döõ lieäu toaï ñoä naøy ta caàn coù hai coät, moät coät ñeå chöùa kinh ñoä vaø moät coät chöùa
vó ñoä. Ta seõ taïo theâm hai coät nöõa. Caùch laøm nhö sau:
- Choïn Table > Maintenance > Table Structure. Hoäp thoaïi Modify Table Structure môû

ra.
- Choïn Add Field, ñaët teân cho tröôøng môùi trong oâ Name laø kinh_do, kieåu laø Float.
- Choïn Add Field laàn nöõa, ñaët teân cho tröôøng thöù hai laø vi_do, kieåu cuõng laø Float.
- Xong choïn OK.

MapInfo töï ñoäng ñoùng cöûa soå baûn ñoà vaø/hay cöûa soå döõ lieäu cuûa lôùp ñoù laïi.

Ñeå coù theå nhìn thaáy caùc toaï ñoä ñöôïc naïp vaøo, môû baûng döõ lieäu cuûa lôùp thanh_pho
ra baèng leänh Window > New Browser Window > thanh_pho. Ta thaáy raèng hai coät môùi
ñaõ ñöôïc taïo theâm.

Hình VII.7. Hoäp thoaïi Update Column (ôû phía sau)
vaø Hoäp thoaïi Expression trong leänh caäp nhaät
coät kinh_do cho lôùp thanh_pho.
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Laàn löôït naïp toïa ñoä cho coät kinh_do vaø vi_do nhö sau:
- Choïn Table > Update Column, hoäp thoaïi Update Column môû ra.
- Choïn teân lôùp laø thanh_pho trong oâ Table to Update; trong oâ Column to Update ta

choïn kinh_do.
- Nhaán chuoät choïn nuùt Assist, hoäp thoaïi Expression môû ra.
- Nhaán chuoät vaøo nuùt thaû xuoáng ôû oâ Functions (haøm soá) vaø choïn haøm CentroidX;

xong choïn OK.
- Quay trôû laïi hoäp thoaïi Update Column, ta thaáy bieåu thöùc trong oâ Value laø

“CentroidX(obj)” (hình VII.7).
- Taét choïn trong oâ Browse Results ñi roài choïn OK.

MapInfo tính toaùn vaøi giaây vaø ta thaáy trong tröôøng kinh_do taát caû caùc haøng ñeàu
ñöôïc naïp kinh ñoä vaøo. Toaï ñoä ôû ñaây ñöôïc tính baèng ñoä thaäp phaân

Ñoái vôùi coät vi_do caùch laøm hoaøn toaøn töông töï, chæ khaùc laø trong oâ Column to
Update ta choïn tröôøng vi_do vaø haøm soá söû duïng laø CentroidY.

Nhö vaäy taát caû caùc baûn ghi (haøng) ñeàu ñöôïc naïp trò soá toaï ñoä vaøo hai coät kinh_do
vaø vi_do. Töø ñaây trôû ñi ta coù theå môû baûng döõ lieäu ra xem toaï ñoä cuûa töøng  thaønh phoá,
thò xaõ maø khoâng caàn nhaép chuoät vaøo chuùng treân baûn ñoà nöõa. Choïn leänh löu (File >
Save Table) ñeå giöõ laïi nhöõng thoâng tin vöøa môùi ñöôïc caäp nhaät töï ñoäng treân neáu muoán.

VII.2.2. Naïp thoâng tin cuûa caùc vaät theå kieåu ñöôøng

Ñoái vôùi caùc vaät theå kieåu ñöôøng, thoâng tin quan troïng nhaát laø chieàu daøi cuûa vaät theå.
Ta seõ naïp chieàu daøi cuûa caùc con soâng trong lôùp song. Tröôùc heát ta cuõng phaûi taïo moät
tröôøng ñeå chöùa chieàu daøi caùc con soâng. Caùch laøm:
- Ñoùng lôùp thanh_pho ôû phaàn treân laïi baèng leänh File > Close Table.
- Môû lôùp song baèng leänh File > Open Table.
- Töø menu chính choïn Table > Maintenance > Table Structure.
- Choïn Add Field trong hoäp thoaïi Modify Table Structure, ñaët teân tröôøng môùi trong oâ

Name laø chieu_dai, choïn kieåu trong Type laø Float; xong choïn OK.
MapInfo ñoùng lôùp song laïi trong caùc cöûa soå lieân quan noù.

- Choïn Window > New Browser Window, choïn lôùp song ñeå môû baûng döõ lieäu cuûa lôùp
song ra. Tröôøng chieu_dai ñaõ ñöôïc taïo theâm.

Naïp chieàu daøi cuûa caùc con soâng vaøo tröôøng môùi naøy nhö sau:
- Choïn Table > Update Column.
- Choïn lôùp song trong oâ Table to Update; trong Column to Update choïn tröôøng

chieu_dai.
- Nhaán chuoät choïn nuùt Assist ñeå môû hoäp thoaïi Expression ra.
- ÔÛ oâ Functions, trong danh saùch thaû xuoáng choïn haøm ObjectLen, doøng bieåu thöùc

hieån thò trong oâ Expression laø ObjectLen(obj, ”mi”). Söûa ñôn vò ño löôøng
maëc ñònh trong ngoaëc keùp mi (daëm) thaønh km (kiloâmeùt) vaø choïn OK.

- Bieåu thöùc hieån thò trong oâ Value seõ laø ObjectLen(obj,“km”) (hình VII.8).
- Taét choïn trong oâ Browse Results ñi roài choïn OK.
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Moät thôøi gian ngaén sau taát caû caùc baûn ghi (haøng) trong lôùp song ñeàu ñöôïc naïp
chieàu daøi (tính baèng km). Nhö vaäy ta ñaõ coù chieàu daøi cuûa taát caû caùc con soâng ñöôïc
naïp töï ñoäng. Neáu muoán ta coù theå thay ñoåi chieàu daøi ñôn vò ño khi nhaäp haøm soá, ví duï

neáu muoán MapInfo tính chieàu daøi baèng meùt thì thay vì söûa chöõ “mi” thaønh “km” thì ta
söûa thaønh “m” (meùt) trong khi laäp bieåu thöùc ôû phaàn treân.

Töông töï nhö vaäy ta coù theå taïo tröôøng môùi vaø naïp chieàu daøi cho taát caû caùc ñöôøng
giao thoâng chính trong lôùp giao_thong.

Ta cuõng coù theå naïp trung ñieåm cuûa caùc vaät theå ñöôøng baèng hai haøm soá CentroidX
vaø CentroidY, tuy nhieân thoâng tin naøy khoâng maáy höõu ích ñoái vôùi vaät theå kieåu ñöôøng.

VII.2.3. Naïp thoâng tin cho caùc vaät theå kieåu vuøng

Caùc vaät theå kieåu vuøng coù hai thoâng tin ñòa lyù quan troïng ñaùng ñeå ta quan taâm laø
chu vi vaø dieän tích. Lôùp cac_tinh seõ ñöôïc söû duïng laøm ví duï cho caùc leänh naøy. Ta seõ
thöïc hieän naïp döõ lieäu naøy nhö sau:
- Ñoùng lôùp song trong ví duï tröôùc laïi. Neáu hoäp thoaïi löu baûng hieän ra hoûi ta coù löu

nhöõng thay ñoåi khoâng thì ta choïn Save ñeå löu hay Discard (boû) neáu muoán.

Hình VII.8. Hoäp thoaïi Update Column (ôû phía sau) vaø
Hoäp thoaïi Expression trong leänh caäp nhaät coät
chieu_dai cho lôùp song.
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- Môû lôùp cac_tinh ra.
- Choïn Table > Maintenance > Table Structure.
- Taïo hai tröôøng môùi laø chu_vi vaø dien_tich cho lôùp caùc tænh, kieåu cuûa hai tröôøng naøy

ñeàu laø Float.
- Môû cöûa soå Browser cuûa lôùp cac_tinh ra laïi ñeå coù theå nhìn thaáy söï thay ñoåi.

Ta caäp nhaät coät chu_vi nhö sau:
- Choïn Table > Update Column.
- Trong Table to Update choïn cac_tinh, trong Column to Update choïn chu_vi.
- Nhaán nuùt Assist. Hoäp thoaïi Expression môû ra.
- Trong hoäp thoaïi Expression, töø danh saùch thaû xuoáng cuûa oâ Functions ta choïn

Perimeter (chu vi).
- Trong hoäp Type an Expression, söûa chöõ “mi” trong ngoaëc keùp thaønh “km” ñeå ñoåi

ñôn vò tính chieàu daøi. Xong choïn OK.
- Trong hoäp thoaïi Update Column, taét choïn trong oâ Browse Results roài choïn OK.

Chu vi cuûa caùc tænh ñöôïc naïp xong, tính baèng kiloâmeùt (hình VII.9).

Ta caäp nhaät coät dien_tich nhö sau:

Hình VII.9. Naïp chu vi cuûa vaät theå kieåu vuøng.
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- Choïn Table > Update Column.
- Trong Table to Update choïn cac_tinh, trong Column to Update choïn dien_tich.
- Nhaán nuùt Assist. Hoäp thoaïi Expression môû ra.
- Trong hoäp thoaïi Expression, töø danh saùch thaû xuoáng cuûa oâ Functions, choïn haøm

Area (dieän tích).
- Trong bieåu thöùc Area(obj, “sq mi”) söûa chöõ “sq mi” (daëm vuoâng) thaønh “hectare”

(heùcta); hoaëc neáu muoán tính laø km2 thì ta söûa thaønh “sq km”
- Choïn OK hai laàn.

Coät dien_tich ñöôïc naïp caùc thoâng soá laø dieän tích cuûa taát caû caùc vuøng.

* Quan troïng: löu yù laø khi naïp thoâng tin ñòa lyù cuûa caùc vaät theå theo phöông phaùp nhö
treân, MapInfo tính toaùn caùc giaù trò döïa vaøo vaät theå ñoà hoaï ñaõ ñöôïc veõ treân baûn ñoà.
Neáu sau naøy ta coù chænh söûa caùc baûn ñoà thì nhöõng thoâng tin ñoù seõ bò thay ñoåi. Ta phaûi
chaïy laïi leänh Update Column vaø cheùp ñeø döõ lieäu caäp nhaät môùi leân nhöõng döõ lieäu cuõ.
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