
CHÖÔNG IX. 
TOÅNG QUAÙT PHÖÔNG PHAÙP 
SOÁ HOAÙ BAÛN ÑOÀ TÖØ AÛNH QUEÙT

Trong caùc chöông tröôùc chuùng ta ñaõ xem qua caùch xaây döïng moät baûn ñoà soá hoaù
tröïc tieáp töø aûnh queùt ñaêng kyù treân MapInfo. Chöông naøy heä thoáng hoaù laïi caùc böôùc
quan troïng nhaát trong quaù trình xaây döïng baûn ñoà soá treân MapInfo töø aûnh queùt ñaõ ñaêng
kyù, moät quaù trình ñöôïc goïi laø head-up digitizing, soá hoaù ngay treân maøn hình.

IX.1. ÑAÊNG KYÙ AÛNH QUEÙT

Baûn ñoà ñöôïc queùt vaøo maùy tính baèng maùy queùt. Treân baûn ñoà phaûi bieát toaï ñoä ít
nhaát 3 ñieåm (toát nhaát laø töø 4 ñieåm trôû leân). Caùch ñaêng kyù aûnh queùt nhö sau:

- Choïn File > Open Table (hay Open a Table töø hoäp thoaïi Quick Start).
- Trong muïc Files of type ta choïn Raster Image roài choïn aûnh queùt caàn ñaêng kyù.

- Choïn Register trong hoäp thoaïi MapInfo ñeå ñaêng kyù aûnh queùt.

- Choïn heä quy chieáu cho baûn ñoà baèng nuùt Projection. Heä quy chieáu choïn phaûi gioáng
vôùi heä quy chieáu cuûa aûnh queùt. Neáu khoâng bieát heä quy chieáu maø coù toaï ñoä caùc ñieåm
khoáng cheá laø kinh ñoä/vó ñoä thì choïn trong Category laø Longitude/Latitude vaø trong
Category Member laø Longitude/Latitude (WGS84).

- Naïp toaï ñoä cuûa caùc ñieåm khoáng cheá vaøo baûn ñoà trong hoäp thoaïi Image Registration
baèng caùch nhaép chuoät vaøo ñieåm ñaõ bieát toaï ñoä, hoäp thoaïi Add Control Point môû ra,
naïp toaï ñoä cho ñieåm khoáng cheá vaøo hai oâ MapX vaø MapY (X laø kinh, Y laø vó ñoä).
Toaï ñoä naïp vaøo phaûi ñöôïc tính baèng ñoä thaäp phaân. Di chuyeån baûn ñoà ñeå tìm ñieåm
khoáng cheá baèng hai thanh tröôït ngang vaø ñöùng, phoùng to - thu nhoû baûn ñoà baèng
hai nuùt coäng vaø tröø ôû döôùi baûn ñoà. Neáu ñaêng kyù baûn ñoà khoâng coù toaï ñoä, ta choïn
heä quy chieáu laø phi quaû ñaát (Non-Earth). Xem chi tieát trong Chöông III, muïc III.4.

- Sau khi naïp toaï ñoä caùc ñieåm khoáng cheá xong, kieåm tra sai soá (tính baèng pixel - ñieåm
aûnh). Quy ñoåi sai soá tính baèng ñieåm aûnh veà kích thöôùc thöïc ñeå xem sai soá coù theå
chaáp nhaän ñöôïc hay khoâng. Neáu chaäp nhaän ñöôïc thì choïn OK trong hoäp thoaïi
Image Registration ñeå môû aûnh queùt.

Chuù yù: Khi ñaêng kyù aûnh queùt maø coù moät ñieåm naøo ñoù sai soá nhieàu nhöng khoâng
theå chænh söûa baèng caùch thay ñoåi vò trí ñieåm khoáng cheá hay thay ñoåi toaï ñoä ñieåm khoáng
cheá, hoaëc ta cuõng khoâng theå tìm ñöôïc aûnh queùt chaát löôïng toát hôn thì neân taêng theâm
soá löôïng ñieåm khoáng cheá. Caùc ñieåm khoáng cheá môùi neân ñöôïc theâm vaøo vuøng xung
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quanh ñieåm sai soá nhieàu ñoàng thôøi theâm moät soá ñieåm khoáng cheá vaøo vuøng giöõa aûnh
queùt. Xem chi tieát caùch thay ñoåi hay chænh söûa aûnh queùt ñaõ ñaêng kyù trong Chöông
XVII, muïc XVII.2.5.

IX.2. SOÁ HOAÙ BAÛN ÑOÀ

IX.2.1. Phöông phaùp tröïc tieáp

Toång quaùt phöông phaùp soá hoaù nhö sau:

- Môû aûnh queùt ñaõ ñaêng kyù ra baèng leänh File > Open Table.

- Choïn Map > Layer Control.
- Ñaùnh daáu chænh söûa vaøo lôùp Cosmetic.

- Tieán haønh soá hoaù baûn ñoà baèng caùch duøng caùc coâng cuï veõ treân thanh coâng cuï
Drawing. Caùc thoâng tin treân baûn ñoà caàn ñöôïc soá hoaù theo nhoùm. Caùc nhoùm vaät theå
ñöôïc löu trong moät lôùp baûn ñoà phaûi coù cuøng kieåu ñeå deã quaûn lyù sau naøy.

- Khi soá hoaù xong duøng leänh Map > Save Cosmetic Objects ñeå löu caùc vaät theå ñaõ veõ
thaønh moät baûng MapInfo hoaøn chænh.

- Coù theå chæ caàn veõ vaøi vaät theå ñaàu tieân laø coù theå duøng leänh treân ñeå löu nhöõng gì ñaõ
veõ thaønh moät lôùp vaø ñaët teân cho noù. Xong vaøo laïi Map > Layer Control vaø ñaùnh daáu
chænh söûa vaøo lôùp môùi löu roài quay laïi veõ tieáp.

Quan troïng: Moät baûn ñoà ñöôïc soá hoaù töø aûnh queùt ñaêng kyù sai nhieàu thì hoaøn toaøn
khoâng theå chænh söûa ñöôïc maø phaûi soá hoaù laïi hoaøn toaøn vì theá neáu ta coù yù ñònh soá hoaù
baûn ñoà tröïc tieáp treân MapInfo theo phöông phaùp soá hoaù theo aûnh queùt thì böôùc ñaêng
kyù toaï ñoä cho aûnh queùt laø raát quan troïng.

IX.2.2. Phöông phaùp taïo baûng môùi tröôùc

Caùch soá hoaù baûn ñoà nhö treân laø caùch laøm coù tính chaát “tröïc quan”. Ta coù moät caùch
khaùc ñeå soá hoaù baûn ñoà. Phaàn döôùi ñaây seõ trình baøy caùch laøm ñoù.

Sau khi ñaõ ñaêng kyù aûnh queùt, ta seõ tieán haønh taïo caùc baûng MapInfo môùi (chöa coù
thoâng tin gì). Giaû söû ta ñaõ ñaêng kyù baûn ñoà haønh chính Vieät Nam nhö trong chöông 2
vaø döï kieán soá hoaù caùc thoâng tin sau: ranh giôùi nöôùc Vieät Nam, caùc tænh, thaønh phoá -
thò xaõ, soâng, vuøng laõnh thoå Vieät Nam. Ta seõ taïo caùc taäp tin MapInfo môùi (nhöng khoâng
coù döõ lieäu - töùc chöa veõ gì caû) nhö sau:

- Choïn File > New Table; hoäp thoaïi New Table môû ra

- Hoäp thoaïi naøy coù 3 tuyø choïn (xem giaûi thích yù nghóa caùc tuyø choïn trong phaàn phuï
luïc), taét ñaùnh daáu choïn trong taát caû caùc tuyø choïn ñi.

- Choïn leänh Create.

- Hoäp thoaïi New Table Structure môû ra.

- Taïo caùc tröôøng döï kieán cho lôùp baûn ñoà môùi, ví duï ñoái vôùi lôùp baûn ñoà caùc tænh seõ coù
coät teân, ta taïo tröôøng ten, ñònh daïng laø Character, tröôøng dieän tích, ta taïo tröôøng
dien_tich, ñònh daïng laø Float,...
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- Choïn nuùt Projection ñeå choïn heä quy chieáu choïn baûn ñoà. Vì ta soá hoaù baûn ñoà töø aûnh
queùt neân heä quy chieáu naøy phaûi gioáng vôùi heä quy chieáu khi ñaêng kyù aûnh queùt.

- Ñaùnh daáu choïn vaøo muïc Table is Mappable.

- Taïo xong caùc tröôøng caàn thieát, choïn Create.

- Hoäp thoaïi Create New Table môû ra.

- Choïn thö muïc löu lôùp baûn ñoà môùi naøy trong oâ Save In.

- Ñaët teân cho baûn ñoà môùi trong oâ File Name.

- Choïn Save.

Baèng phöông phaùp naøy ta taïo ra caùc baûng MapInfo ñeå chöùa caùc thoâng tin seõ soá
hoaù, ví duï ta seõ taïo caùc baûng MapInfo laø ranh_gioi, cac_tinh, thanh_pho, song, viet-
nam_vung gioáng nhö caùc teân trong Chöông IV.

Ñeå soá hoaù, caùch laøm nhö sau:

- Môû aûnh queùt ñaõ ñaêng kyù toaï ñoä ra.

- Môû lôùp ñònh soá hoaù ra, trong oâ Preferred View choïn Current Mapper. Ví duï ta choïn
môû ranh_gioi. Lôùp ranh_gioi ñöôïc môû chung vôùi cöûa soå baûn ñoà queùt nhöng chöa coù
gì.

Coù hai caùch soá hoaù:

IX.2.2.1. Soá hoaù thoâng qua lôùp Cosmetic
+ Choïn Map > Layer Control, ñaùnh daáu choïn chænh söûa vaøo lôùp Cosmetic Layer.
+ Baét ñaàu soá hoaù ñöôøng ranh giôùi baèng caùch söû duïng coâng cuï veõ ñöôøng ñeå veõ

caùc chi tieát theo aûnh queùt ñaõ môû.

+ Soá hoaù ñöôïc moät luùc choïn Map > Save Cosmetic Objects.

+ Trong hoäp thoaïi Save Cosmetic Objects, thay vì choïn <New>, ta choïn ranh_gioi
roài choïn Save. Nhö vaäy nhöõng gì ñaõ veõ trong lôùp Cosmetic seõ ñöôïc chuyeån leân
lôùp ranh_gioi.

+ Nhaán nuùt löu, hoäp thoaïi Save table môû ra choïn ranh_gioi roài choïn Save ñeå löu
nhöõng gì ñaõ chuyeån töø lôùp Cosmetic vaøo lôùp ranh_gioi.

IX.2.2.2. Soá hoaù tröïc tieáp treân lôùp ranh_gioi

+ Choïn Map > Layer Control.
+ Ñaùnh daáu choïn vaøo coät chænh söûa cuûa lôùp ranh_gioi.
+ Tieán haønh soá hoaù lôùp ranh_gioi baèng caùch söû duïng coâng cuï veõ ñöôøng. Trong

quaù trình veõ thænh thoaûng phaûi nhaán toå hôïp phím <Ctrl>+<S> hay choïn File >
Save Table ñeå löu laïi nhöõng gì ñaõ veõ vaøo lôùp ranh_gioi.

* Öu vaø nhöôïc ñieåm cuûa hai phöông phaùp treân:

Söû duïng Cosmetic Layer: öu ñieåm cuûa vieäc söû duïng lôùp naøy laø trong quaù trình soá
hoaù, khi coù chænh söûa (caét, goäp hay xoaù) caùc vaät theå thì vì chuùng laø nhöõng vaät theå treân
lôùp Cosmetic neân khoâng coù thoâng tin do vaäy caùc leänh chænh söûa ñöôïc thöïc hieän nhanh
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hôn. Söû duïng lôùp Cosmetic coøn coù moät öu ñieåm nöõa laø trong quaù trình soá hoaù nhöõng
baûn ñoà ñaõ soá hoaù moät phaàn roài thì lôùp Cosmetic coù taùc duïng nhö moät lôùp veõ nhaùp, öng
yù roài ta môùi duøng leänh Save Cosmetic Objects ñeå chuyeån noù sang lôùp caàn soá hoaù, neáu
khoâng öng yù ta coù theå duøng leänh Clear Cosmetic Layer ñeå xoaù boû toaøn boä maø khoâng
aûnh höôûng ñeán lôùp baûn ñoà ñaõ coù thoâng tin. Nhöôïc ñieåm cuûa phöông phaùp naøy laø sau
khi chuyeån töø lôùp Cosmetic leân lôùp baûn ñoà caàn soá hoaù, ta phaûi tieán haønh nhaäp lieäu theo
3 phöông phaùp seõ ñöôïc trình baøy ôû phaàn döôùi ñaây.

Söû duïng tröïc tieáp lôùp ñang soá hoaù: soá hoaù tröïc tieáp leân lôùp ñang caàn soá hoaù coù
moät öu ñieåm laø ta coù theå nhaäp lieäu ngay trong quaù trình soá hoaù (xem tieáp phaàn döôùi),
khoâng phaûi maát thôøi gian tìm laïi töøng vaät theå ñeå nhaäp lieäu sau khi soá hoaù xong. Nhöôïc
ñieåm cuûa phöông phaùp naøy laø khi chænh söûa baûn ñoà trong quaù trình soá hoaù, vì ta ñaõ taïo
caùc tröôøng döõ lieäu trong leänh File > New Table luùc ñaàu neân moãi khi chænh söûa moät vaät
theå  (caùc leänh Combine, Split, Erase, Erase Outside) MapInfo ñeàu hieän moät hoäp thoaïi
hoûi ta xöû lyù döõ lieäu nhö theá naøo (xem laïi chöông V, chænh söûa caùc vaät theå trong quaù
trình soá hoaù). Ñieàu naøy laøm chaäm quaù trình soá hoaù.

IX.2.2.3. Naïp döõ lieäu ngay trong quaù trình soá hoaù

Khi soá hoaù baèng phöông phaùp taïo baûng môùi tröôùc, trong quaù trình soá hoaù ta coù theå
nhaäp döõ lieäu ngay sau khi veõ xong töøng vaät theå. Caùch nhaäp döõ lieäu tröïc tieáp trong quaù
trình soá hoaù nhö sau:

- Taïo moät lôùp baûn ñoà troáng chöa coù döõ lieäu nhö treân, taïo caùc tröôøng caàn thieát, môû ra
chung vôùi aûnh queùt ñaõ ñaêng kyù.

- Choïn Map > Layer Control, ñaùnh daáu chænh söûa vaøo lôùp caàn soá hoaù.

- Veõ vaät theå ñaàu tieân.
- Choïn nuùt leänh Info Tool treân thanh coâng cuï Main.

- Nhaép chuoät choïn vaät theå môùi veõ, hoäp thoaïi Info Tool môû ra.

- Nhaäp döõ lieäu vaøo caùc tröôøng cuûa vaät theå ñoù.

- Choïn coâng cuï veõ ñeå veõ tieáp vaät theå thöù hai; hoäp thoaïi Info Tool khoâng bieán maát maø
khi veõ xong vaät theå thöù hai noù hieån thò thoâng tin cuûa vaät theå môùi vöøa veõ xong.

- Nhaäp döõ lieäu ngay cho vaät theå môùi veõ xong vaøo cöûa soå Info Tool.
- Laïi tieáp tuïc veõ vaø nhaäp döõ lieäu cho caùc vaät theå moät caùch töông töï trong quaù trình soá

hoaù.

Caùch naøy giuùp tieát kieäm thôøi gian nhaäp döõ lieäu khaù nhieàu trong tröôøng hôïp caùc vaät
theå coù thuoäc tính ñeàu khaùc nhau nhieàu ôû caùc tröôøng. Tuy nhieân ñoái vôùi moät soá tröôøng
maø caùc vaät theå treân baûn ñoà coù thuoäc tính gioáng nhau (chia thaønh vaøi nhoùm thuoäc tính)
thì nhaäp lieäu cho nhöõng tröôøng ñoù baèng phöông phaùp Update Column (xem phaàn döôùi)
nhanh vaø chính xaùc hôn. Maëc duø vaäy ta coù theå giaûi quyeát vaán ñeà toán thôøi gian trong
phöông phaùp naøy moät caùch deã daøng baèng caùch maõ hoaù döõ lieäu ñeå tieát kieäm thôøi gian
nhaäp lieäu roài söû duïng leänh Update Column ñeå phuïc hoài laïi döõ lieäu goác sau naøy moät
caùch nhanh choùng neáu muoán (xem theâm trong phaàn maõ hoaù döõ lieäu ôû chöông naøy).

Soá hoaù baûn ñoà laø moät trong nhöõng coâng vieäc cöïc nhoïc nhaát trong quaù trình xaây
döïng baûn ñoà soá vì khoái löôïng coâng vieäc thao taùc baèng tay töông ñoái nhieàu vaø deã gaëp
sai soá. Söï caêng thaúng trong quaù trình nhaép chuoät lieân tuïc ñeå soá hoaù caùc ñöôøng nhö
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vaäy thöôøng daãn ñeán sai soá.

Ñeå giaûi quyeát vaán ñeà naøy coù moät soá giaûi phaùp:

- Söû duïng döõ lieäu ôû caùc ñònh daïng khaùc vaø dòch sang MapInfo. Ví duï caùc baûn veõ treân
AutoCAD hay caùc baûn ñoà soá cuûa Arcview, ArcInfo coù theå ñöôïc dòch sang MapInfo
maø khoâng caàn phaûi soá hoaù laïi. MapInfo coù trang bò moät coâng cuï giuùp ta thöïc hieän
ñieàu naøy, ñoù laø öùng duïng Universal Translator. Chi tieát phaàn naøy ñöôïc trình baøy
trong chöông ///.

- Söû duïng caùc phaàn meàm soá hoaù töï ñoäng. Treân thò tröôøng coù khaù nhieàu phaàn meàm
soá hoaù töï ñoäng thöông maïi ví duï nhö R2V. Nhöõng phaàn meàm soá hoaù töï ñoäng
thöông maïi naøy ña phaàn laø coù tính chuyeân duïng cao, khoâng phoå bieán trong giôùi
khoâng chuyeân nghieäp. Tuy nhieân coù moät phaàn meàm soá hoaù töï ñoäng mieãn phí raát
toát, ñoù laø MapScan do Phaân ban Thoáng keâ cuûa Lieân Hieäp Quoác vieát. Coù theå taûi
phaàn meàm naøy veà töø ñòa chæ :

http://www.un.org/Depts/unsd/softproj/software/mapscan.htm
Phaàn meàm naøy nhoû goïn, chæ toán vaøi Megabyte khi caøi ñaët nhöng soá hoaù baûn ñoà raát
toát. Soá hoaù töï ñoäng khoâng phaûi laø muïc tieâu chính cuûa cuoán saùch naøy neân MapScan
khoâng ñöôïc giôùi thieäu ôû ñaây. Ñoäc giaû coù theå töï taûi phaàn meàm naøy veà töø Internet vaø
nghieân cöùu söû duïng. Moät ñieàu caàn ghi nhôù laø neáu aùp duïng phöông phaùp soá hoaù töï
ñoäng thì vieäc xöû lyù aûnh queùt laïi laø moät coâng ñoaïn raát quan troïng vì neáu khoâng xöû lyù
aûnh queùt toát, keát quaû baûn ñoà ñöôïc soá hoaù töï ñoäng coù theå bò loãi nhieàu ñeán noãi coâng
ñoaïn chænh söûa laïi toán thôøi gian hôn caû soá hoaù baèng tay. Kieán thöùc veà xöû lyù aûnh soá
treân maùy tính laø raát quan troïng ñeå ñaûm baûo vieäc soá hoaù töï ñoäng thaønh coâng.

- Söû duïng maùy ñònh vò toaøn caàu ñeå laäp baûn ñoà. Maùy ñònh vò toaøn caàu (GPS - Global
Positioning System) ngaøy nay ñang trôû thaønh moät trong nhöõng thieát bò ñöôïc söû duïng
raát phoå bieán trong GIS. Vôùi maùy ñònh vò ta coù theå veõ baûn ñoà ngay treân thöïc ñòa roài
chuyeån döõ lieäu ñoù vaøo maùy tính. Döõ lieäu chuyeån vaøo maùy tính coù theå ñöa vaøo moät
cô sôû döõ lieäu ñôn giaûn nhö baûng Excel hay Access hay thaäm chí giöõ nguyeân laø moät
taäp tin ñònh daïng kieåu vaên baûn (.txt) cuõng ñöôïc. Sau ñoù caùc thoâng tin veà toaï ñoä naøy
coù theå ñöa vaøo MapInfo ñeå leân toaï ñoä treân baûn ñoà. Ñeå ñöa caùc thoâng tin ghi trong
GPS leân maùy tính, ta caàn coù moät caùp noái maùy ñònh vò vôùi maùy tính (thöôøng laø qua
coång COM, töø 1 ñeán 4) ñeå taûi döõ lieäu, ñoàng thôøi treân maùy tính phaûi coù phaàn meàm
nhaän ñöôïc caùc döõ lieäu treân. Moät trong nhöõng phaàn meàm raát ñôn giaûn, mieãn phí, coù
theå giuùp ta taûi döõ lieäu töø maùy ñònh vò veà laø phaàn meàm Waypoint+, phieân baûn 1.8.03.
Ñoäc giaû coù theå taûi phaàn meàm naøy veà töø trang web: 

http://www.tapr.org/~kh2z/Waypoint
Löu yù raèng phieân baûn Waypoint+ 1.8.03 naøy chæ hoaït ñoäng treân caùc maùy ñònh vò cuûa
haõng Garmin, moät loaïi maùy ñònh vò khaù phoå bieán ôû nöôùc ta, vôùi caùc model sau:
Garmin 38, Garmin 40, Garmin 45, vaø Garmin 45XL, phieân baûn phaàn meàm treân
GPS laø 2.03, 2.32, 2.41 vaø 3.04; Garmin 12XL phaàn meàm phieân baûn 2.01, vaø
Garmin 90 phieân baûn phaàn meàm 2.05, Garmin 95XL, vaø Garmin 135 Sounder.  Caùc
model Garmin II (model Garmin II Plus khoâng chaïy ñöôïc treân phaàn meàm naøy), III,
III Plus, vaø moät soá model Garmin eTrex cuøng moät soá phieân baûn phaàn meàm cuõng coù
theå söû duïng Waypoint+, tuy nhieân caùc bieåu töôïng treân maùy ñònh vò khoâng ñöôïc hoã
trôï. Model Garmin GPSMAP76 cuõng ñaõ ñöôïc hoã trôï trong phieân baûn Waypoint+
v.1.8.50.

PDF created with pdfFactory Pro trial version www.pdffactory.com

http://www.pdffactory.com


Khi söû duïng maùy ñònh vò ñeå ñöa toaï ñoä vaøo maùy tính roài sau ñoù vaøo MapInfo, moät
trong nhöõng vaán ñeà caàn chuù yù laø heä quy chieáu. Töông töï nhö phaàn meàm MapInfo,
treân maùy ñònh vò coù raát nhieàu heä quy chieáu khaùc nhau. Khi muoán ñöa toaï ñoä treân
maùy ñònh vò vaøo moät baûn ñoà naøo ñoù, ta phaûi choïn heä quy chieáu treân maùy ñònh vò vaø
treân baûn ñoà gioáng nhau, neáu khoâng toaï ñoä töø maùy ñònh vò ñöa leân baûn ñoà seõ bò leäch.

Ngoaøi chöùc naêng laáy toaï ñoä vaøo maùy tính, phaàn meàm treân coøn coù khaû naêng taûi caùc
toaï ñoä töø maùy tính vaøo laïi maùy ñònh vò ñeå söû duïng trong coâng taùc thöïc ñòa. Ví duï ta
coù theå laäp keá hoaïch ñieàu tra treân baûn ñoà trong MapInfo, sau ñoù ñöa tuyeán ñöôøng
ñieàu tra naøy vaøo maùy ñònh vò ñeå thöïc hieän ngoaøi ñòa baøn, söû duïng maùy ñònh vò giuùp
xaùc ñònh caùc ñieåm ñieàu tra cho chính xaùc. Hy voïng seõ coù dòp trình baøy caùc vaán ñeà
naøy trong moät taøi lieäu khaùc.

IX.3. NHAÄP DÖÕ LIEÄU VAØO BAÛNG DÖÕ LIEÄU

Baûng döõ lieäu cuûa baûn ñoà ñöôïc môû ra baèng leänh Window > New Browser Window >
<choïn lôùp baûn ñoà caàn môû döõ lieäu>. Coù theå môû moät phaàn döõ lieäu cuûa moät lôùp baûn ñoà
baèng leänh Query vaø choïn nhöõng vaät theå naøo muoán xem döõ lieäu baèng caùch söû duïng
bieåu thöùc (xem theâm trong phaàn Bieåu thöùc).

Tröôùc khi naïp döõ lieäu cho moät lôùp baûn ñoà, caàn taïo caùc tröôøng ñeå chöùa caùc döõ lieäu.
Ñònh daïng tröôøng phaûi phuø hôïp vôùi döõ lieäu döï kieán naïp vaøo. Löu yù raèng khi ñònh daïng
tröôøng sai, hay noùi caùch khaùc, döõ lieäu naïp vaøo khoâng ñuùng ñònh daïng cuûa tröôøng thì
MapInfo khoâng baùo loãi maø chæ thay giaù trò sai baèng moät giaù trò khaùc (ñöôïc goïi laø giaù trò
”toài” - bad value), vì vaäy phaûi caån thaän trong khi naïp döõ lieäu cuõng nhö khi söû duïng caùc
leänh lieân quan ñeán thay ñoåi döõ lieäu, nhö leänh Update Column chaúng haïn.

Döõ lieäu trong MapInfo coù theå ñöôïc naïp vaøo baèng nhieàu caùch.

IX.3.1. Nhaäp döõ lieäu töø cöûa soå Browser: 

+ Môû baûn ñoà ra, choïn Window > New Browser Window > choïn lôùp baûn ñoà caàn môû
döõ lieäu.

+ Choïn Window > Tile Windows ñeå hieån thò cöûa soå baûn ñoà laãn cöûa soå döõ lieäu. Ñieàu
chænh kích thöôùc caùc cöûa soå sao cho thuaän tieän.

+ Choïn moät vaät theå treân cöûa soå baûn ñoà baèng nuùt choïn, baûn ghi (haøng) lieân keát vôùi
vaät theå ñoù ñöôïc toâ ñen ôû meùp traùi. Neáu khoâng thaáy (vì naèm ngoaøi vuøng nhìn thaáy
trong cöûa soå Browser) thì choïn leänh Query > Find Selection, vaät theå ñöôïc choïn
seõ hieån thò trong cöûa soå Browser.

+ Nhaép chuoät vaøo haøng ñoù vaø nhaäp döõ lieäu cho caùc tröôøng. Di chuyeån giöõa caùc oâ
vaø caùc haøng baèng caùch söû duïng phím <Tab> hoaëc toå hôïp phím <Shift> + <Tab>.

+ Choïn moät vaät theå khaùc vaø laøm töông töï cho ñeán heát.

IX.3.2. Nhaäp döõ lieäu baèng leänh Update Column

Neáu coù nhieàu baûn ghi trong moät lôùp baûn ñoà coù cuøng giaù trò trong moät tröôøng, ta
khoâng nhaát thieát phaûi goõ laïi nhieàu laàn maø coù theå nhaäp döõ lieäu cho taát caû caùc vaät theå coù
cuøng giaù trò moät laàn baèng leänh Update Column. Caùch laøm toång quaùt nhö sau:
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+ Choïn caùc vaät theå coù cuøng giaù trò cuûa tröôøng döï kieán naïp döõ lieäu treân cöûa soå baûn
ñoà baèng nuùt choïn, söû duïng phím <Shift> ñeå choïn nhieàu vaät theå moät laàn. Neáu
choïn nhaàm vaät theå thì coù theå giöõa <Shift> vaø nhaép chuoät laïi leân vaät theå choïn
nhaàm thì vaät theå ñoù seõ ñöôïc khöû choïn.

+ Choïn Table > Update Column.

+ Trong Table to Update choïn Selection.

+ Trong Column to Update, choïn tröôøng caàn nhaäp döõ lieäu.

+ Trong oâ Get Value from Table, giöõ nguyeân thieát laäp laø Selection.

+ Trong oâ Value, goõ giaù trò caàn nhaäp lieäu vaøo. Löu yù raèng ñònh daïng kieåu kyù töï
(chöõ), ngaøy thaùng naêm vaø kieåu luaân lyù phaûi ñöôïc ñaët trong daáu ngoaëc keùp.

IX.3.3. Nhaäp döõ lieäu baèng leänh Info Tool

Ñaây laø leänh ñeå xem döõ lieäu cuûa moät vaät theå treân baûn ñoà baèng caùch choïn vaät theå
ñoù. Ta coù theå duøng cöûa soå Info Tool ñeå nhaäp lieäu cho baûn ñoà. Caùch laøm nhö sau:

+ Choïn nuùt leänh Info Tool treân thanh coâng cuï Main.

+ Nhaép chuoät leân moät vaät theå treân cöûa soå baûn ñoà.

+ Cöûa soå Info Tool môû ra, hieån thò caùc tröôøng chöùa giaù trò cuûa vaät theå ñoù.

+ Nhaép chuoät vaøo caùc tröôøng trong cöûa soå Info Tool ñeå naïp döõ lieäu cho vaät theå
ñöôïc nhaép chuoät choïn luùc ñaàu.

+ Di chuyeån laïi cöûa soå baûn ñoà, nhaép chuoät leân moät vaät theå khaùc, cöûa soå Info Tool
khoâng taét nhöng hieån thò caùc giaù trò trong caùc tröôøng cuûa vaät theå vöøa môùi ñöôïc
nhaép chuoät leân, laïi nhaäp döõ lieäu vaøo caùc tröôøng cho vaät theå ñoù.

+ Laøm töông töï cho taát caû caùc vaät theå trong lôùp baûn ñoà ñoù

Löu yù: 
+ Khi daáu nhaùy chuoät naèm trong cöûa soå Info Tool, coù theå di chuyeån giöõa caùc tröôøng

baèng phím <Tab> hay <Shift>+<Tab>.
+ Tieáng Vieät hieån thò khoâng ñuùng trong cöûa soå naøy neân phaûi caån thaän ñeå traùnh sai

chính taû.
+ Döõ lieäu ñöôïc nhaäp hay chænh söûa trong cöûa soå Info Tool cuõng seõ ñöôïc löu laïi

trong baûng döõ lieäu chính cuûa lôùp baûn ñoà MapInfo ñoù.
+ Caùc tröôøng ñònh daïng kieåu kyù töï, ngaøy thaùng vaø kieåu luaân lyù khoâng ñöôïc ñaët

trong daáu ngoaëc keùp khi goõ giaù trò trong cöûa soå Info Tool.
Ngoaøi ra nhö ñaõ trình baøy trong phaàn treân, ta coù theå nhaäp döõ lieäu cho vaät theå ngay

trong quaù trình soá hoaù.

IX.4. CAÙC KIEÅU ÑÒNH DAÏNG CHO TRÖÔØNG DÖÕ LIEÄU TRONG MAPINFO

MapInfo cho pheùp ñònh daïng caùc tröôøng döõ lieäu vôùi caùc kieåu nhö sau:

- Character:  Kieåu kyù töï. Tröôøng coù ñònh daïng naøy ñöôïc duøng ñeå chöùa döõ lieäu kieåu
chöõ, ví duï nhö teân tænh, teân soâng, teân thaønh phoá,... Tröôøng naøy coù theå
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chöùa toái ña 254 kyù töï vaø coù theå chöùa caùc chöõ soá (löu yù raèng con soá
naïp vaøo tröôøng ñöôïc ñònh daïng kieåu kyù töï ñöôïc coi nhö laø nhöõng chöõ
soá (khoâng tính toaùn ñöôïc) chöù khoâng phaûi laø con soá).

- Integer: Kieåu soá nguyeân. Tröôøng kieåu naøy duøng ñeå chöùa caùc soá chaün (khoâng
coù soá leû). Giôùi haïn kích thöôùc cuûa tröôøng naøy laø töø aâm hai tyû (-
2,000,000,000) ñeán döông hai tyû (2,000,000,000). Ñaây laø giaù trò öôùc
löôïng töông ñoái. Khi ñònh daïng tröôøng theo kieåu naøy, giaù trò maëc ñònh
ban ñaàu cuûa taát caû caùc baûn ghi (haøng) laø 0.

- Small Integer: Kieåu soá nguyeân nhoû. Tröôøng kieåu naøy coù giôùi haïn trong khoaûng aâm
32,768 (-32,768) ñeán döông 32,767 (32,767). Löu yù raèng tröôøng naøy
hoaøn toaøn töông töï nhö tröôøng Integer nhöng giôùi haïn nhoû hôn do
vaäy MapInfo daønh ít boä nhôù hôn ñeán chöùa giaù trò cuûa tröôøng naøy. Neáu
ta chaéc chaén raèng giaù trò ta naïp vaøo naèm trong khoaûng giôùi haïn treân
thì neân ñònh daïng laø tröôøng naøy ñeå giaûm kích thöôùc taäp tin cuûa
MapInfo. Khi ñònh daïng tröôøng theo kieåu naøy, giaù trò maëc ñònh ban
ñaàu cuûa taát caû caùc baûn ghi (haøng) laø 0.

- Float: Kieåu soá thaäp phaân coù daáu chaám ñoäng. Ta neân thieát laäp ñònh daïng laø
tröôøng naøy neáu khoâng bieát chính xaùc giaù trò naïp vaøo laø soá thaäp phaân
bao nhieâu, ví duï nhö nhaäp döõ lieäu vaøo tröôøng baèng caùc laäp coâng thöùc
tính toaùn töø döõ lieäu cuûa caùc tröôøng khaùc.

- Decimal: Kieåu soá thaäp phaân xaùc ñònh, coù nghóa laø ta phaûi bieát chính xaùc giôùi
haïn con soá thaäp phaân naïp vaøo laø bao nhieâu (töùc laø bieát coù toái ña bao
nhieâu soá tröôùc daáu phaåy vaø bao nhieâu soá leû sau daáu phaåy). Khi ñònh
daïng tröôøng theo kieåu naøy, giaù trò maëc ñònh ban ñaàu cuûa taát caû caùc
baûn ghi (haøng) laø 0.

- Date: Kieåu ngaøy thaùng. Tröôøng naøy cho pheùp ta naïp ngaøy thaùng vaøo. Giaù
trò ngaøy thaùng naïp vaøo phaûi theo thöù töï heä Anh - Myõ töùc laø
thaùng/ngaøy/naêm. Ví duï neáu ta muoán goõ laø ngaøy 12 thaùng 6 naêm
1998 thì ta phaûi goõ laø “06/12/1998”, neáu ta goõ laø “12/06/1998” thì
MapInfo seõ hieåu laø ngaøy 6 thaùng 12 naêm 1998. Daáu phaân caùch ngaøy,
thaùng, naêm maëc ñònh treân heä ñieàu haønh Window laø daáu xuyeäc xuoâi
(/). Neáu muoán ñoåi daáu phaân caùch vaø thöù töï naïp ngaøy thaùng naêm ta
phaûi ñieàu chænh trong heä ñieàu haønh, phaàn Settings > Control Panel >
Regional Settings > Regional Options > Date. Neáu ñònh daïng tröôøng
kieåu naøy thì ta coù theå saép thöù töï baûng döõ lieäu theo ngaøy thaùng ñöôïc.
Neáu ta chæ naïp hai giaù trò laø thaùng vaø ngaøy thì MapInfo seõ töï ñoäng
nhaäp naêm hieän taïi treân ñoàng hoà cuûa maùy tính vaøo döõ lieäu. Ñieàu quan
troïng laø khi thay ñoåi ñònh daïng maëc ñònh ngaøy thaùng naêm thì khi môû
baûng MapInfo ñoù ra treân moät maùy tính coù ñònh daïng ngaøy thaùng naêm
khaùc thì tröôøng ngaøy thaùng naêm coù theå seõ bò maát döõ lieäu vì theá neân
caån thaän khi thay ñoåi ñònh daïng ngaøy thaùng naêm.

- Logical: Ñaây laø ñònh daïng tröôøng kieåu luaân lyù. Tröôøng naøy chæ coù hai giaù trò laø
ñuùng/coù (ñöôïc goõ laø “T” hay “t” - Vieát taét cuûa chöõ True) hoaëc
sai/khoâng (ñöôïc goõ laø “F” hay “f” - vieát taét cuûa chöõ False). Khi ñònh
daïng tröôøng theo kieåu naøy, taát caû caùc baûn ghi (haøng) ñeàu coù giaù trò
maëc ñònh ban ñaàu laø sai (F).
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Löu yù raèng khi naïp caùc soá nguyeân, ta coù theå goõ daáu phaân caùch haøng nghìn. Neáu
ta khoâng goõ daáu phaân caùch haøng nghìn thì MapInfo seõ töï ñoäng taïo daáu phaân caùch haøng
nghìn. Daáu phaân caùch haøng nghìn phuï thuoäc vaøo ñònh daïng cuûa heä thoáng. Maëc ñònh
daáu phaân caùch haøng nghìn theo heä Anh-Myõ laø daáu phaåy (,).
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