
CHÖÔNG XVII. 
BAÛNG CUÛA MAPINFO 
VAØ QUAÛN LYÙ DÖÕ LIEÄU TRONG BAÛNG

Trong chöông ñaàu tieân, chuùng ta ñaõ xem xeùt sô löôïc veà thaønh phaàn cuûa moät baûn
ñoà soá trong MapInfo. Nhö ñaõ trình baøy, baûn ñoà soá trong MapInfo ñöôïc goïi laø baûng
(table). Thöïc ra moät “baûng” cuûa MapInfo bao goàm nhieàu taäp tin thaønh phaàn khaùc nhau.

Moät baûng cuûa MapInfo coù theå coù phaàn döõ lieäu (töùc noäi dung hieån thò trong cöûa soå
Browser) vaø phaàn ñoà hoaï (töùc noäi dung hieån thò treân cöûa soå baûn ñoà). Trong caùc chöông
tröôùc chuùng ta ñaõ xem xeùt nhieàu veà phaàn ñoà hoïa cuûa baûn ñoà soá. Chöông naøy chuû yeáu
taäp trung chuû yeáu vaøo phaàn döõ lieäu cuûa MapInfo.

XVII.1. CAÁU TAÏO BAÛNG CUÛA MAPINFO

Ñeå coù moät baûng MapInfo, caàn coù toái thieåu laø hai hay taát caû caùc taäp tin thaønh phaàn
sau:

- Taäp tin coù ñuoâi môû roäng laø .tab: ñaây laø taäp tin moâ taû caáu truùc cuûa phaàn döõ lieäu trong
MapInfo. Thöïc chaát noù laø moät taäp tin nhoû kieåu vaên baûn moâ taû ñònh daïng cuûa taäp tin
chöùa döõ lieäu

- Taäp tin coù ñuoâi môû roäng laø .dat: ñaây laø taäp tin chöùa döõ lieäu cuûa MapInfo. Tuy nhieân
neáu ta laøm vieäc vôùi cô sôû döõ lieäu töø caùc phaàn meàm khaùc nhö dBASE/FoxBASE, taäp
tin vaên baûn ASCII, Lotus, Excel hay Access thì phaàn cô sôû döõ lieäu vaãn giöõ nguyeân
ñònh daïng cuûa caùc phaàn meàm nguyeân thuyû cuûa noù. Trong tröôøng hôïp khoâng coù vaät
theå ñoà hoaï thì moät “baûng” döõ lieäu cuûa MapInfo goàm hai taäp tin, moät taäp tin coù phaàn
môû roäng laø .tab ñeå moâ taû döõ lieäu nhö ñaõ trình baøy vaø taäp tin döõ lieäu (coù theå laø cuûa
MapInfo ôû ñònh daïng .dat hay caùc ñònh daïng cuûa caùc phaàn meàm khaùc nhö .dbf
(Access), .xls (Excel),... Ñoái vôùi caùc baûng daïng aûnh queùt, nhö tröôøng hôïp ñaêng kyù
baûn ñoà daïng aûnh queùt vaøo MapInfo ñeå soá hoaù, moät baûng kieåu aûnh nhö vaäy seõ goàm
coù taäp tin .tab vaø taäp tin aûnh töông öùng, taäp tin aûnh coù ñònh daïng goác cuûa noù nhö
.bmp, .tif, .gif hay .jpg.

- Taäp tin coù ñuoâi môû roäng laø .map: neáu baûng MapInfo coù vaät theå ñoà hoaï, töùc coù baûn
ñoà, thì seõ coù theâm moät taäp tin nöõa coù ñuoâi môû roäng laø .map. Ñaây laø taäp tin moâ taû caùc
vaät theå ñoà hoaï trong baûn ñoà soá.

- Taäp tin coù ñuoâi môû roäng laø .id: nhö ta ñaõ bieát, moät baûng cuûa MapInfo coù theå khoâng
coù phaàn ñoà hoaï nhöng baát kyø vaät theå ñoà hoaï naøo trong baûng cuûa MapInfo ñeàu phaûi
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lieân keát vôùi moät haøng trong döõ lieäu (moät haøng trong cöûa soå Browser). Ñeå taïo ra moái
lieân keát giöõa vaät theå ñoà hoaï vôùi döõ lieäu, MapInfo taïo ra moät taäp tin coù ñuoâi môû roäng
laø .id. Ñaây laø taäp tin thöïc hieän söï lieân keát giöõa phaàn döõ lieäu vôùi phaàn ñoà hoaï. Trong
tröôøng hôïp baûng trong MapInfo coù nguoàn goác döõ lieäu töø Access thì taäp tin lieân keát
giöõa döõ lieäu Access vaø vaät theå ñoà hoaï coù ñuoâi môû roäng laø .aid.

- Taäp tin coù ñuoâi môû roäng laø .ind: ñaây laø taäp tin taïo ra chæ muïc nhaèm phuïc vuï cho leänh
Find (xem Chöông XII). Taäp tin chæ muïc naøy giuùp tìm kieám caùc vaät theå ñoà hoaï treân
baûn ñoà baèng leänh treân. Neáu muoán thöïc hieän vieäc tìm kieám vaät theå treân baûn ñoà theo
moät tröôøng döõ lieäu naøo ñoù thì tröôøng ñoù phaûi ñöôïc ñaùnh daáu chæ muïc (baèng leänh
Table > Maintenance > Table Structure, ñaùnh daáu vaøo coät Indexed). Khi naøo coù moät
tröôøng trong moät baûng MapInfo ñöôïc ñaùnh daáu chæ muïc thì taäp tin .ind seõ ñöôïc taïo
thaønh.

Nhö vaäy vôùi moät “baûng” MapInfo phaûi coù toái thieåu hai taäp tin: taäp tin .tab vaø taäp tin
döõ lieäu (.dat, .xls hay ñònh daïng döõ lieäu khaùc). Ngoaøi taäp tin .tab ra thì phaàn döõ lieäu (taäp
tin .dat) khoâng theå thieáu ñöôïc. Chính vì vaäy khi ta soá hoaù baûn ñoà töø aûnh queùt, maëc duø
luùc ñoù chöa naïp döõ lieäu gì MapInfo vaãn töï ñoäng taïo ra moät tröôøng coù teân laø ID ñeå chöùa
giaù trò soá laø 0 vaøo ñoù. Moät baûng MapInfo nguyeân thuyû (native) hoaøn chænh seõ coù 5 taäp
tin. Giaû söû teân baûng laø ban_do thì ta seõ coù 5 taäp tin sau: ban_do.tab, ban_do.dat,
ban_do.map, ban_do.id vaø ban_do.ind. Neáu phaàn döõ lieäu khoâng phaûi cuûa MapInfo thì
taäp tin döõ lieäu laø ban_do.dat seõ trôû thaønh moät taäp tin döõ lieäu töông öùng töø phaàn meàm
goác, ví duï neáu phaàn döõ lieäu ñöôïc môû ra trong MapInfo laø taäp tin Excel, thì taäp tin döõ
lieäu seõ laø ban_do.xls.

Khi thöïc hieän leänh File > Open Table ta chæ thaáy moät taäp tin duy nhaát cuûa baûng
MapInfo laø taäp tin .tab. Thöïc chaát caùc taäp tin kia ñeàu toàn taïi vaø neáu thieáu chuùng thì
khoâng theå môû baûng MapInfo ra. Vì vaäy khi sao cheùp baûng cuûa MapInfo sang moät choã
khaùc, phaûi cheùp ñaày ñuû caùc taäp tin thaønh phaàn.

XVII.2. QUAÛN LYÙ BAÛNG TRONG MAPINFO

Ñeå quaûn lyù baûng, MapInfo coù moät soá leänh lieân quan ñeán döõ lieäu trong baûng cuõng
nhö quaûn lyù caùc taäp tin thaønh phaàn cuûa moät baûng. Caùc leänh naøy naèm trong menu
Table.

XVII.2.1. Xem vaø chænh söûa caáu truùc baûng döõ lieäu MapInfo

Baûng trong MapInfo, cuõng gioáng nhö caùc cô sôû döõ lieäu khaùc, bao goàm caùc coät
(tröôøng) vaø haøng (baûn ghi). Caùc tröôøng cuûa MapInfo coù moät soá ñònh daïng khaùc nhau
(xem Chöông IX veà caùc kieåu tröôøng trong MapInfo). Ñeå xem vaø chænh söûa caùc tröôøng,
ta thöïc hieän nhö sau:

- Môû baûng coù chöùa döõ lieäu caàn xem hay chænh söûa (coù theå laø cöûa soå baûn ñoà hay cöûa
soå Browser cuõng ñöôïc).

- Töø menu chính choïn Table > Maintenance > Table Structure. Neáu ta môû nhieàu baûng
moät löôït thì hoäp thoaïi View/Modify Table Structure hieän ra lieät keâ danh saùch caùc
baûng ñang môû, choïn baûng caàn xem/chænh söûa döõ lieäu roài choïn OK. Hoäp thoaïi Modify
Table Structure (Thay ñoåi caáu truùc baûng) môû ra (hình XVII.1).
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Coät Fields lieät keâ caùc tröôøng coù trong baûng, coät Type cho bieát ñònh daïng cuûa töøng
tröôøng, coät Indexed cho bieát tröôøng ñoù coù ñöôïc laäp chæ muïc hay khoâng.

Khi nhaép chuoät choïn moät tröôøng thì thoâng tin veà tröôøng ñoù seõ hieän leân trong phaàn
Field Information ôû döôùi. Ta coù theå thay ñoåi tröôøng ñoù neáu muoán. OÂ Name cho pheùp
thay ñoåi teân tröôøng. OÂ Type cho pheùp thay ñoåi ñònh daïng cuûa tröôøng. Tuyø ñònh daïng
cuûa tröôøng maø döôùi oâ Type coù theå moät soá oâ khaùc, ví duï neáu ñònh daïng tröôøng laø kieåu
Character thì phía döôùi coù theâm oâ Width cho bieát tröôøng ñoù ñöôïc ñònh daïng coù bao
nhieâu kyù töï.

Coät Indexed cho pheùp baät hay taét chöùc naêng chæ muïc cuûa moät tröôøng. Moät tröôøng
ñöôïc ñaùnh daáu Indexed thì môùi coù theå söû duïng trong leänh Find ñöôïc.

Beân phaûi danh saùch tröôøng coù hai nuùt Up vaø Down. Khi choïn moät tröôøng roài nhaán
nuùt Up hay Down thì ta coù di chuyeån tröôøng ñoù leân hay xuoáng. Thöù töï hieån thò cuûa caùc
tröôøng trong baûng naøy seõ quy ñònh thöù töï hieån thò tröôøng trong cöûa soå döõ lieäu (cöûa soå
Browser). Tröôøng naèm treân cuøng seõ xuaát hieän beân traùi.

Nuùt Add Field cho pheùp taïo theâm moät tröôøng môùi vaøo baûng döõ lieäu cuûa MapInfo.
Khi nhaép chuoät vaøo nuùt Add Field, moät tröôøng môùi ñöôïc taïo thaønh. MapInfo töï ñoäng
ñaët teân cho tröôøng ñoù laø Fieldn, trong ñoù n laø soá thöù töï cuûa tröôøng ñoù. Ví duï neáu trong
baûng cuûa ta ñaõ coù 5 tröôøng thì khi nhaán nuùt Add Field tröôøng môùi seõ ñöôïc ñaët teân laø
Field6. Ñònh daïng cuûa tröôøng môùi maëc ñònh laø Integer (soá nguyeân). Ta ñaët teân cho
tröôøng môùi trong oâ Name vaø ñònh daïng kieåu tröôøng trong oâ Type ôû phaàn Field
Information.

Khi nhaép chuoät choïn moät tröôøng roài nhaán nuùt Remove Field thì tröôøng ñoù seõ bò xoaù
boû. Neáu ta choïn OK thì moät hoäp thoaïi caûnh baùo seõ hieän ra (hình XVII.2). Hoäp thoaïi naøy

Hình XVII.1. Hoäp thoaïi Modify Table Structure -
Ñieàu chænh Caáu truùc baûng.
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noùi raèng “Moät hay nhieàu tröôøng ñaõ bò
ruùt ngaén hay bò xoaù. Keát quaû laø döõ
lieäu seõ bò maát vaø khoâng theå phuïc hoài
ñöôïc”. Neáu ta chaéc chaén muoán xoaù
boû moät tröôøng thì nhaép chuoät choïn
OK. Hoäp thoaïi caûnh baùo naøy cuõng
hieän ra khi ta ruùt ngaén moät tröôøng laïi.
Ví duï neáu ta coù moät tröôøng kieåu
Character coù chieàu daøi laø 50 kyù töï, ta
söûa tröôøng ñoù xuoáng coøn 45 kyù töï thì
hoäp thoaïi naøy seõ hieän ra nhaéc nhôû.
Caàn phaûi bieát chaéc vieäc thay ñoåi
tröôøng hay xoaù tröôøng khoâng aûnh
höôûng ñeán döõ lieäu cuûa tröôùc khi thöïc
hieän leänh naøy.

ÔÛ goùc döôùi beân phaûi cuûa hoäp
thoaïi Modify Table Structure coù moät
tuyø choïn laø Table is Mappaple. Ñoái
vôùi baûng coù vaät theå ñoà hoaï, töùc coù
baûn ñoà, thì tuyø choïn naøy ñöôïc ñaùnh
daáu ñoàng thôøi phía döôùi coù nuùt
Projection cho pheùp ta thay ñoåi heä
quy chieáu cuûa baûn ñoà trong baûng ñoù
(xem theâm veà heä quy chieáu trong
Chöông XIX). Neáu taét choïn trong oâ
naøy roài choïn OK thì moät hoäp thoaïi
caûnh baùo seõ hieän ra (hình XVII.3). Hoäp thoaïi naøy coù yù nghóa laø: “Caùc vaät theå ñoà hoaï
lieân quan seõ bò xoaù hoaøn toaøn; leänh naøy khoâng theå quay ngöôïc laïi ñöôïc”. Neáu ta choïn
OK ñeå xaùc nhaän thì phaàn baûn ñoà seõ bò xoaù maát.

Ñoái vôùi baûng MapInfo chæ coù
phaàn döõ lieäu thì oâ naøy khoâng ñöôïc
ñaùnh daáu. Trong tröôøng hôïp ñoù
neáu ta ñaùnh daáu choïn oâ naøy vaø
choïn heä quy chieáu trong nuùt
Projection hieän leân ôû döôùi thì ta coù
theå theâm caùc vaät theå ñoà hoaï vaøo
baûng ñoù.

Khi caùc taäp tin thaønh phaàn cuûa
baûng môû ra ñöôïc ñaùnh daáu laø
nhöõng taäp tin chæ-ñoïc (read-only)
thì hoäp thoaïi Modify Table
Structure khoâng môû ra maø thay
vaøo ñoù laø hoäp thoaïi View Table
Structure (xem caáu truùc baûng)
(hình XVII.4). Trong hoäp thoaïi
naøy ta chæ coù theå xem vaø thay ñoåi
heä quy chieáu (neáu laø baûng coù baûn

Hình XVII.3. Caûnh baùo seõ bò maát caùc vaät
theå ñoà hoaï khi taét choïn trong oâ Table
is Mappable.

Hình XVII.2. Caûnh baùo coù khaû naêng maát döõ
lieäu khi xoaù tröôøng hay thay ñoåi
tröôøng.

Hình XVII.4. Hoäp thoaïi View Table  Structure
- Xem Caáu truùc Baûng.
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ñoà) chöù khoâng theå thay ñoåi caáu truùc cuûa baûng ñöôïc. Trong cöûa soå döõ lieäu (cöûa soå
Browser) cuûa baûng chæ-ñoïc ta cuõng chæ coù theå xem döõ lieäu chöù khoâng theå thay ñoåi noäi
dung döõ lieäu ñöôïc. Neáu muoán chænh söûa caáu truùc baûng ta phaûi thay ñoåi thuoäc tính caùc
taäp tin thaønh phaàn cuûa MapInfo töø cöûa soå Explorer cuûa heä ñieàu haønh hoaëc phaûi sao löu
laïi thaønh moät baûn sao vaøo ñóa cöùng treân maùy tính. Ñaây laø tröôøng hôïp cheùp taäp tin
MapInfo töø ñóa CD leân ñóa cöùng. Caùc taäp tin khi ñöôïc cheùp vaøo ñóa CD luoân ñöôïc ñaùnh
daáu thuoäc tính laø chæ ñoïc.

Ñoái vôùi moät baûng coù nguoàn goác döõ lieäu töø Excel, ta cuõng bò nhöõng giôùi haïn nhö vaäy
(duø thuoäc tính khoâng phaûi laø chæ ñoïc). Baûng döõ lieäu coù nguoàn goác töø Excel khoâng cho
pheùp thay ñoåi caáu truùc baûng cuõng nhö döõ lieäu trong baûng.

XVII.2.2. Ñoåi teân baûng MapInfo - Leänh Rename Table

Nhö ta ñaõ bieàt, baûng trong MapInfo bao goàm nhieàu taäp tin thaønh phaàn. Caùc taäp tin
thaønh phaàn cuûa moät baûng coù teân hoaøn toaøn gioáng nhau, chæ khaùc phaàn môû roäng. Vì theá
neáu thay ñoåi teân moät taäp tin thaønh phaàn cuûa baûng MapInfo (ví duï nhö ñoåi teân trong cöûa
soå Explorer treân heä ñieàu haønh Window hay ñoåi teân trong DOS chaúng haïn) thì baûng ñoù
khoâng theå môû ra ñöôïc nöõa. Muoán ñoåi teân baûng MapInfo thì phaûi ñoåi teân taát caû caùc taäp
tin thaønh phaàn sao cho gioáng nhau. Ñieàu naøy khaù baát tieän vì theá trong MapInfo coù moät
leänh cho pheùp ñoåi teân cuûa baûng laø leänh Rename Table (ñoåi teân baûng). Khi thöïc hieän
leänh naøy trong MapInfo, teân cuûa taát caû caùc taäp tin thaønh phaàn cuûa MapInfo ñeàu ñöôïc
thay ñoåi. Caùch thöïc hieän nhö sau:

- Môû baûng MapInfo muoán ñoåi teân ra.

- Töø menu chính choïn Table > Maintenance >Rename Table. Hoäp thoaïi Rename Table
môû ra, lieät keâ danh saùch caùc baûng ñang môû. Ta choïn baûng muoán ñoåi teân roài choïn
OK. Hoäp thoaïi Rename Table thöù hai môû ra.

- Hoäp thoaïi naøy gioáng nhö hoäp thoaïi löu taäp tin bình thöôøng. Ñaët teân môùi cho baûng
trong oâ File Name, choïn thö muïc trong oâ Save In, giöõ nguyeân ñònh daïng baûng laø
.tab trong oâ Save as Type.

- Nhaép chuoät choïn Save thì baûng seõ ñöôïc ñoåi teân. Taát caû caùc taäp tin thaønh phaàn cuûa
baûng ñeàu ñöôïc ñoåi sang teân môùi.

Khi ñaêng kyù moät aûnh queùt, MapInfo cuõng taïo ra moät taäp tin .tab ñeå ñaêng kyù aûnh
queùt ñoù. Taäp tin .tab seõ coù cuøng teân vôùi teân taäp tin aûnh ñöôïc ñaêng kyù. Khi ñoåi teân moät
baûng laø aûnh queùt ñaõ ñaêng kyù baèng leänh naøy, chæ coù taäp tin .tab laø ñoåi teân coøn taäp tin
aûnh goác khoâng thay ñoåi teân. Noäi dung cuûa taäp tin .tab luùc ñoù seõ tham chieáu veà teân cuõ
cuûa taäp tin aûnh.

Löu yù raèng khoâng theå ñoåi teân moät baûng coù nguoàn goác töø Excel baèng leänh naøy vì
taäp tin döõ lieäu laø taäp tin coù ñònh daïng Excel vaø MapInfo khoâng theå thay ñoåi teân cuûa taäp
tin Excel ñoù ñöôïc. Neáu muoán ñoåi teân moät baûng coù nguoàn goác töø Excel, phaûi duøng leänh
File > Save Copy As ñeå löu baûng ñoù thaønh moät baûng MapInfo thöïc söï (native) roái môùi
coù theå ñoåi teân baûng neáu muoán. Tuy nhieân cuõng caàn löu yù laø söû duïng döõ lieäu töø Excel
maø khoâng dòch haûn sang MapInfo khieán ta tieát kieäm ñöôïc khoâng gian treân ñóa cöùng vaø
khoâng phaûi quaûn lyù nhieàu taäp tin.
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XVII.2.3. Xoaù moät baûng - leänh Delete Table

Töông töï nhö tröôøng hôïp ñoåi teân cho baûng, neáu ta muoán xoaù moät baûng cuûa
MapInfo ta phaûi xoaù taát caû caùc taäp tin thaønh phaàn cuûa MapInfo. Trong cöûa soå Explorer
cuûa heä ñieàu haønh chaúng haïn, ta phaûi choïn taát caû caùc taäp tin thaønh phaàn roài môùi xoaù
ñöôïc. Caùch xoaù nhö vaäy cuõng baát tieän. MapInfo cung caáp cho ta moät leänh ñeå xoaù hoaøn
toaøn moät baûng vôùi caùc taäp tin thaønh phaàn cuûa noù. Caùch thöïc hieän leänh naøy nhö sau:

- Môû baûng muoán xoaù ra.

- Töø menu chính choïn Table >
Maintenance > Delete Table. Hoäp
thoaïi Delete Table hieän ra, choïn
baûng muoán xoaù trong danh saùch
lieät keâ roài choïn OK.

- Moät hoäp thoaïi caûnh baùo môû ra
(hình XVII.5), noù coù nghóa laø:
“Baûng <teân baûng> treân ñóa seõ bò
xoaù hoaøn toaøn. Leänh naøy khoâng
theå quay ngöôïc laïi ñöôïc.” Neáu
chaéc chaén muoán xoaù baûng ñoù, ta
choïn OK thì taát caùc caùc taäp tin thaønh phaàn cuûa baûng ñoù seõ bò xoaù maát.

Baûng coù döõ lieäu nguoàn goác töø Excel khoâng xoaù ñöôïc baèng leänh naøy maø phaûi xoaù
thuû coâng.

XVII.2.4. “Ñoùng goùi” baûng

Ta ñaõ bieát raèng moãi vaät theå ñoà hoaï treân cöûa soå baûn ñoà chæ lieân keát vôùi vôùi moät haøng
trong cöûa soå döõ lieäu maø thoâi. Vì vaäy khi thöïc hieän leänh Combine (goäp) hai hay nhieàu
vaät theå laïi thaønh moät thì keát quaû laø caùc baûn ghi thaønh phaàn bò xoaù ñi. Baûn ghi naøo hay
döõ lieäu ñöôïc giöõ laïi tuyø thuoäc vaøo chæ ñònh cuûa ta trong hoäp thoaïi Data Aggregation
(xem theâm veà hoäp thoaïi naøy trong muïc XVII.3.3 cuûa chöông naøy) coøn caùc baûn ghi khaùc
seõ bò xoaù ñi. Tuy nhieân caùc haøng trong cöûa soå Browser cuûa MapInfo khoâng bieán maát

Hình XVII.5. Caûnh baùo khi xoaù baûng seõ
khoâng theå quay ngöôïc laïi ñöôïc.

Hình XVII.6. Baûng döõ lieäu coù caùc haøng bò xoaù.
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hoaøn toaøn maø ñoåi thaønh caùc haøng coù maøu xaùm khoâng chöùa döõ lieäu (hình XVII.6). Ñieàu
töông töï cuõng xaûy ra khi ta xoaù moät vaät theå töø cöûa soå baûn ñoà hay xoaù moät haøng trong
cöûa soå Browser. Haøng bò xoaù chæ maát döõ lieäu vaø bieán thaønh maøu xaùm chöù khoâng maát
haún.

Trong quaù trình taïo moät baûn ñoà soá trong MapInfo, neáu thöïc hieän nhieàu laàn leänh xoaù
vaät theå hay leänh Combine thì seõ coù raát nhieàu haøng maøu xaùm roãng taïo thaønh trong cô
sôû döõ lieäu, coù theå thaáy treân cöûa soå Browser. Töông töï nhö vaäy thoâng tin veà caùc vaät theå
ñoà hoaï treân cöûa soå baûn ñoà vaãn ñöôïc giöõ laïi duø ñaõ bò xoaù ñi. Ñieàu naøy khoâng aûnh höôùng
gì ñeán baûn chaát cuûa baûng MapInfo nhöng khieán cho baûng MapInfo toán khoâng gian treân
ñóa. Ngoaøi ra vieäc duyeät döõ lieäu treân cöûa soå Browser baát tieän ñoàng thôøi thanh traïng thaùi
treân maøn hình MapInfo lieät keâ soá baûn ghi coù trong baûng ñoù tính luoân caùc haøng maøu
xaùm ñoù vaø vì theá ta khoâng bieát thöïc chaát coù bao nhieâu baûn ghi trong baûng döõ lieäu.

Ñeå xoaù caùc baûn ghi maøu xaùm khoâng chöùa döõ lieäu naøy ñi, MapInfo cung caáp cho ta
moät leänh coù teân goïi laø Pack Table (ñoùng goùi baûng) duøng ñeå “ñoùng goùi” hay neùn baûng
laïi, laøm cho chuùng toán ít khoâng gian treân ñóa hôn. Leänh naøy coù tuyø choïn cho pheùp ta
ñoùng goùi phaàn döõ lieäu, phaàn ñoà hoaï hay caû hai. Caùch thöïc hieän nhö sau:

- Môû baûng caàn “ñoùng goùi” ra.

- Töø menu chính choïn Table >
Maintenance > Pack Table.
Hoäp thoaïi Pack Table môû ra
(hình XVII.7).

- Choïn baûng muoán ñoùng goùi
trong oâ Pack Table.

- Choïn moät trong 3 tuyø choïn
ñoùng goùi döõ lieäu ôû döôùi: Pack
Tabular Data - chæ ñoùng goùi
phaàn döõ lieäu, Pack Graphic
Data - chæ ñoùng goùi phaàn ñoà
hoaï vaø Pack Both Types of
Data - ñoùng goùi caû hai thaønh
phaàn treân.

- xong choïn OK.

MapInfo seõ chaïy leänh naøy vaø taát caû nhöõng thoâng tin veà caùc vaät theå hay baûn ghi ñaõ
bò xoaù ñeàu ñöôïc loaïi boû.

Khi thöïc hieän leänh naøy caàn chuù yù caùc vaán ñeà sau:

- Trong quaù trình thöïc hieän ñoùng goùi baûng, MapInfo caàn moät khoaûng khoâng gian troáng
treân ñóa cöùng coù dung löôïng toái thieåu gaáp ñoâi baûng caàn ñoùng goùi ñeå chöùa döõ lieäu
cuûa baûng ôû daïng taïm thôøi trong luùc xöû lyù (scratch file).

- Thöïc hieän leänh ñoùng goùi baûng coù theå aûnh höôûng ñeán caùc nhaõn laøm thuû coâng treân
cöûa soå trình baøy ñöôïc löu laïi trong taäp tin workspace. Vì theá neáu coù yù ñònh laøm vieäc
vôùi caùc nhaõn thuû coâng cuûa moät baûng, haõy thöïc hieän leänh ñoùng goùi tröôùc khi laøm caùc
nhaõn.

Hình XVII.7. Hoäp thoaïi Pack Table -
“ñoùng goùi” baûng.
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XVII.2.5. Laøm vieäc vôùi caùc baûng ñaêng kyù töø aûnh queùt trong MapInfo.

Khi ñaêng kyù baûn ñoà queùt vaøo MapInfo ta coù theå thöïc hieän moät soá ñieàu chænh aûnh
queùt ñaõ ñaêng kyù. Caùc chöùc naêng naøy ñöôïc thöïc hieän qua leänh Table > Raster.

XVII. 2.5.1. Ñieàu chænh cheá ñoä hieån thò cuûa aûnh queùt

Caùch thöïc hieän:

- Môû aûnh queùt ñaõ ñöôïc ñaêng kyù ra.

- Töø menu chính choïn Table > Raster > Adjust Image Styles. Hoäp thoaïi naøy môû ra
(hình XVII.8). Hoäp thoaïi naøy bao goàm caùc thaønh phaàn sau:

+ Adjustments: phaàn naøy cho pheùp ta ñieàu chænh ñoä töông phaûn vaø ñoä saùng cuûa
aûnh queùt treân hai thanh tröôït Contrast (ñoä töông phaûn) vaø Brightness (ñoä saùng).
Giaù trò maëc ñònh cuûa hai thanh tröôït naøy laø 50%.

+ Conversion: tuyø choïn cho chuyeån ñoåi töø  aûnh maøu sang aûnh thang ñoä xaùm. Tuyø
choïn maëc ñònh laø Original Image (giöõ nguyeân maøu aûnh goác). Neáu choïn Grayscale
thì aûnh queùt seõ ñoåi sang maøu thang ñoä xaùm.

+ ÔÛ döôùi coù moät tuyø choïn laø Transparent. Maëc ñònh tuyø choïn naøy taét. Neáu ñaùnh
daáu vaøo tuyø choïn naøy thì nuùt Select Color seõ noåi leân vaø söû duïng ñöôïc. Khi ñoù di
chuyeån con troû chuoät treân baûn ñoà thì con troû chuoät bieán thaønh hình daáu coäng.

Hình XVII.8. Hoäp thoaïi Adjust Image Styles - ñieàu
chænh aûnh queùt ñaõ ñaêng kyù vaøo MapInfo.
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Neáu ta nhaép chuoät taïi vò trí naøo thì maøu taïi vò trí ñoù ñöôïc ñaùnh daáu vaø hieän leân oâ
maøu maãu beân caïnh nuùt Select Color. Maøu ñoù seõ ñöôïc ñoåi thaønh trong suoát
(transparent), töùc khoâng maøu, treân cöûa soå baûn ñoà. Leänh naøy thöïc ra chæ coù hieäu
quaû ñoái vôùi baûn ñoà maøu ñôn giaûn (16 maøu hay 256 maøu). Nhöõng baûn ñoà coù cheá
ñoä maøu 8 bit trôû leân thì phaàn ñaùnh daáu maøu raát nhoû vaø gaàn nhö khoâng thaáy.

Treân hoäp thoaïi naøy ta cuõng thaáy hai thanh cuoän ngang vaø ñöùng ñeå di chuyeån aûnh
cuøng vôùi hai nuùt hình daáu coäng vaø daáu tröø ñeå phoùng to/thu nhoû aûnh.

Löu raèng caùch ñieàu chænh veà ñoä töông phaûn, ñoä saùng cuõng nhö phaàn ñoåi cheá ñoä
maøu cuûa hoäp thoaïi naøy khoâng aûnh höôûng gì ñeán aûnh goác. Caùc leänh naøy chæ thay ñoåi
caùch aûnh queùt ñoù hieån thò trong MapInfo maø thoâi.

XVII.2.5.2. Thay ñoåi ñaêng kyù aûnh queùt

Ñoái vôùi nhöõng aûnh queùt ñaõ ñaêng kyù vaøo MapInfo, vì moät lyù do naøo ñoù ta muoán thay
ñoåi thoâng soá ñaêng kyù (nhö ñoåi heä quy chieáu, chænh söûa toaï ñoä ñieåm khoáng cheá, theâm
ñieåm khoáng cheá,...) thì khoâng nhaát thieát phaûi ñaêng kyù laïi. Ta coù theå thay ñoåi aûnh queùt
ñaõ ñaêng kyù roài. Caùch laøm:

- Môû aûnh queùt ñaõ ñaêng kyù ra.

- Töø menu chính choïn Table > Maintenance > Modify Image Registration. Hoäp thoaïi
Image Registration môû ra. Ñaây thöïc chaát chính laø hoäp thoaïi ñaêng kyù aûnh queùt neáu
ta môû moät aûnh queùt laàn ñaàu tieân trong MapInfo ñeå ñaêng kyù, chæ khaùc laø caùc ñieåm
khoáng cheá ñaõ coù roài maø thoâi.

- Ta coù theå thay ñoåi, theâm, bôùt caùc ñieåm khoáng cheá cuõng nhö thay ñoåi heä quy chieáu
cuûa aûnh queùt neáu muoán.

XVII.2.5.3. Ñaêng kyù aûnh queùt theo baûn ñoà soá khaùc ñaõ coù saün cuûa cuøng khu vöïc

Nhö ñaõ trình baøy trong Chöông II, muoán ñaêng kyù moät baûn ñoà daïng aûnh queùt vaøo
MapInfo, phaûi bieát toaï ñoä cuûa ít nhaát 3 ñieåm thì môùi ñaêng kyù ñuùng ñöôïc. Tuy nhieân neáu
ta coù moät baûn ñoà soá treân MapInfo cuûa cuøng khu vöïc vôùi baûn ñoà aûnh queùt muoán ñaêng
kyù thì coù theå laáy ngay caùc toaï ñoä treân baûng MapInfo ñoù vaø söû duïng laøm ñieåm khoáng
cheá ñeå ñaêng kyù aûnh queùt theo baûn ñoà ñaõ coù. Vieäc naøy ñöôïc thöïc hieän baèng leänh Select
Control Point from Map (choïn ñieåm khoáng cheá töø baûn ñoà). Caùch thöïc hieän nhö sau:

1 - Môû baûn ñoà soá coù cuøng khu vöïc vôùi aûnh queùt caàn ñaêng kyù ra (ta coù theå môû moät
aûnh queùt khaùc ñaõ ñaêng kyù roài cuõng ñöôïc).

2 - Môû baûn ñoà aûnh queùt muoán ñaêng kyù ra baèng leänh File > Open Table, trong oâ Files
of Type choïn Raster Image (*.bil, *.tif, *.grd,...).

3 - Moät hoäp thoaïi môû ra hoûi ta muoán ñaêng kyù (Register) hay chæ hieån thò aûnh (Display)
aûnh queùt. Nhaép chuoät choïn Register. Hoäp thoaïi Image Registration môû ra.

4 - Choïn heä quy chieáu cho aûnh queùt muoán ñaêng kyù baèng nuùt Projection, choïn ñôn vò
baèng nuùt Units. Trong phöông phaùp ñaêng kyù aûnh queùt kieåu naøy thì heä quy chieáu
vaø ñôn vò cuûa aûnh queùt caàn ñaêng kyù phaûi truøng vôùi heä quy chieáu cuûa baûn ñoà soá
maø ta söû duïng ñeå laáy toaï ñoä caùc ñieåm khoáng cheá.

5 - Di chuyeån aûnh queùt treân hoäp thoaïi Image Registration ñeán vuøng coù ñieåm khoáng
cheá muoán laáy. Coù theå phoùng to hay thu nhoû aûnh queùt neáu caàn.

PDF created with pdfFactory Pro trial version www.pdffactory.com

http://www.pdffactory.com


6 - Choïn nuùt coâng cuï Grabber treân thanh coâng cuï Main.

7 - Duøng nuùt coâng cuï naøy ñeå di chuyeån baûn ñoà soá trong cöûa soå baûn ñoà ñeán cuøng moät
vuøng vôùi aûnh queùt. Coù theå duøng hai nuùt coâng cuï phoùng to-thu nhoû ñeå thay ñoåi ñoä
phoùng ñaïi cuûa baûn ñoà soá neáu caàn. Trong tình huoáng naøy, thaáy hoäp thoaïi Image
Registration khoâng bieán maát maø thanh tieâu ñeà cuûa hoäp thoaïi naøy chæ chuyeån sang
maøu xaùm maø thoâi. Vì theá nhôù di chuyeån baûn ñoà ñeå sao cho vuøng döï kieán choïn laáy
ñieåm khoáng cheá khoâng bò hoäp thoaïi naøy
che khuaát.

8 - Töø menu chính choïn Table > Raster >
Select Control Point from Map.

9 - Di chuyeån chuoät laïi cöûa soå baûn ñoà, con
troû chuoät bieán thaønh hình daáu coäng.
Nhaép chuoät leân vò trí choïn laøm ñieåm
khoáng cheá.

10 - Hoäp thoaïi Add Control Point môû ra
(hình XVII.9). ÔÛ hai oâ MapX vaø MapY
hieån thò toaï ñoä cuûa ñieåm môùi nhaép
chuoät. Hai oâ ImageX vaø ImageY hieän
giaù trò 0. Coù theå ñaët teân cho ñieåm khoáng
cheá trong oâ Label. Ta choïn OK ñeå chaáp
nhaän laáy ñieåm khoáng cheá ñoù. Toaï cuûa
ñieåm ñoù ñöôïc ñöa vaøo hoäp thoaïi Image
Registration.

11 - Quay laïi hoäp thoaïi Image Registration
nhaép chuoät leân choïn ñieåm khoáng cheá
môùi ñöôïc ñöa vaøo. Phía döôùi hieän leân
doøng thoâng baùo: “Click on Image to
modify point’s coordinates” (nhaép chuoät
leân aûnh ñeå thay ñoåi toaï ñoä ñieåm).

12 - Di chuyeån chuoät laïi phaàn aûnh queùt.
Con troû chuoät bieán thaønh hình daáu
coäng. Nhaép chuoät leân aûnh queùt ngay taïi
ñieåm truøng vôùi ñieåm ñaõ nhaép chuoät treân
baûn ñoà soá tröôùc ñoù.

13 - Hoäp thoaïi Edit Control Point môû ra
(hình XVII.10). Luùc naøy hoäp thoaïi hieän
ra laïi toaï ñoä cuûa ñieåm ñaõ nhaép chuoät
trong baûn ñoà soá luùc ñaàu trong hai oâ
MapX vaø MapY. Trong hai oâ ImageX vaø
ImageY luùc naøy khoâng phaûi laø giaù trò 0
nöõa maø hieän ra toaï ñoä cuûa ñieåm ta môùi
nhaép chuoät treân aûnh queùt (toaï ñoä naøy
tính baèng ñieåm aûnh - pixel). Nhö vaäy
toaï ñoä töø baûn ñoà soá ñaõ ñöôïc gaùn leân
ñieåm nhaép chuoät treân aûnh queùt caàn
ñaêng kyù.

Hình XVII.9. Hoäp thoaïi Add Control
Point - Theâm ñieåm khoáng cheá.

Hình XVII.10. Toaï ñoä ñieåm khoáng
cheá töø baûn ñoà soá ñöôïc gaùn leân
toaï ñoä ñieåm töông öùng trong
aûnh ñaêng kyù.
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14 - Nhaép chuoät choïn OK ñeå keát thuùc ñaêng kyù ñieåm thöù nhaát.

15 - Thöïc hieän laïi töø böôùc 5 ñeán böôùc 7 ñeå di chuyeån aûnh queùt vaø baûn ñoà soá ñeán vò
trí caàn ñaêng kyù thöù hai.

16 - Treân hoäp thoaïi Image Registration nhaép chuoät choïn nuùt New ñeå chuaån bò naïp
ñieåm khoáng cheá thöù hai.

17 - Thöïc hieän laïi töø böôùc 8 ñeán böôùc 14 ñeå ñaêng kyù ñieåm khoáng cheá thöù hai.

18 - Thöïc hieän laïi böôùc 5 ñeán böôùc 7 roài choïn nuùt New, sau ñoù thöïc hieän laïi böôùc 8
ñeán böôùc 14 ñeå ñaêng kyù ñieåm khoáng cheá thöù ba.

Laëp laïi quy trình nhö treân cho ít nhaát 4 ñieåm khoáng cheá ñeå ñaûm baûo thaáy ñöôïc
sai soá khi ñaêng kyù cuûa aûnh queùt ñeå bieát ñöôïc coù theå chaáp nhaän ñöôïc sai soá hay
khoâng.

19 - Sau khi naïp ñuû soá löôïng ñieåm khoáng cheá caàn thieát, nhaép chuoät vaøo nuùt OK treân
hoäp thoaïi Image Registration ñeå keát thuùc quaù trình ñaêng kyù aûnh queøt.

XVII.3. LAØM VIEÄC VÔÙI DÖÕ LIEÄU TRONG BAÛNG

Ngoaøi vieäc quaûn lyù caùc baûng MapInfo thoâng qua caùc leänh neâu treân, chuùng ta cuõng
coøn caàn phaûi laøm vieäc vôùi döõ lieäu cuûa baûng. MapInfo coù moät soá leänh cho pheùp ta laøm
vieäc vôùi döõ lieäu trong caùc baûng. Ta seõ xem xeùt döôùi ñaây nhöõng leänh ñoù.

XVII.3.1. Leänh Append Rows to Table

Leänh naøy cho pheùp ta noái
caùc haøng töø moät baûng naøy
vaøo moät baûng khaùc. Hai baûng
phaûi coù soá coät vaø ñònh daïng
coät nhö nhau ñoàng thôøi thöù töï
caùc coät phaûi gioáng nhau. Neáu
ñònh daïng coät khaùc nhau,
MapInfo seõ ñieàu chænh ñònh
daïng coät laïi sao cho phuø hôïp
nhaát. Khi hai baûng coù soá coät
nhö nhau nhöng thöù töï coät
khaùc nhau ta coù theå ñieàu
chænh laïi thöù töï caùc coät baèng leänh Table > Maintenance > Table, söû duïng hai nuùt Up vaø
Down ñeå ñieàu chænh laïi thöù töï caùc coät. Caùch thöïc hieän leänh naøy nhö sau:

- Môû hai baûng caàn noái ra.

- Töø menu chính choïn Table > Append Rows to Table. Hoäp thoaïi Append Rows to
Table môû ra (hình XVII.11).

- Trong oâ Append Table, choïn baûng nguoàn (töùc baûng coù döõ lieäu ta caàn laáy).

- Trong oâ to Table, choïn baûng ta caàn noái caùc haøng vaøo (baûng ñích).

- Xong choïn OK.

Hình XVII.11. Hoäp thoaïi Append Rows to Table -
Noái haøng vaøo baûng.
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Caùc haøng trong baûng nguoàn seõ ñöôïc noái vaøo baûng ñích. Neáu baûng nguoàn coù vaät
theå ñoà hoaï thì chuùng cuõng ñöôïc ñöa vaøo baûng kia. Muoán löu laïi nhöõng thay ñoåi trong
baûng ñích ta choïn File > Save Table.

Tröôùc khi thöïc hieän leänh naøy, neáu ta choïn moät soá haøng trong baûng nguoàn thì tuyø
choïn Selection seõ hieän ra trong oâ Append Table. Neáu ta giöõ nguyeân tuyø choïn laø
Selection thì chæ coù nhöõng haøng ñöôïc choïn ñöôïc noái vaøo baûng ñích.

Leänh naøy thay ñoåi döõ lieäu trong baûng ñöôïc noái haøng vì theá haõy sao löu laïi caùc baûng
neáu muoán thöïc taäp phaàn naøy.

XVII.3.2. Xem caùc thoáng keâ veà döõ lieäu kieåu soá cuûa moät tröôøng.

Ñoái vaø tröôøng döõ lieäu kieåu soá nhö
dieän tích, daân soá, chieàu daøi,... ta coù
theå xem caùc thoáng keâ veà döõ lieäu cuûa
moät tröôøng trong moät baûng. Vieäc naøy
ñöôïc thöïc hieän baèng leänh Calculate
Statistics (Tính toaùn thoáng keâ) trong
menu Query. Caùch laøm nhö sau:

- Môû baûng coù döõ lieäu caàn xem thoâng
tin thoáng keâ ra.

- Töø menu chính choïn Query >
Calculate Statistics. Hoäp thoaïi
Calculate Statistics môû ra (hình
XVII.12).

- Trong oâ Table choïn baûng coù thoâng tin caàn xem, trong oâ Column, choïn coät coù thoâng
tin caàn xem.

- Choïn OK.

MapInfo seõ môû ra moät hoäp thoaïi
(hình XVII.12) cho pheùp xem caùc thoâng
tin thoáng keâ veà caùc baûn ghi trong coät
ñöôïc choïn cuûa baûng ñoù. Caùc thoâng tin
naøy bao goàm:

- Table: teân baûng ñöôïc choïn.

- Column: coät ñöôïc choïn.

- Count: soá baûn ghi (soá haøng) trong
baûng ñoù.

- Minimum: giaù trò nhoû nhaát trong baûng.

- Maximum: giaù trò lôùn nhaát trong baûng.

- Range: khoaûng cheânh leäch giöõa giaù
trò lôùn nhaát vaø nhoû nhaát.

- Sum: toång giaù trò caùc haøng trong coät
ñöôïc choïn.

Hình XVII.12. Hoäp thoaïi Calculate Column
Statistics - choïn baûng ñeå xem thoáng keâ
döõ lieäu trong coät kieåu soá.

Hình XVII.13. Thoâng baùo Column
Statistics - thoáng keâ döõ lieäu trong
coät ñöôïc choïn.
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- Mean: trò trung bình cuûa taát caû caùc giaù trò.

- Variance: Phöông sai cuûa caùc giaù trò.

- Standard Deviation: ñoä leäch chuaån cuûa caùc giaù trò trong coät.

Neáu tröôùc khi thöïc hieän leänh naøy ta choïn moät soá baûn ghi trong moät baûng maø thoâi
thì trong oâ Table ôû hoäp thoaïi Calculate Column Statistics hieän ra tuyø choïn Selection cho
pheùp ta xem nhöõng thoâng tin naøy cuûa nhöõng baûn ghi ñöôïc choïn maø thoâi.

XVII.3.3. Xem thoâng tin thoáng keâ cuûa caùc baûn ghi ñöôïc choïn

Ta cuõng coù theå xem thoâng tin thoáng keâ giöõa caùc baûn ghi ñöôïc choïn. Nhöõng tröôøng
kieåu soá seõ ñöôïc tính toång vaø tính trung bình. Caùch laøm laøm nhö sau:

- Môû baûng coù thoâng tin caàn xem ra.

- Töø menu chính choïn Options > Show Statistics Window. Cöûa soå Statistics môû ra vaø
coù doøng chöõ “no selection”
(chöa coù baûn ghi naøo ñöôïc
choïn).

- Söû duïng coâng cuï choïn treân
thanh coâng cuï Main nhaép
chuoät leân choïn moät vaät theå,
laäp töùc caùc thoâng tin cuûa vaät
theå ñoù hieän leân trong cöûa soå
Statistics (hình XVII.14). Cöûa
soå naøy coù 3 coät: Coät Field lieät
keâ teân caùc tröôøng kieåu soá,
coät Sum tính toång cuûa caùc
giaù trò caùc tröôøng vaø coät
Average tính giaù trò trung
bình cuûa caùc tröôøng.

- Giöõ phím <Shift> choïn theâm
moät vaät theå thöù hai trong
cuøng moät baûng, laäp töùc ta
thaáy caùc thoâng soá trong caùc coät Sum vaø Average thay ñoåi theo. Caùc giaù trò toång vaø
trung bình thay ñoåi töông öùng vôùi soá vaät theå ñöôïc choïn treân cöûa soå baûn ñoà.

Treân cuøng cuûa cöûa soå thoáng keâ coù doøng Table, noù hieän teân baûng coù caùc vaät theå
ñang ñöôïc choïn vaø ôû döôùi coù doøng Records Selected baùo cho ta bieát coù bao nhieâu vaät
theå ñang ñöôïc choïn.

Ta coù theå choïn caùc baûn ghi trong cöûa soå döõ lieäu hay cöûa soå bieåu ñoà cuõng ñöôïc
(neáu coù). Khi choïn caùc baûn ghi trong cöûa soå bieåu ñoà, ñeå hieån thò ñöôïc thoâng tin trong
cöûa soå thoáng keâ, söû duïng coâng cuï choïn bieåu ñoà chöù khoâng phaûi coâng cuï choïn bình
thöôøng.

XVII.3.2. Leänh Update Column - Caäp nhaät coät

Hình XVII.14. Thoâng tin thoáng keâ döõ lieäu kieåu
soá cuûa caùc baûn ghi ñöôïc choïn.
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XVII.3.2.1. Toång quaùt

Trong nhieàu tröôøng hôïp laøm vieäc vôùi döõ lieäu cuûa moät baûng MapInfo, ta khoâng
nhöõng thao taùc vôùi caùc döõ lieäu coù trong caùc tröôøng ñôn leû maø ñoâi khi coøn muoán thöïc
hieän tính toaùn giöõa caùc tröôøng ñoù vaø ñöa caùc soá lieäu tính toaùn vaøo moät tröôøng môùi, hoaëc
thay ñoåi döõ lieäu moät tröôøng baèng caùch tính toaùn döõ lieäu töø moät tröôøng khaùc,... Khoâng
nhöõng theá, nhieàu luùc ta coøn coù nhu caàu söû duïng döõ lieäu töø caùc baûng khaùc. Nhöõng nhu
caàu nhö vaäy coù theå thöïc hieän ñöôïc thoâng qua leänh Update Column (leänh Caäp nhaät coät).

Khi söû duïng leänh Update Column, ta coù voâ soá caùch ñeå laáy vaø xöû lyù döõ lieäu. Leänh
naøy khoâng nhöõng coù khaû naêng truy xuaát thoâng tin töø döõ lieäu maø coøn coù khaû naêng caäp
nhaät thoâng tin theo vò trí ñòa lyù treân baûn ñoà.

Moät caùch toång quaùt, caùch thöïc hieän leänh Caäp nhaät coät nhö sau:
- Môû baûng caàn thöïc hieän söï thay ñoåi hay caäp nhaät döõ lieäu. Neáu ta caàn laáy döõ lieäu töø

moät baûng khaùc thì baûng ñoù cuõng phaûi ñöôïc môû ra.
- Choïn Table > Update Column. Hoäp thoaïi Update Column môû ra (hình XVII.12).
- Trong oâ Table to Update choïn teân baûng muoán caäp nhaät döõ lieäu.
- Trong oâ Colunn to Update choïn coät muoán caäp nhaät döõ lieäu.
- Trong oâ Get Value From Table choïn baûng naøo caàn laáy döõ lieäu ñeå caäp nhaät. Neáu

muoán laáy döõ lieäu töø caùc tröôøng coù trong cuøng moät baûng, giöõ nguyeân teân baûng gioáng
nhö teân trong oâ Table to Update. Neáu muoán caäp nhaät döõ lieäu töø moät baûng khaùc thì
choïn teân baûng ñoù trong oâ naøy. Khi choïn caäp nhaät döõ lieäu töø moät baûng khaùc oâ
Column to Update töï ñoäng ñoåi thaønh Add new temporary column (theâm coät taïm). Ta
seõ thaûo luaän phaàn naøy sau.

- OÂ Value: naïp giaù trò caàn caäp nhaät vaøo oâ naøy. Giaù trò caàn caäp nhaät tuyø theo chæ ñònh
cuûa ta. Noù coù theå laø moät haèng soá, moät chuoãi kyù töï, moät coâng thöùc tính toaùn töø döõ
lieäu trong moät coät khaùc,...Nuùt Assist duøng ñeå vaøo hoäp thoaïi Expression vaø thieát laäp
bieåu thöùc caäp nhaät.

Hình XVII.12. Hoäp thoaïi Update Column Caäp nhaät coät.
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- ÔÛ döôùi laø tuyø choïn Browse Results, ñaùnh daáu oâ naøy seõ môû cöûa soå döõ lieäu cuûa caùc
baûn ghi ñöôïc caäp nhaät.

- Choïn OK ñeå thöïc hieän caäp nhaät coät.

Neáu choïn moät soá vaät theå/baûn ghi tröôùc khi thöïc hieän leänh naøy thì oâ Table to Update
coù tuyø choïn Selection. Neáu giöõ tuyø choïn naøy thì leänh caäp nhaät chæ taùc ñoäng leân caùc vaät
theå ñang ñöôïc choïn. Löu yù raèng leänh caäp nhaät taùc ñoäng leân baûng döõ lieäu cuûa baûng
MapInfo nhöng ta coù theå thöïc hieän pheùp choïn töø cöûa soå baûn ñoà.

XVII.3.2.2. Ví duï

Ta seõ xem xeùt moät soá ví duï döôùi ñaây.

Ví duï 1: Caäp nhaät coät döõ lieäu tính maät ñoä daân soá cho baûng cac_tinh.

Trong baûn ñoà caùc tænh cuûa Vieät Nam, ta ñaõ coù coät dieän tích (dien_tich) vaø coät daân
soá (dan_so). Ta muoán ñöa thoâng tin veà maät ñoä daân soá vaøo baûng döõ lieäu cuûa lôùp baûn
ñoà naøy.

Phaân tích: maät ñoä daân soá baèng soá daân chia cho dieän tích. Trong coät dan_so, soá daân
ñöôïc tính baèng nghìn ngöôøi nhö vaäy maät ñoä daân soá seõ baèng giaù trò trong coät dan_so
nhaân vôùi 1000 vaø chia cho giaù trò trong coät dien_tich. Ñeå chöùa giaù trò maät ñoä daân soá, ta
caàn taïo ra moät tröôøng môùi.

Caùch thöïc hieän nhö sau:

- Môû baûng cac_tinh ra.

- Töø menu chính choïn Table > Maintenance > Table Structure. Hoäp thoaïi Modify Table
Structure môû ra.

- Choïn nuùt Add Field ñeå taïo theâm moät tröôøng môùi. Söûa teân maëc ñònh cuûa tröôøng môùi
thaønh mat_do (maät ñoä). Ñònh daïng kieåu tröôøng trong oâ Type laø Float.

- Laøm xong choïn OK. Cöûa soå baûn ñoà lieân quan ñöôïc ñoùng laïi.

- Choïn Window > New Browser Window ñeå môû cöûa soå döõ lieäu cuûa baûng cac_tinh ra.
Ta thaáy tröôøng mat_do ñöôïc taïo thaønh vaø chöa coù döõ lieäu.

- Choïn Table > Update Column. Hoäp thoaïi Update Column môû ra.

- Trong oâ Table to
Update choïn baûng

cac_tinh, trong oâ
Column to Update choïn

coät mat_do.

- Trong oâ Get Value from
Table giöõ nguyeân laø baûng

cac_tinh.

- Nhaép chuoät vaøo nuùt Assist ñeå môû
hoäp thoaïi Expression ra.

- Trong oâ Expression ta goõ vaøo Bieåu thöùc
sau:
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dan_so*1000/dien_tich

Neáu khoâng nhôù chính xaùc teân tröôøng vaø chöa thoâng thaïo caùch goõ bieåu thöùc, ta coù
theå söû duïng hai menu thaû xuoáng Column vaø Operators ñeå laäp bieåu thöùc. Xem caùch
söû duïng caùc menu thaû xuoáng naøy trong chöông ///.

- Laøm xong nhaán OK ñeå quay laïi hoäp thoaïi Update Column. Bieåu thöùc ñöôïc naïp vaøo
oâ Value.

- Nhaán OK ñeå keát thuùc leänh caäp nhaät.

Trong giaây laùt ta thaáy taát caû caùc haøng cuûa baûng cac_tinh ñöôïc naïp giaù trò vaøo coät
mat_do. Vì ñôn vò dieän tích luùc naïp vaøo tröôøng naøy laø km2 neân giaù trò maät ñoä trong coät
seõ laø ngöôøi/km2.

Ví duï 2: Haõy ñoåi coät ten cuûa baûng cac_tinh thaønh chöõ vieát hoa.

Phaân tích: trong baûng cac_tinh, luùc naïp teân caùc tænh, ngöôøi nhaäp lieäu ñaõ goõ teân caùc
tænh theo kieåu vieát hoa chöõ ñaàu maø thoâi. Giaû söû ta muoán ñoåi teân taát caû caùc tænh trong
tröôøng naøy thaønh daïng chöõ vieát hoa taát caû caùc chöõ, ví duï “Nam Ñònh” thaønh “NAM
ÑÒNH”. Ñaây laø moät tröôøng kieåu chuoãi, neân ta caàn söû duïng moät haøm soá xöû lyù chuoãi ñeå
thöïc hieän ñieàu naøy. Haøm soá caàn ñöôïc söû duïng laø haøm UCase$(str). Caùch thöïc hieän
nhö sau:

- Môû baûng cac_tinh ra neáu chöa môû.

- Töø menu chính choïn Table > Update Column. Hoäp thoaïi Update Column môû ra.

Hình XVII.13. Caäp nhaät coät kieåu kyù töï baèng haøm soá xöû lyù chuoãi.
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- Trong oâ Table to Update ta choïn baûng cac_tinh.

- Trong oâ Column to Update ta choïn coät ten.

- Trong oâ Get Value from Table ta giöõ nguyeân teân baûng cac_tinh.

- Trong oâ Value ta goõ vaøo chuoãi bieåu thöùc sau: UCase$(ten). Trong tröôøng hôïp
chöa thaønh thaïo caùch goõ bieåu thöùc tröïc tieáp, ta coù theå söû duïng nuùt Assist ñeå choïn
haøm naøy töø menu thaû xuoáng Functions, chuyeån con troû chuoät vaøo giöõa daáu ngoaëc
ñôn cuûa haøm soá trong oâ Expression roài naïp teân tröôøng baèng caùch choïn noù töø menu
thaû xuoáng Column.

- Xong choïn OK.

Trong tích taéc taát caû teân caùc tænh ñöôïc ñoåi thaønh chöõ vieát hoa. Bieåu thöùc
UCase$(ten) coù nghóa laø ñoåi taát caû caùc chuoãi (töùc teân caùc tænh) trong tröôøng ten töø
chöõ thöôøng thaønh chöõ hoa. Keát quaû troâng gioáng nhö treân hình XVII.13.

Trong ví duï naøy coù moät ñieåm lyù thuù laø ta ñaõ laáy döõ lieäu trong moät tröôøng (tröôøng
ten), thay ñoåi noù baèng moät haøm soá vaø caäp nhaät laïi chính tröôøng ñoù. Töông töï nhö haøm
soá naøy, ñoäc giaû coù theå thöû caùc haøm chuoãi khaùc nhö haøm LCase(str) (traû moät chuoãi veà
kieåu chöõ thöôøng) hay haøm Proper$(str) (traû moät chuoãi veà caùch vieát hoa ñuùng kieåu - töùc
laø vieát hoa chöõ ñaàu tieân).

Trong tröôøng hôïp nhaäp döõ lieäu daïng chuoãi, caùc haøm naøy khaù tieän lôïi. Ví duï nhö khi
ta phaûi nhaäp moät danh saùch teân chaúng haïn. Muoán vieát hoa chöõ ñaàu tieân, ta phaûi nhaán
phím <Shift>, ñieàu naøy laøm giaûm toác ñoä nhaäp döõ lieäu. Ta chæ caàn goõ taát caû caùc teân baèng
chöõ thöôøng, sau ñoù chæ caàn thöïc hieän leänh caäp nhaät coät baèng haøm Proper$(str) thì teân
seõ ñöôïc ñoåi thaønh chöõ vieát hoa ngay.

Ví duï 3: Haõy tìm xem töøng
thaønh phoá trong lôùp thanh_pho
thuoäc tænh naøo.

Phaân tích: trong tình huoáng
naøy, caùc thaønh phoá laø moät lôùp
baûn ñoà kieåu ñieåm, lôùp caùc tænh laø
moät lôùp baûn ñoà kieåu vuøng. Khi
môû hai lôùp chung vôùi nhau (hình
XVII.14) thì nhìn treân cöûa soå baûn
ñoà ta coù theå bieát ñöôïc thaønh
phoá/thò xaõ ñoù thuoäc tænh naøo. Tuy
nhieân neáu muoán bieát taát caû caùc
thaønh phoá trong lôùp thanh_pho,
moãi ñòa danh thuoäc vaøo tænh naøo
thì neáu laøm baèng tay raát maát thôøi
gian. MapInfo coù khaû naêng giaûi
quyeát baøi toaùn naøy baèng khaû
naêng phaân tích döõ lieäu theo ñòa
lyù. Caùch thöïc hieän nhö sau:

- Môû baûng cac_tinh vaø baûng
thanh_pho ra.

- Töø menu chính choïn Table >

Hình XVII.14. Môû hai lôùp baûn ñoà chung ñeå thaáy
töông quan veà ñòa lyù giöõa chuùng vôùi nhau.
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Maintenance > Table Structure ñeå taïo theâm moät tröôøng môùi cho baûng thanh_pho.
Ñaët teân tröôøng môùi laø tinh (tænh), ñònh daïng kieåu tröôøng laø Character, chieàu daøi laø
trong oâ Width laø 20.

- Xong choïn OK. Baûng thanh_pho ñöôïc ñoùng laïi.

- Môû cöûa soå döõ lieäu cuûa baûng thanh_pho ra baèng leänh Window > New Browser
Window. Ta thaáy tröôøng môùi coù teân laø tinh ñöôïc taïo thaønh.

Ta seõ tieán haønh naïp teân caùc tænh maø töøng thaønh phoá/thò traán naèm trong ñoù vaøo
tröôøng môùi naøy nhö sau:

- Töø menu chính choïn Table > Update Column. Hoäp thoaïi Update Column môû ra.

- Trong oâ Table to Update choïn baûng thanh_pho, trong oâ Column to Update ta choïn
tröôøng tinh môùi taïo, trong oâ Get Value from Table ta choïn baûng cac_tinh, trong oâ
Calculate ta choïn Value trong oâ of ta choïn ten (Hình XVII.15).

Khi choïn baûng cac_tinh laäp töùc oâ Column to Update ñoåi thaønh Add new temporary
Column. Ta seõ baøn tröôøng hôïp naøy sau. Cöù choïn laïi trong oâ naøy laø tröôøng tinh.

- Nhaép chuoät choïn nuùt Join. Hoäp thoaïi Specify Join môû ra.

- Tuyø choïn maëc ñònh laø where ..., ta choïn nhaép chuoät choïn laïi muïc where object from
table cac_tinh, trong menu thaû xuoáng phía döôùi giöõ nguyeân tuyø choïn contains. Caùc
pheùp choïn naøy taïo thaønh moät caâu laø “where object from table cac_tinh contains
object from table thanh_pho” (caùc vaät theå trong baûng cac_tinh chöùa caùc vaät trong
baûng thanh_pho).

- Choïn OK ñeå quay laïi hoäp thoaïi Update Column.

- Choïn OK ñeå keát thuùc leänh caäp nhaät.

Teân cuûa caùc tænh ñöôïc caäp nhaäp vaøo tröôøng tinh cuûa baûng thanh_pho.

Hình XVII.15. Caäp nhaät coät cuûa moät baûng baèng döõ lieäu
cuûa moät coät töø baûng khaùc.
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Nhö vaäy chæ qua vaøi
leänh ngaén ta coù ngay danh
saùch töøng thaønh phoá/thò traán
trong baûng thanh_pho thuoäc
tænh naøo. Leänh caäp nhaät naøy
coù yù nghóa laø baûo MapInfo
xem töøng thaønh phoá/thò traán
naèm trong ranh giôùi tænh naøo
roài laáy giaù trò trong tröôøng
ten cuûa baûng cac_tinh gaùn
vaøo tröôøng tinh cuûa baûng
thanh_pho.

Dó nhieân trong quaù trình
soá hoaù baûng thanh_pho, ta
phaûi chaám ñieåm vò trí caùc
thaønh phoá/thò traán chính

xaùc, neáu chaám sai sang tænh khaùc thì ... “mieãn bình luaän” vì ñöông nhieân MapInfo seõ
tìm tænh cuûa thaønh phoá ñoù sai.

Ví duï treân laø moät minh hoaï cho khaû naêng tìm kieám thoâng tin theo ñòa lyù maø chæ coù
nhöõng phaàn meàm GIS môùi laøm ñöôïc vì tieâu chuaån tìm kieám caõn cöù vaøo toaï ñoä chöù
khoâng döïa vaøo döõ lieäu. Ngoaøi nhöõng ví duï treân, MapInfo coøn coù khaû naêng caäp nhaät caùc
thoâng tin coù tính chaát ñòa lyù töø caùc vaät theå treân cöûa soå baûn ñoà vaøo baûng döõ lieäu nhö
chieàu daøi, dieän tích, toaï ñoä,... Caùc ví duï veà nhöõng tröôøng hôïp naøy ñaõ ñöôïc trình baøy
trong Chöông VII, muïc VII.2.

XVII.3.2.3. Caäp nhaät döõ lieäu vaøo baûng moät caùch taïm thôøi

Trong ví duï 3 ôû treân, ta taïo ra moät tröôøng môùi vaø nhaäp döõ lieäu töø leänh caäp nhaät vaøo
tröôøng ñoù. Nhö vaäy döõ lieäu ñöôïc caäp nhaät trôû thaønh moät phaàn cuûa baûng döõ lieäu neáu ta
thöïc hieän löu baûng ñoù laïi. Tuy nhieân coù khi ta chæ caàn nhaäp döõ lieäu taïm thôøi töø baûng
khaùc vaøo baûng caàn döõ lieäu ñoù ñeå thöïc hieän phaân tích maø thoâi. Trong tröôøng hôïp ñoù khi
choïn caäp nhaät döõ lieäu töø baûng khaùc, MapInfo maëc ñònh choïn moät coät noù töï taïo ra taïm
thôøi vaø trong oâ Column to Update seõ hieän ra doøng chöõ Add to temporary Column (theâm
vaøo coät taïm thôøi). Coät ñoù ñöôïc duøng ñeå chöùa döõ lieäu taïm thôøi khi ta thöïc hieän leänh caäp
nhaät.

Khi döõ lieäu töø baûng nguoàn ñöôïc chuyeån leân coät taïm thôøi thì baát cöù thay ñoåi naøo
trong baûng döõ lieäu nguoàn ñeàu seõ ñöôïc phaûn aùnh qua coät taïm thôøi treân baûng ñöôïc caäp
nhaät. Neáu muoán löu laïi coät taïm thôøi ñoù ta phaûi duøng leänh File > Save Copy As ñeå löu
baûng chöùa coät taïm thôøi thaønh moät baûng môùi. Khi löu thaønh baûng môùi baèng leänh naøy
thì döõ lieäu seõ khoâng coøn thay ñoåi nöõa neáu baûng nguoàn thay ñoåi. Neáu baûng coù chöùa coät
taïm thôøi naèm trong moät taäp tin workspace thì thoâng tin trong coät naøy seõ ñöôïc giöõ trong
taäp tin workspace vaø trong tröôøng hôïp ñoù khi döõ lieäu trong baûng nguoàn thay ñoåi thì laàn
sau môû taäp tin workspace ra döõ lieäu trong coät taïm thôøi ñoù cuõng seõ ñöôïc caäp nhaät.

Khi taïo baûn ñoà chuû ñeà (Thematic map) ta coù theå söû duïng leänh caäp nhaät coät ngay
trong quaù trình taïo baûn ñoà chuû ñeà ñeå laáy döõ lieäu töø baûng khaùc phuïc vuï cho nhu caàu
cuûa ta.

Hình XVII.16. Hoäp thoaïi Specify Join - chæ ñònh
phöông phaùp keát hôïp döõ lieäu giöõa hai baûng.
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XVII.3.2.4. Caùc phöông phaùp toång hôïp döõ lieäu khi Caäp nhaät Coät

Chuùng ta haõy quay laïi hoäp thoaïi Update Column treân hình XVII.15. ÔÛ oâ Calculate,
neáu ta nhaép chuoät vaøo nuùt menu thaû xuoáng thì ngoaøi tuyø choïn Value ra coøn coù nhieàu
tuøy choïn khaùc. Trong quaù trình caäp nhaät coät ñeå laáy döõ lieäu töø moät baûng khaùc, MapInfo
cung caáp cho ta nhieàu phöông phaùp toång hôïp soá lieäu khi caäp nhaät coät, chuùng ñöôïc
lieät keâ trong menu thaû xuoáng cuûa oâ Calculate. Caùc phöông phaùp ñoù nhö sau:
- Average (Giaù trò trung bình): Tính trò trung bình cuûa caùc giaù trò cuûa taát caû caùc baûn

ghi trong moät nhoùm.
- Count (Ñeám): Ñeám soá baûn ghi trong moät nhoùm.
- Minimum (Giaù trò nhoû nhaát): tìm giaù trò nhoû nhaát trong caùc baûn ghi cuûa moät nhoùm.
- Maximum (Giaù trò lôùn nhaát): tìm giaù trò lôùn nhaát trong caùc baûn ghi cuûa moät nhoùm.
- Sum (Toång): Tính toång giaù trò cuûa taát caû caùc baûn ghi trong moät nhoùm.
- Weighted Average (Giaù trò trung bình coù troïng soá): Cho troïng soá cuûa moät giaù trò naøy

cao hôn giaù trò khaùc khi tính trung bình.
- Proprotion Sum (Toång theo tyû leä): Laø pheùp tính toång ñöôïc ñieàu chænh döïa treân chæ

tieâu moät vaät theå naøy coù phaàn chung vôùi moät vaät theå khaùc nhieàu hay ít.
- Proportrion Average (Giaù trò trung bình theo tyû leä): Laø pheùp tính trò trung bình ñöôïc

ñieàu chænh döïa treân chæ tieâu moät vaät theå naøy coù phaàn chung vôùi moät vaät theå khaùc
nhieàu hay ít.

- Proportion Weighted Average (Trò trung bình coù troïng soá theo tyû leä): Laø pheùp tính
trò trung bình coù troïng soá döïa treân chæ tieâu moät vaät theå naøy coù phaàn chung vôùi moät
vaät theå khaùc nhieàu hay ít.

Löu yù raèng caùc phöông phaùp tính trò trung bình, ñeám, giaù trò nhoû nhaát, giaù trò lôùn
nhaát, toång vaø trò trung bình coù troïng soá chæ döïa vaøo döõ lieäu, trong khi ñoù caùc haøm tính
tyû leä (Proportion) coù xeùt ñeán caû moái lieân quan veà ñòa lyù.

XVII.3.3. Nhaäp vaø taùch döõ lieäu khi thay ñoåi caùc vaät theå ñoà hoaï treân baûn ñoà

Ñoái vôùi moät baûng MapInfo coù vaät theå ñoà hoaï vaø coù döõ lieäu, trong nhieàu tröôøng hôïp
ta caàn thöïc hieän söï thay ñoåi treân baûn ñoà. Ñoái vôùi nhöõng leänh töông taùc giöõa caùc vaät
theå treân baûn ñoà nhö Combine, Split, Erase, Erase Outside thì khi thöïc hieän ta cuõng phaûi
xem xeùt caùch xöû lyù döõ lieäu nhö theá naøo. MapInfo cho pheùp ta choïn moät soá phöông aùn
ñeå xöû lyù döõ lieäu khi thöïc hieän caùc leänh treân.

XVII.3.3.1. Nhaäp döõ lieäu trong leänh Combine

Nhö ñaõ bieát, Combine laø leänh goäp hai hay nhieàu vaät theå cuøng kieåu laïi thaønh moät.
Khi thöïc hieän leänh Combine trong moät baûng, MapInfo hieån thò hoäp thoaïi Data
Aggregation ñeå cho ta choïn caùch xöû lyù döõ lieäu cho vaät theå goäp ñöôïc taïo thaønh. Hoäp
thoaïi naøy (hình XVII.17) bao goàm caùc noäi dung sau:

- Phaàn treân cuûa hoäp thoaïi naøy bao goàm 3 coät:
+ Destination: lieät keâ taát caû caùc tröôøng coù trong baûng coù caùc vaät theå caàn goäp.
+ Method: ñeå chæ ñònh phöông phaùp goäp döõ lieäu cho töøng tröôøng töông öùng beân

coät Destination. Ñoái vôùi tröôøng kieåu soá, phöông phaùp maëc ñònh laø Sum (tính
toång), ñoái vôùi tröôøng kieåu kyù töï, ngaøy thaùng, luaân lyù, phöông phaùp maëc ñònh laø
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Value (laáy giaù trò).
+ Weight by: chæ hieån thò khi naøo choïn phöông phaùp goäp döõ lieäu laø Average (xem

tieáp phaàn döôùi).

- Phaàn Aggregation Method: chæ ñònh phöông phaùp goäp döõ lieäu cho töøng tröôøng ñöïôc
choïn ôû treân. Khi choïn moät tröôøng trong oâ danh saùch tröôøng ôû treân ta phaûi choïn
phöông phaùp goäp döõ lieäu trong phaàn Aggregation Method naøy. Phöông phaùp goäp
döõ lieäu bao goàm;
+ Blank: boû troáng, coù nghóa laø khi goäp vaät theå, tröôøng ñöôïc choïn seõ bò boû troáng,

khoâng chöùa döõ lieäu.

+ Sum: tính toång, döõ lieäu chöùa trong tröôøng ñöôïc choïn ôû treân seõ ñöôïc naïp giaù trò
laø toång caùc giaù trò cuûa caùc vaät theå ñöôïc choïn. Tuyø choïn naøy chæ aùp duïng cho caùc
tröôøng kieåu soá.

+ Value: laáy giaù trò. Giaù trò naïp vaøo laø moät trong nhöõng giaù trò cuûa caùc vaät theå ñöôïc
choïn.

+ Average: tính trung bình, giaù trò naïp vaøo laø trung bình caùc giaù trò cuûa caùc vaät theå
ñöôïc choïn. Khi choïn Average, ta coù theâm moät tuyø choïn nöõa laø Weight by. Tuyø
choïn maëc ñònh trong oâ Weight by laø none (khoâng tính troïng soá). Tuyø choïn naøy
coù nghóa laø khi tính giaù trò trung bình, MapInfo seõ xem xeùt troïng soá (weight) theo
moät tieâu chuaån naøo ñoù. OÂ naøy lieät keâ taát caû caùc tröôøng kieåu soá vaø coù theâm tuyø
choïn laø Area (dieän tích). Trong caùch tính trung bình thoâng thöôøng, giaù trò trung
bình laø toång caùc giaù trò caù theå chia cho soá löôïng caù theå. Khi tính troïng soá theo
moät tieâu chuaån naøo ñoù thì giaù trò cuûa caù theå naøo lôùn hôn seõ coù phaàn aûnh höôûng
(troïng soá) trong trò trung bình cao hôn. Neáu thöïc hieän leänh nhaäp vaät theå kieåu
ñöôøng, khoâng ñöôïc söû duïng tuyø choïn Weight by laø Area vì vaät theå kieåu ñöôøng

Hình XVII.17. Hoäp thoaïi Data Aggregation - nhaäp döõ lieäu.
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khoâng coù dieän tích.

- Döôùi cuøng laø tuyø choïn No Data. Neáu ñaùnh daáu choïn vaøo oâ naøy thì caùc vaät theå khi
ñöôïc nhaäp laïi thaønh moät seõ khoâng chöùa döõ lieäu trong tröôøng naøo caû.

Ta seõ xeùt moät ví duï ñôn giaûn döôùi ñaây ñeå minh hoaï. Coù hai tænh trong baûng cac_tinh
laø Höng Yeân vaø Haûi Döông. Giaû söû ta muoán nhaäp hai tænh naøy laïi thaønh moät laø tænh môùi
Haûi Höng. Löu yù raèng ñaây chæ laø ví duï, khoâng coù thöïc. Caùch thöïc hieän (xem laïi hình
XVII.17) nhö sau:

- Môû baûng cac_tinh ra.

- Choïn Map > Layer Control ñeå vaøo hoäp thoaïi Layer Control vaø ñaùnh daáu vaøo coät

chænh söûa ôû lôùp cac_tinh.

- Duøng coâng cuï choïn vaø giöõ phím <Shift> nhaép chuoät choïn hai tænh naøy.

- Töø menu chính choïn Objects > Combine. Hoäp thoaïi Data Aggregation môû ra.

- Nhaép chuoät choïn tröôøng ten, ta thaáy trong oâ Value ôû döôùi laø teân Höûng Yeoõn (Höng
Yeân). Ta muoán teân cuûa tænh môùi ñöôïc nhaäp vaøo laø “Haûi Höng” neân ta seõ goõ laïi vaøo
oâ Value naøy chöõ Haûi Höng (Hayûi Höûng).

- Nhaép chuoät choïn tröôøng chu_vi. Phöông phaùp nhaäp döõ lieäu maêc ñònh cuûa tröôøng
naøy laø laáy toång (Sum). Chu vi cuûa tænh môùi baèng toång chu vi hai tænh naèm saùt nhau
(coù ranh giôùi chung) laø khoâng ñuùng. Chu vi cuûa tænh môùi baèng toång chu vi hai tænh
tröø ñi ñöôøng ranh giôùi chung giöõa hai tænh. Vì vaäy chu vi cuûa tænh môùi phaûi tính laïi,
do vaäy trong phöông phaùp goäp giöõ lieäu ta seõ choïn Blank (boû troáng).

- Nhaép chuoät choïn tröôøng dien_tich. Phöông phaùp nhaäp döõ lieäu maëc ñònh laø toång
(Sum). Dieän tích tænh môùi baèng toång hai dieän tích laø ñuùng vì vaäy ta giöõ nguyeân tuyø
choïn laø Sum.

- Nhaép chuoät choïn tröôøng dan_so. Töông töï nhö treân, daân soá tænh môùi baèng toång daân
soá hai tænh neân tuyø choïn Sum laø ñuùng vaø ñöôïc giöõ nguyeân.

- Nhaép chuoät choïn tröôøng Mien (mieàn). Ta ñaõ quy öôùc mieàn Baéc laø soá 1 vaø hai tænh
naøy ñeàu coù giaù trò 1 trong tröôøng naøy, vaäy tænh môùi ñöôïc taïo thaønh seõ laø soá 1. Vì vaäy
ta choïn tuyø choïn nhaäp döõ lieäu laø Value. Giaù trò maëc ñònh hieän ra laø 1, ñuùng neân ta
giöõ nguyeân.

- Nhaép chuoät choïn tröôøng mat_do. Tuyø choïn maëc ñònh nhaäp döõ lieäu ôû döôùi cuõng laø
Sum. Ñieàu naøy khoâng ñuùng vì maät ñoä cuûa tænh môùi khoâng phaûi baèng toång hai maät
ñoä maø seõ baèng trò trung bình vì vaäy ta phaûi choïn Average trong phaàn Aggregation
Method. Luùc naøy tuyø choïn maëc ñònh trong oâ Weight by laø none. Ta coù theå choïn tính
trung bình coù troïng soá theo dieän tích chaúng haïn, vì theá giaû söû ta choïn trong danh
saùch thaû xuoáng tieâu chuaån tính troïng soá laø tröôøng dien_tich.

- Nhaép chuoät choïn OK ñeå keát thuùc. Vaäy ta ñaõ goäp hai tænh laïi thaønh moät vôùi caùc giaù
trò trong caùc tröôøng cuûa tænh môùi nhö sau:

+ ten : Haûi Höng
+ chu_vi : boû troáng ñeå tính laïi
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+ dien_tich : baèng toång dieän tích hai tænh
+ dan_so : baèng toång daân soá hai tænh
+ Mien : 1 (quy öôùc cuûa Mieàn Baéc)
+ mat_do : trung bình maät ñoä daân soá cuûa hai tænh, laáy troïng soá theo dieän tích.

Nhö vaäy coù theå thaáy raèng khi tieán haønh goäp hai hay nhieàu vaät theå trong moät baûng
MapInfo baèng leänh Combine, döõ lieäu ñöôïc xöû lyù nhö theá naøo hoaøn toaøn phuï thuoäc vaøo
baûn chaát cuûa döõ lieäu ñoù vaø ngöôøi duøng phaûi töï quyeát ñònh phöông phaùp xöû lyù döõ lieäu
naøo laø phuø hôïp cho töøng tröôøng moät.

Trong ví duï treân caùc tröôøng dien_tich, dan_so ñöôïc aùp duïng phöông phaùp nhaäp döõ
lieäu gioáng nhau (tính toång). Trong tröôøng hôïp nhö vaäy, coù theå laøm nhanh baèng caùch
giöõ phím <Ctrl> vaø choïn caùc tröôøng coù phöông phaùp nhaäp döõ lieäu gioáng nhau ñeå choïn
caùch nhaäp döõ lieäu moät laàn cho taát caû caùc tröôøng ñöôïc choïn.

Khi thöïc hieän leänh Combine neáu moät vaät theå (vaø chæ moät maø thoâi) ñöôïc thieát laäp laø
muïc tieâu (choïn vaät theå ñoù vaø thöïc hieän leänh Objects > Set Target) thì hoäp thoaïi Data
Aggregation hieän ra hôi khaùc moät chuùt. ÔÛ phaàn Aggregation Method, thay vì tuyø choïn
Blank thì ta seõ coù tuyø choïn No Change. Neáu ta choïn moät tröôøng naøo ñoù roài choïn No
Change, thì giaù trò trong tröôøng ñoù seõ laø giaù trò cuûa vaät theå ñöôïc thieát laäp laø muïc tieâu.
Trong tröôøng hôïp choïn moät vaät theå vaø thieát laäp noù laø muïc tieâu thì ta coù theå nhaäp caùc
vaät theå töø moät baûng khaùc vaøo baûng coù chöùa vaät theå ñang ñöôïc thieát laäp laø muïc tieâu.

XVII.3.3.2. Taùch döõ lieäu trong caùc leänh Split, Erase vaø Erase Outside
Khi thöïc hieän caùc leänh Split (caét), Erase (xoaù) vaø Erase Outside (xoaù phaàn naèm

ngoaøi) treân caùc vaät theå trong moät baûng MapInfo, hoäp thoaïi Data Disaggregation (taùch
döõ lieäu) (hình XVII.18) cuõng hieän ra ñeå ta choïn phöông phaùp taùch döõ lieäu trong töøng
tröôøng. Xin nhaéc laïi laø ñeå thöïc hieän ñöôïc
caùc leänh treân, moät hay nhieàu vaät theå phaûi
ñöôïc thieát laäp laø muïc tieâu tröôùc ñoù baèng
leänh Objects > Set Target.

Phaàn treân cuûa hoäp thoaïi naøy töông töï
nhö hoäp thoaïi nhaäp döõ lieäu, noù lieät keâ caùc
tröôøng cuûa (caùc) vaät theå ñöôïc thieát laäp laø
muïc tieâu. Döôùi cuøng cuõng coù tuyø choïn
No Data ñeå caét vaät theå vaø khoâng naïp döõ
lieäu vaøo tröôøng naøo caû.

Trong phaàn Disaggregation Method,
ta coù 3 tuyø choïn;

+ Blank: töông töï nhö phaàn nhaäp döõ lieäu,
tröôøng ñöôïc choïn khi taùch hay xoaù vaät
theå seõ khoâng chöùa döõ lieäu.

+ Value: tröôøng ñöôïc choïn seõ chöùa giaù trò
cuûa vaät theå ñöôïc thieát laäp laø muïc tieâu, coù
nghóa laø giaû söû ta thöïc hieän leänh caét
(Split) moät tænh ra laøm hai, neáu trong
tröôøng ten ta choïn phöông phaùp taùch döõ
lieäu laø Value thì phaàn bò caét ra seõ coù cuøng

Hình XVII.18. Hoäp thoaïi Data
Disaggregation - Taùch döõ lieäu.
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teân vôùi tænh goác.

+ Area Proportion: tuyø choïn naøy chæ aùp duïng cho caùc vaät theå kieåu vuøng. Neáu duøng tuyø
choïn naøy thì trong tröôøng ñöôïc choïn, giaù trò döõ lieäu cuûa caùc vaät theå bò caét ra seõ tyû leä
vôùi dieän tích cuûa caùc vuøng ñöôïc caét ra. Ví duï nhö neáu ta caét moät tænh ra laøm hai phaàn,
moät phaàn coù dieän tích gaáp ñoâi phaàn kia thì khi choïn phöông phaùp Area Proportion cho
tröôøng dan_so thì daân soá trong tænh goác seõ ñöôïc chia laøm 3 phaàn, phaàn coù dieän tích
lôùn hôn seõ coù 2/3 daân soá vaø phaàn caét ra nhoû hôn seõ coù 1/3 daân soá.
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